Bug 256023 - Cannot work with Sigma-RAW-files (X3F)
Summary: Cannot work with Sigma-RAW-files (X3F)
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-DImg-RAW (show other bugs)
Version: 1.5.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 09:16 UTC by Michael
Modified: 2012-06-27 10:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2010-11-04 09:16:00 UTC
Version:           1.5.0 (using KDE 4.5.2) 
OS:                Linux

Digikam 1.5 cannot view Sigma-Raw-Files. Version 1.2 could do this without any problems. I posted this in the german forum linuxforen.de. Other users have the same problem. My digikam-version 1.5 is originally from OpenSuSE11.3 without any changes. When opening the program the preview cannot be shown, there are only the symbolic icons and when clicking to a picture there is the german message "Das Vorschaubild für XXXXX.X3F kann nicht angezeigt werden", in english "The previewpicture for XXXXX.X3F cannot be shown". As in version 1.2 of digikam this problem didn't exist, I hope, that this is an error, who can be eliminated.

Reproducible: Always

Steps to Reproduce:
Happens always, when I click to a picture-icon.

Actual Results:  
The error-message from above

Expected Results:  
I expect, that digikam1.5 shows and works with the raw-files, as in version 1.2

OS: Linux (i686) release 2.6.34.7-0.5-default
Compiler: gcc
Comment 1 caulier.gilles 2010-11-04 10:05:31 UTC
Michael,

See below a private email thread about Sigma RAW file support:

//-----------------------------------------------------------------------------

RAW files and conversions for ...Sigma SD10
3 messages
Janox <janox@tiscali.it> 28 août 2010 10:15
À: caulier.gilles@gmail.com
Hello,
After downloading and using the last version of Digikam, I have to thank you for your
great work, this software is really wonderful, now I can abandone Windows!
In order to help your team to develope the next releases of Digikam, I send you via ftp
some RAW files of my camera (Sigma SD10), even if Foveon sensor is no longer
supported [ :-( ].
You'll find (at ftp sit e zeus.serveft p.net) the
following files :
- Sigma RAW files (.X3F)
- JPG converted by Sigma Photo Pro 4.0 (X3F setting, no any adjustment)
- JPG converded by LightRoom -Win32- Trial version (no any adjustment)
(I placed in each photos star marks (3star), some tags, IPTC data, just to evaluate the import function)
- .XPM files by Lightroom with additional data.
My best regards for this project, it's so admirable your team produce a package better than commercial software, and with a constant improving! BRAVO!
Mario

Gilles Caulier < caulier.gilles@gmail.com> 28 août 2010 11:22
À: Janox <janox@tis cali.it>, Alex Tutubalin <lexa@lexa.ru>
Janox,
To proces s RAW files, digiKam us e libraw.
http://www.libraw.org
Since 0.9.x releas e (if i remember) libraw author (Alex Tutubalin)
have removed Foveon support from the implementation, about
incompatibility of license of this code taken from dcraw.
I recommend to as k to Alex directly for more information about. I s et
him in CC from this mail.
All the best
Gilles Caulier

Alex Tutubalin < lexa@lexa.ru> 28 août 2010 12:37
À: Janox <janox@tiscali.it>
Cc: Gilles Caulier <caulier.gilles@gmail.com>
Hello Mario!
Yes , Gilles is right, the Foveon sensor is unsupported by LibRaw because of two causes :
- there is no way to get good color from this s ens or. Ever Sigma own software produces very strange
colors from these cameras (and, sure, different versions of Sigma s/w produces very different colors
from the same shot of ColorChecker table).
- the Foveon parser code (part of Dave Coffin's dcraw.c program) is GPL licensed. Our library (LibRaw)
has more liberal license since version 0.9, so no way to use this code and no format information from
Foveon/Sigma to make our own parser. All other dcraw.c code has very liberal license, so no problem
with other (Bayer sensor) cameras .
So, we decided to drop Foveon support. Sorry.
Alex Tutubalin, LibRaw team.

//-----------------------------------------------------------------------------
Comment 2 caulier.gilles 2010-11-30 14:04:32 UTC
Michael,

Alex work on new Libraw 0.12 with the capabilty to plug demosaicing modules. X3F (Sigma) support will be added with this release.

I will try to backport libraw 0.12 in libkdcraw from KDE 4.5 and next 4.6, but i'm not yet sure is binary compatibility will be respected. This is a rule from KDE project.

Anyway, the next libkdcraw coming with KDE 4.7 will have X3F support. Code is in developement in a separate branch. It will be avaialble in KDE core after KDE 4.6 release date (january 2011)

Gilles Caulier
Comment 3 caulier.gilles 2010-12-06 09:44:35 UTC
With new libraw 0.12-beta3, X3F support have been added to libkdcraw.

This new version will be avaialble with KDE 4.7 (perhaps 4.6 if libraw 0.12 will be stable before KDE 4.6 release date)

This file can be closed now...

Gilles Caulier
Comment 4 caulier.gilles 2010-12-06 09:53:23 UTC
The proof :

http://www.flickr.com/photos/digikam/5237007527/

Gilles Caulier