Bug 255975 - Slowdowns and flickerings in fullscreen applications by incoming notification
Summary: Slowdowns and flickerings in fullscreen applications by incoming notification
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-03 16:31 UTC by Fabian B.
Modified: 2010-11-15 18:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian B. 2010-11-03 16:31:16 UTC
Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

Same thing on the Netbook (Intel 4500) and Notebook (AMD radeon1400). when i play a game like Neverwinter Nights in fullscreen mode and there is an incoming messege in Kopete or kmail or any other messege that let popup a notification, the game slows extremely down und starts to flicker. The same in dragonplayer. im watch a video and flicker flicker. i think it would be better is the notifications where disabled if there is a application i a fullscreen mode (not maximized, real fullscreen)

Reproducible: Always

Steps to Reproduce:
starts kopete and a video in fullscreen, watch and wait for a notification

Actual Results:  
the videooutput gets curupted and starts to flicker

Expected Results:  
it should disabled for the time the programm run fullscreen

there is no real diffret if i run with or without compositing
Comment 1 Beat Wolf 2010-11-15 17:43:45 UTC
this could be a kwin problem, not sure. please reasign back to plasma if not true.
Comment 2 Martin Flöser 2010-11-15 18:53:04 UTC
Disable unredirect fullscreen windows, though this gives a performance penality for watching videos.

*** This bug has been marked as a duplicate of bug 177495 ***