Bug 255945 - Crash after resume and changing location (new network)
Summary: Crash after resume and changing location (new network)
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-03 09:45 UTC by Bruno Friedmann
Modified: 2010-11-08 23:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2010-11-03 09:45:32 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.36-rc4-16-desktop x86_64
Distribution: "openSUSE 11.4 Milestone 2 of 6 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: KDE lead to this crash after having suspended the computer on one network with attached external monitor, keyboard and mouse.
When I wake up the laptop, connected on a new location network, without external keyboard, and mouse. I get this crash just after unlocking the session.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Démon de KDE (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f4853b65959 in QMetaObject::cast (this=0x7f4838c76940, obj=0xf078b0) at kernel/qmetaobject.cpp:266
#8  0x00007f4838ee779a in qobject_cast<Knm::InterfaceConnection const*> (first=0xf078b0, second=0x103ff30) at /usr/include/QtCore/qobject.h:468
#9  activatableLessThan (first=0xf078b0, second=0x103ff30) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#10 0x00007f4838ee8293 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=@0xd13e78, lessThan=0x7f4838ee7730 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:358
#11 0x00007f4838ee7b48 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#13 0x00007f4838ed8943 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:144
#14 0x00007f4838ed4308 in ActivatableList::qt_metacall (this=0x91c640, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd0eeb240) at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:74
#15 0x00007f4853b74c6f in QMetaObject::activate (sender=0xcfbde0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#16 0x00007f4838a65341 in Knm::InterfaceConnection::setActivationState (this=0xcfbde0, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#17 0x00007f4838caf12d in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0xd47090, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#18 0x00007f4838caf159 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0xd47090, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#19 0x00007f4838cb1297 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#20 0x00007f4838cafa96 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#21 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#22 0x00007f4838c86eb0 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x9add10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd0eeb400) at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#23 0x00007f4853b74c6f in QMetaObject::activate (sender=0x9853b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd0eeb400) at kernel/qobject.cpp:3272
#24 0x00007f483a82a7ae in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:100
#25 0x00007f483a82a9c3 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x9853b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd0eeb550) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:83
#26 0x00007f483a82ad90 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x9853b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd0eeb550) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager_p.moc:76
#27 0x00007f4853b74c6f in QMetaObject::activate (sender=0x990420, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd0eeb550) at kernel/qobject.cpp:3272
#28 0x00007f483a406b4e in Solid::Control::Ifaces::NetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/ifaces/networkmanager.moc:108
#29 0x00007f483819e30b in NMNetworkManager::qt_metacall (this=0x990420, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd0eeb6b0) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/manager.moc:97
#30 0x00007f4853b74c6f in QMetaObject::activate (sender=0x985940, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd0eeb6b0) at kernel/qobject.cpp:3272
#31 0x00007f4838195b81 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:176
#32 0x00007f483819a566 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x985940, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fffd0eeb8e0) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#33 0x00007f4850f77d28 in QDBusConnectionPrivate::deliverCall (this=0x86a220, object=0x985940, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#34 0x00007f4850f82def in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#35 0x00007f4853b738ea in QObject::event (this=0x985940, e=<value optimized out>) at kernel/qobject.cpp:1211
#36 0x00007f4852d15f64 in QApplicationPrivate::notify_helper (this=0x6ea6a0, receiver=0x985940, e=0xbf5e50) at kernel/qapplication.cpp:4396
#37 0x00007f4852d1e38a in QApplication::notify (this=<value optimized out>, receiver=0x985940, e=0xbf5e50) at kernel/qapplication.cpp:4277
#38 0x00007f48547d9446 in KApplication::notify (this=0x7fffd0eec3c0, receiver=0x985940, event=0xbf5e50) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#39 0x00007f4853b5fa9c in QCoreApplication::notifyInternal (this=0x7fffd0eec3c0, receiver=0x985940, event=0xbf5e50) at kernel/qcoreapplication.cpp:732
#40 0x00007f4853b63245 in sendEvent (receiver=0x0, event_type=0, data=0x60f3e0) at kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f3e0) at kernel/qcoreapplication.cpp:1373
#42 0x00007f4853b8a603 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#44 0x00007f484f6b86e3 in g_main_dispatch (context=0x6ed120) at gmain.c:2149
#45 g_main_context_dispatch (context=0x6ed120) at gmain.c:2702
#46 0x00007f484f6b8ec0 in g_main_context_iterate (context=0x6ed120, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#47 0x00007f484f6b9160 in g_main_context_iteration (context=0x6ed120, may_block=1) at gmain.c:2843
#48 0x00007f4853b8a79f in QEventDispatcherGlib::processEvents (this=0x616cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#49 0x00007f4852db9e1e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x00007f4853b5eed2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#51 0x00007f4853b5f0e5 in QEventLoop::exec (this=0x7fffd0eec310, flags=...) at kernel/qeventloop.cpp:201
#52 0x00007f4853b634fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#53 0x00007f4844324657 in kdemain (argc=1, argv=0x6bc2c0) at /usr/src/debug/kdelibs-4.5.2/kded/kded.cpp:894
#54 0x00000000004074f9 in launch (argc=1, _name=0x40b3bb "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b257 "0") at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:723
#55 0x0000000000409d0a in main (argc=4, argv=0x7fffd0eed3b8, envp=0x7fffd0eed3e0) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:06:43 UTC

*** This bug has been marked as a duplicate of bug 210878 ***