Bug 255743 - Plasma keeps crashing
Summary: Plasma keeps crashing
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-31 15:19 UTC by Andrei Sebastian Cimpean
Modified: 2010-10-31 15:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Sebastian Cimpean 2010-10-31 15:19:14 UTC
Application: kwin (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
After I installed some new widgets on the desktop and rebooted the computer, everytime i try to login into the kde system it crashes continuosly.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fd6dafac194 in SharedMemory::removeEntry (this=0x7fd6beccf000, index=2181) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1160
#7  0x00007fd6db04592f in KSharedDataCache::insert (this=<value optimized out>, key=..., data=...) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1269
#8  0x00007fd6dd9db1bd in KImageCache::insertImage (this=0x7cb4b0, key=..., image=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:86
#9  0x00007fd6ddaeb696 in KImageCache::insertPixmap (this=0x7cb4b0, key=..., pixmap=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:105
#10 0x00007fd6dd505f35 in Plasma::ThemePrivate::scheduledCacheUpdate (this=0x7d0380) at /usr/src/debug/kdelibs-4.5.2/plasma/theme.cpp:275
#11 0x00007fd6dd5080d2 in Plasma::Theme::qt_metacall (this=0x7db6f0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x7fff950469f0) at /usr/src/debug/kdelibs-4.5.2/build/plasma/theme.moc:119
#12 0x00007fd6da8d5b5f in QMetaObject::activate (sender=0x7cc5d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#13 0x00007fd6da8d4509 in QObject::event (this=0x7cc5d0, e=<value optimized out>) at kernel/qobject.cpp:1175
#14 0x00007fd6d9a66f34 in QApplicationPrivate::notify_helper (this=0x630e00, receiver=0x7cc5d0, e=0x7fff95047190) at kernel/qapplication.cpp:4396
#15 0x00007fd6d9a6f35a in QApplication::notify (this=<value optimized out>, receiver=0x7cc5d0, e=0x7fff95047190) at kernel/qapplication.cpp:4277
#16 0x00007fd6dd9c2826 in KApplication::notify (this=0x7fff95047620, receiver=0x7cc5d0, event=0x7fff95047190) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#17 0x00007fd6da8c09dc in QCoreApplication::notifyInternal (this=0x7fff95047620, receiver=0x7cc5d0, event=0x7fff95047190) at kernel/qcoreapplication.cpp:732
#18 0x00007fd6da8ee189 in sendEvent (this=0x631810) at kernel/qcoreapplication.h:215
#19 QTimerInfoList::activateTimers (this=0x631810) at kernel/qeventdispatcher_unix.cpp:617
#20 0x00007fd6da8ee820 in QEventDispatcherUNIX::processEvents (this=0x60e540, flags=...) at kernel/qeventdispatcher_unix.cpp:938
#21 0x00007fd6d9b0bd0c in QEventDispatcherX11::processEvents (this=0x60e540, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#22 0x00007fd6da8bfe12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007fd6da8c0025 in QEventLoop::exec (this=0x7fff95047560, flags=...) at kernel/qeventloop.cpp:201
#24 0x00007fd6da8c443b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#25 0x00007fd6de288ba4 in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#26 0x00007fd6dde7cb7d in __libc_start_main () from /lib64/libc.so.6
#27 0x0000000000400699 in _start ()

This bug may be a duplicate of or related to bug 253795.

Possible duplicates by query: bug 254625, bug 253795.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-31 15:26:58 UTC

*** This bug has been marked as a duplicate of bug 253795 ***