Bug 255551 - KWin and Plasma crashing during relogin after using dual display
Summary: KWin and Plasma crashing during relogin after using dual display
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 23:56 UTC by Jinesh
Modified: 2010-10-31 16:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jinesh 2010-10-28 23:56:07 UTC
Version:           unspecified (using KDE 4.5.2) 
OS:                Linux


Hi,

I am using KDE 4.5.2 on OpenSUSE 11.3 x86_64 and what I notice is that whenever I use a dual display and then reboot the system, during the next login, both KWin as well as Plasma are crashing very frequently.

The only way to fix this problem is to remove the directory /var/tmp/kdecache-<username> .



Reproducible: Always

Steps to Reproduce:

1. Get a system with two displays
2. Login to KDE desktop
3. Use systemsettings tool and configure display (side-by-side) on these displays.
4. Power off your system
5. Disconnect the second monitor
6. Power on your system
7. Login to your KDE desktop once again



Actual Results:  

KWin and Plasma keeps crashing very frequently. 

Expected Results:  

KWin and Plasma should not crash.


I am using a laptop with the LVDS display (left side) and VGA monitor (right side) connected to it. LVDS resolution is 1366x768 and the VGA resolution is 1280x1024. I have already tried disabling compositing, but the problem still persists.
Comment 1 Christoph Feck 2010-10-29 00:19:44 UTC
This is probably bug 253795 (should be fixed in the soon-to-be-released 4.5.3 version), but to be sure we need a backtrace.

For more information, see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 2 Jinesh 2010-10-30 05:43:26 UTC
I do not think this is the same bug as the one mentioned by you because this problem happens if and only if I use dual displays. Below is the crash backtrace :


Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd913668760 (LWP 2748))]

Thread 3 (Thread 0x7fd8f1511710 (LWP 2774)):
#0  0x00007fd911fe7709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd912271f12 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fd912267d28 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007fd9122718be in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fd911fe2a4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007fd910da282d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd8ea408710 (LWP 2828)):
#0  0x00007fd911fe7709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd912271f12 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fd912267d28 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007fd9122718be in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007fd911fe2a4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007fd910da282d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd913668760 (LWP 2748)):
[KCrash Handler]
#6  0x00007fd9127d2bb4 in ?? () from /usr/lib64/libkdecore.so.5
#7  0x00007fd91286892f in KSharedDataCache::insert(QString const&, QByteArray const&) () from /usr/lib64/libkdecore.so.5
#8  0x00007fd9130011dd in KImageCache::insertImage(QString const&, QImage const&) () from /usr/lib64/libkdeui.so.5
#9  0x00007fd913111236 in KImageCache::insertPixmap(QString const&, QPixmap const&) () from /usr/lib64/libkdeui.so.5
#10 0x00007fd909b23f35 in ?? () from /usr/lib64/libplasma.so.3
#11 0x00007fd909b260d2 in Plasma::Theme::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libplasma.so.3
#12 0x00007fd912371b5f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#13 0x00007fd912370509 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#14 0x00007fd911502f34 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#15 0x00007fd91150b35a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x00007fd912fe8846 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#17 0x00007fd91235c9dc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#18 0x00007fd91238a189 in ?? () from /usr/lib64/libQtCore.so.4
#19 0x00007fd912386f58 in ?? () from /usr/lib64/libQtCore.so.4
#20 0x00007fd90dea6a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fd90dea7270 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fd90dea7510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fd9123875ff in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#24 0x00007fd9115a6eee in ?? () from /usr/lib64/libQtGui.so.4
#25 0x00007fd91235be12 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#26 0x00007fd91235c025 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#27 0x00007fd91236043b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#28 0x00007fd904404c7b in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#29 0x0000000000407509 in _start ()
Comment 3 Christoph Feck 2010-10-30 13:54:37 UTC
Thanks for the update. While bug 253795 does not mention dual screens, it is same backtrace.

*** This bug has been marked as a duplicate of bug 253795 ***
Comment 4 Jinesh 2010-10-31 16:17:26 UTC
Thank you.