Bug 255329 - When I try to assign the "Calculator" key to "kcalc", shows as "Launch (1)" and doesn't work
Summary: When I try to assign the "Calculator" key to "kcalc", shows as "Launch (1)" a...
Status: RESOLVED DUPLICATE of bug 263109
Alias: None
Product: kmenuedit
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
Depends on:
Reported: 2010-10-26 17:33 UTC by Darin McBride
Modified: 2012-02-18 14:03 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Darin McBride 2010-10-26 17:33:01 UTC
Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

Having set my "Calculator" key via xmodmap to "XF86Calculator", and tested that it comes back as such via "xev", I try to set this key to launch kcalc.  When I go into the menu editor, I click on the "Current shortcut key" button, and hit the caculator key.  It registers the key as "Launch (1)" for some reason I don't understand, which seems strange, but wasn't immediately an issue, since I figured that whatever the key name, it'd be the same throughout, so I could use the key to launch the application later.  However, pressing the calculator key after saving and closing the menu editor does not seem to respond with anything.

Looking at the ~/.xsession-errors file, the only line that gets output when I press the key is:

Fetched layout groups from X server:    layouts: ("us")         variants: ("") 

Reproducible: Always

Using a Microsoft Natural Ergonomic Keyboard 4000.  This has worked in the past with different levels of KDE4 / Xorg, though I'm not sure exactly where.  I am starting with KDE because xev is showing the correct key being registered with the correct name.
Comment 1 Romain Henriet 2010-11-01 11:04:19 UTC
I confirm this bug. 
I use OpenSuse 11.3 with KDE 4.5.2. My keyboard is Logitech EX110.

This worked in the past with kde 4 for me too.
Comment 2 Dave Lyon 2011-03-16 11:57:00 UTC
I also had this bug in openSUSE 11.4 with KDE 4.6 with a Logitech K520. Assigning the hotkey showed "Launch (1)" as the assigned key.

I was able to resolve it using the tips at https://bbs.archlinux.org/viewtopic.php?pid=837944 which suggested:

"I searched for the string "Launch (1)" recursively in my directory ~/.kde  and found it in the files


In both files I had to replace "Launch (1)" with "Calculator". Oddly enough I had to replace it with "Calculator", though the terminal application xev actually indicates the name "XF86Calculator" for that key.

Afterwards you have to reboot, then your special calculator key should work."

After changing mine to be 'Calculator' instead of 'Launch (1)' it worked too.
Comment 3 Aleksander Mierzwicki 2011-05-05 13:32:53 UTC
I confirm that on debian wheezy, kde 4.4.5. My keyboard is Microsoft Natural Ergonomic Keyboard 4000.

Workaround given by Dave Lyon works fine.
Comment 4 Marc Payne 2011-07-02 16:57:28 UTC
Another confirmation here with KDE 4.7 RC1 on Arch Linux x86_64 with a Microsoft Comfort Curve Keyboard 2000.

Workaround by Dave Lyon works.
Comment 5 Alassane 2011-07-21 08:22:54 UTC
I can also confirm this on kde 4.7 RC2. And the workaround works too.
Comment 6 Darin McBride 2011-08-12 23:26:49 UTC
ugh... I thought I could change the status to verify the fix. I guess not. I'll leave alone now, sorry :-(
Comment 7 Christian Trippe 2011-11-05 05:17:19 UTC
Why was this bug closed? Itis not fixed only a workaround is available, please reopen it.
Comment 8 Malvern Star 2011-11-07 06:08:32 UTC
Please re-open this bug.  It is not fixed.  I have submitted a report for openSuSE 12.1 here: https://bugzilla.novell.com/show_bug.cgi?id=726550
Comment 9 Christoph Feck 2012-02-18 14:03:38 UTC
Looks like it worked for the reporter, but not for anyone else. The issue is now tracked at bug 263109, it isn't a kmenuedit problem to begin with.

*** This bug has been marked as a duplicate of bug 263109 ***