Bug 254976 - There is no way to open new identical session in a tab with menu (Shortcut is working fine)
Summary: There is no way to open new identical session in a tab with menu (Shortcut is...
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.2
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-22 18:22 UTC by Vladislav Bogdanov
Modified: 2012-02-10 18:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav Bogdanov 2010-10-22 18:22:17 UTC
Version:           2.5.2 (using KDE 4.5.2) 
OS:                Linux

It became impossible (starting with 4.5.0) to run new identical session in a new tab using menu navigation. "New window" menu item opens such session, but there is no way to select "New Tab" because it was transformed into a submenu with list of preconfigured profiles.
I use .desktop shortcuts to open sessions to remote hosts with ssh. Before 4.5.0 I was able to press New Tab menu item to open new session to host. Now I'm not.
Ctrl-Shift-T keyboard shortcut works just fine, but Ctrl-Shift is often used to switch keyboard layout (and most people are unwilling to change their habits), so this do not work either (and only recent versions of Xorg provide separate LShift-LCtrl and RShift-RCtrl for layout switch).

Reproducible: Always

Steps to Reproduce:
1. run konsole -e ssh user@host
2. Try to open a new tab with the same command run by using menu

Actual Results:  
The only options are to open pre-defined profiles (which actually lead to shell on local host).

Expected Results:  
New session to the same host in a new tab.
Comment 1 Jekyll Wu 2011-10-16 09:08:55 UTC
In kosole-2.8, The 'New tab' and 'New Window' actions will always open the default profile.

I guess what you want is a new dedicated action: "clone/duplicate current tab".
Comment 2 Jekyll Wu 2012-02-10 18:43:19 UTC
Git commit 56acddac933b96c10c782a918a419f6aaf4b2702 by Jekyll Wu.
Committed on 10/02/2012 at 19:37.
Pushed by jekyllwu into branch 'master'.

Add 'Clone Tab' action for cloning current tab

This action will create new tab/session using the same settings(command,
colors, etc) used in current tab/session.

At this moment, this action does not always clone current tab/session
100%. For example, If you change the scrollback setting of current
session temporarily through context menu or dbus method, this action
won't clone the temporary change. Another example is the tab title.

On the other hand, this action works quite well with command line
options(-e, -p, etc) and the 'konsoleprofile' utility.
Related: bug 292518
FIXED-IN:4.9.0

REVIEW:103859

DIGEST:

M  +3    -1    desktop/konsoleui.rc
M  +23   -0    src/MainWindow.cpp
M  +2    -0    src/MainWindow.h

http://commits.kde.org/konsole/56acddac933b96c10c782a918a419f6aaf4b2702