Bug 254828 - plasma crashes randomly
Summary: plasma crashes randomly
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-21 03:04 UTC by suppandi G
Modified: 2010-11-08 23:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description suppandi G 2010-10-21 03:04:53 UTC
Application: kded4 ($Id: kded.cpp 1151015 2010-07-17 13:50:01Z pokrzywka $)
KDE Platform Version: 4.5.73 (4.6 >= 20101019) "release 2"
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.4-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
I think on some notifications. it doesnt crash on all notifications, and i am not sure if it is notification related...but everytime its crashed...i've seen the systray was getting either a new status icon/ some program was using desktop notifications.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f36559ac760 (LWP 2268))]

Thread 3 (Thread 0x7f3638d65710 (LWP 2521)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fffd57ff7a1 in ?? ()
#2  0x00007f365043c2a3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007f36545b218f in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#5  0x00007f365467600d in QTimerInfoList::updateCurrentTime (this=0x870c40) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f3654676395 in QTimerInfoList::timerWait (this=0x870c40, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f3654674e6c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f3638d64c4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f3654674f15 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f3650193f7f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f3650194e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#11 0x00007f3650195510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#12 0x00007f3654675656 in QEventDispatcherGlib::processEvents (this=0x90a2d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#13 0x00007f3654649e12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f365464a025 in QEventLoop::exec (this=0x7f3638d64de0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f365455d034 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007f365462b478 in QInotifyFileSystemWatcherEngine::run (this=0x94c820) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f365455f8be in QThreadPrivate::start (arg=0x94c820) at thread/qthread_unix.cpp:266
#18 0x00007f36542d0a4f in start_thread () from /lib64/libpthread.so.0
#19 0x00007f365309082d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f363806d710 (LWP 2960)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fffd57ff7a1 in ?? ()
#2  0x00007f365043c2a3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007f36545b218f in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#5  0x00007f365467600d in QTimerInfoList::updateCurrentTime (this=0xa3bb70) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f3654676395 in QTimerInfoList::timerWait (this=0xa3bb70, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f3654674e6c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f363806cc4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f3654674f15 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f3650193f7f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f3650194e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#11 0x00007f3650195510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#12 0x00007f3654675656 in QEventDispatcherGlib::processEvents (this=0x9acbf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#13 0x00007f3654649e12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f365464a025 in QEventLoop::exec (this=0x7f363806cde0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f365455d034 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007f365462b478 in QInotifyFileSystemWatcherEngine::run (this=0x9802b0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f365455f8be in QThreadPrivate::start (arg=0x9802b0) at thread/qthread_unix.cpp:266
#18 0x00007f36542d0a4f in start_thread () from /lib64/libpthread.so.0
#19 0x00007f365309082d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f36559ac760 (LWP 2268)):
[KCrash Handler]
#6  0x0000000000000020 in ?? ()
#7  0x00007f3654650899 in QMetaObject::cast (this=0x7f363a0d17e0, obj=0x85b7a0) at kernel/qmetaobject.cpp:266
#8  0x00007f363a34421a in qobject_cast<Knm::InterfaceConnection const*> (first=0x85b7a0, second=0x8606a0) at /usr/include/QtCore/qobject.h:468
#9  activatableLessThan (first=0x85b7a0, second=0x8606a0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#10 0x00007f363a344d13 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x7170c8, lessThan=0x7f363a3441b0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:358
#11 0x00007f363a3445c8 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#13 0x00007f363a334a83 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:144
#14 0x00007f363a3305b8 in ActivatableList::qt_metacall (this=0x8d67f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd56dd5e0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:74
#15 0x00007f365465fb5f in QMetaObject::activate (sender=0x6ebda0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#16 0x00007f3639ebf831 in Knm::InterfaceConnection::setActivationState (this=0x6ebda0, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#17 0x00007f363a10a2ed in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x9043f0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#18 0x00007f363a10a319 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x9043f0, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#19 0x00007f363a10c3f7 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#20 0x00007f363a10abf6 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#21 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#22 0x00007f363a0e1eb0 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x8ed120, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd56dd7a0)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#23 0x00007f365465fb5f in QMetaObject::activate (sender=0x8a5e00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd56dd7a0) at kernel/qobject.cpp:3272
#24 0x00007f3639c75e8e in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.73svn1187456/build/libs/solid/control/networkmanager.moc:103
#25 0x00007f3639c76103 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x8a5e00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd56dd8f0)
    at /usr/src/debug/kdebase-workspace-4.5.73svn1187456/build/libs/solid/control/networkmanager.moc:85
#26 0x00007f3639c764d0 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8a5e00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd56dd8f0)
    at /usr/src/debug/kdebase-workspace-4.5.73svn1187456/build/libs/solid/control/networkmanager_p.moc:76
#27 0x00007f365465fb5f in QMetaObject::activate (sender=0x8da9a0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd56dd8f0) at kernel/qobject.cpp:3272
#28 0x00007f363919e2be in NMNetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown)
    at /usr/src/debug/kdebase-workspace-4.5.73svn1187456/build/solid/networkmanager-0.7/manager.moc:127
#29 0x00007f36391a188b in NMNetworkManager::qt_metacall (this=0x8da9a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd56dda40)
    at /usr/src/debug/kdebase-workspace-4.5.73svn1187456/build/solid/networkmanager-0.7/manager.moc:113
#30 0x00007f365465fb5f in QMetaObject::activate (sender=0x8e4790, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd56dda40) at kernel/qobject.cpp:3272
#31 0x00007f36391aad71 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1)
    at /usr/src/debug/kdebase-workspace-4.5.73svn1187456/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:182
#32 0x00007f36391ab16e in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x8e4790, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fffd56dded0)
    at /usr/src/debug/kdebase-workspace-4.5.73svn1187456/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:108
#33 0x00007f3651a503f8 in QDBusConnectionPrivate::deliverCall (this=0x8a1000, object=0x8e4790, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#34 0x00007f3651a5bf9f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#35 0x00007f365465e7da in QObject::event (this=0x8e4790, e=<value optimized out>) at kernel/qobject.cpp:1211
#36 0x00007f36537f0f34 in QApplicationPrivate::notify_helper (this=0x69cd70, receiver=0x8e4790, e=0x8eeed0) at kernel/qapplication.cpp:4396
#37 0x00007f36537f935a in QApplication::notify (this=<value optimized out>, receiver=0x8e4790, e=0x8eeed0) at kernel/qapplication.cpp:4277
#38 0x00007f36553aae66 in KApplication::notify (this=0x7fffd56de9b0, receiver=0x8e4790, event=0x8eeed0) at /usr/src/debug/kdelibs-4.5.73svn1187456/kdeui/kernel/kapplication.cpp:311
#39 0x00007f365464a9dc in QCoreApplication::notifyInternal (this=0x7fffd56de9b0, receiver=0x8e4790, event=0x8eeed0) at kernel/qcoreapplication.cpp:732
#40 0x00007f365464e185 in sendEvent (receiver=0x0, event_type=0, data=0x6150f0) at kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6150f0) at kernel/qcoreapplication.cpp:1373
#42 0x00007f3654675463 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#44 0x00007f3650194a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#45 0x00007f3650195270 in ?? () from /usr/lib64/libglib-2.0.so.0
#46 0x00007f3650195510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#47 0x00007f36546755ff in QEventDispatcherGlib::processEvents (this=0x617420, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#48 0x00007f3653894eee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007f3654649e12 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#50 0x00007f365464a025 in QEventLoop::exec (this=0x7fffd56de900, flags=...) at kernel/qeventloop.cpp:201
#51 0x00007f365464e43b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#52 0x00007f3643d92577 in kdemain (argc=1, argv=0x67b220) at /usr/src/debug/kdelibs-4.5.73svn1187456/kded/kded.cpp:900
#53 0x0000000000407139 in launch (argc=1, _name=0x40b3d1 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40b276 "0") at /usr/src/debug/kdelibs-4.5.73svn1187456/kinit/kinit.cpp:727
#54 0x000000000040994a in main (argc=4, argv=0x7fffd56df9a8, envp=0x7fffd56df9d0) at /usr/src/debug/kdelibs-4.5.73svn1187456/kinit/kinit.cpp:1841

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:07:39 UTC

*** This bug has been marked as a duplicate of bug 210878 ***