Bug 254804 - improve feedback for download region dialog
Summary: improve feedback for download region dialog
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Maemo 5 Linux
: NOR normal (vote)
Target Milestone: 1.0 (KDE 4.6)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-20 23:29 UTC by jack
Modified: 2013-04-14 21:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jack 2010-10-20 23:29:27 UTC
Version:           unspecified (using Devel) 
OS:                Linux

'Download region' feature doesn't appear to work. When I use it, specify my options or use the default 'visible region' setting and click apply, the apply button remains depressed for a few seconds and then becomes unpressed once again. No notification of success or failure is shown, and the time it takes to become unpressed is not enough to actually download all the tiles specified (sometimes thousands) so I assume that it has failed for no good reason (wifi connection is connected to N900).

Reproducible: Didn't try

Steps to Reproduce:
open app menu for marble on maemo, click download region, click apply and observe the above results.

Actual Results:  
nothing happens other than  button being depressed and then becoming unpressed

Expected Results:  
notification of success or failure; specified tiles actually being successfully downloaded.
Comment 1 Dennis Nienhüser 2010-10-21 08:22:08 UTC
I'm pretty sure it does work unless you have the "Work Offline" option in the menu activated. The progress indication however is a bit hidden since it's completely outside the dialog: There's a round white/gray info box that shows a pie chart which indicates the download progress in percent. If you had a quite early version of Marble on Maemo installed (prior to any one-click installs), this info box may be disabled in the configuration file. The easiest option in this case would be to delete "/home/user/.config/kde.org/Marble Desktop Globe.conf" to restore the default settings.
Comment 2 jack 2010-10-30 16:10:17 UTC
yes you're right that there is a pie chart indicator that correctly displays progress. This is only visible when action is taking place however, and not when the connection is idle, so I hadn't noticed it before.

the problem is that this indicator is invisible when you are in the region download dialogue because it obscures the bottom of the screen where the indicator is based. a solution might be to replace 'apply', which is confusong when its pressed and nothing vosobly happens, with 'ok' which would ommediately close the dialogue and reveal the piechart.

this would save you having to implement the progress bar into the region download dialogue.
Comment 3 Dennis Nienhüser 2010-11-01 12:40:25 UTC
SVN commit 1191896 by nienhueser:

Don't show the Apply button on Maemo since it is only useful in modal dialogs.
CCBUG: 254804

 M  +4 -0      DownloadRegionDialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1191896