Bug 254697 - Kdevelop crash on start
Summary: Kdevelop crash on start
Status: RESOLVED DUPLICATE of bug 224337
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 4.0.90
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 4.1.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-19 22:10 UTC by xcojack@gmail.com
Modified: 2010-10-20 17:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xcojack@gmail.com 2010-10-19 22:10:05 UTC
Application: kdevelop (4.0.90)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: I just only start the kdevelop from shoutcut, and I realy don't know what to write here ;p

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcea7186760 (LWP 5495))]

Thread 6 (Thread 0x7fce9002a710 (LWP 5496)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007fcea591bda2 in wait (this=<value optimized out>, mutex=0x13c5df0, time=200000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x13c5df0, time=200000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fcea1a6b9de in KDevelop::DUChainPrivate::CleanupThread::run (this=0x13c5dd0) at ../../language/duchain/duchain.cpp:286
#4  0x00007fcea591b27e in QThreadPrivate::start (arg=0x13c5dd0) at thread/qthread_unix.cpp:266
#5  0x00007fcea431f971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007fcea461b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fce8932e710 (LWP 5512)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fcea591be3b in wait (this=<value optimized out>, mutex=0x207c1a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x207c1a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fce9c8d7524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x20781c0, th=0x20817d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fce9c8da72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x207afb0, th=0x20817d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fce9c8d8c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7fce8932de00, parent=0x20781c0, th=0x20817d0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fce9c8d91f8 in ThreadWeaver::Thread::run (this=0x20817d0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fcea591b27e in QThreadPrivate::start (arg=0x20817d0) at thread/qthread_unix.cpp:266
#8  0x00007fcea431f971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007fcea461b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fce80c7c710 (LWP 5516)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fce80c7bad0 in ?? ()
#2  0x00007fff32ede852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7fce8047b710 (LWP 5517)):
#0  g_main_context_check (context=0x24bdd80, max_priority=2147483647, fds=<value optimized out>, n_fds=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2658
#1  0x00007fce9e64c023 in g_main_context_iterate (context=0x24bdd80, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2777
#2  0x00007fce9e64c45c in g_main_context_iteration (context=0x24bdd80, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#3  0x00007fcea5a3b1e6 in QEventDispatcherGlib::processEvents (this=0x1dcca20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fcea5a0da02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fcea5a0ddec in QEventLoop::exec (this=0x7fce8047adb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fcea59182fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fcea59ed5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1d88c10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fcea591b27e in QThreadPrivate::start (arg=0x1d88c10) at thread/qthread_unix.cpp:266
#9  0x00007fcea431f971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007fcea461b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fce7a21d710 (LWP 5551)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fcea591be3b in wait (this=<value optimized out>, mutex=0x11df1f0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x11df1f0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fce9c8d7524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x12faaa0, th=0x3c9d840) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fce9c8da72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x120a120, th=0x3c9d840) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fce9c8d8c9f in ThreadWeaver::ThreadRunHelper::run (this=0x7fce7a21ce00, parent=0x12faaa0, th=0x3c9d840) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fce9c8d91f8 in ThreadWeaver::Thread::run (this=0x3c9d840) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fcea591b27e in QThreadPrivate::start (arg=0x3c9d840) at thread/qthread_unix.cpp:266
#8  0x00007fcea431f971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007fcea461b91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcea7186760 (LWP 5495)):
[KCrash Handler]
#6  QUrlPrivate::parse (this=0x401fba0, parseOptions=QUrlPrivate::ParseAndSet) at io/qurl.cpp:3753
#7  0x00007fcea59c5cdc in QUrl::scheme (this=0x7fce8418abe0) at io/qurl.cpp:4413
#8  0x00007fcea6c02096 in hasSubUrl (this=<value optimized out>) at ../../kdecore/io/kurl.cpp:956
#9  KUrl::hasSubUrl (this=<value optimized out>) at ../../kdecore/io/kurl.cpp:1000
#10 0x00007fcea280634f in KIO::SimpleJobPrivate::SimpleJobPrivate (this=0x7fce8418ab30, url=<value optimized out>, command=71, packedArgs=<value optimized out>) at ../../kio/kio/job_p.h:91
#11 0x00007fcea27f92b4 in ListJobPrivate (url=..., flags=<value optimized out>, includeHidden=true) at ../../kio/kio/job.cpp:2362
#12 newJob (url=..., flags=<value optimized out>, includeHidden=true) at ../../kio/kio/job.cpp:2387
#13 KIO::listDir (url=..., flags=<value optimized out>, includeHidden=true) at ../../kio/kio/job.cpp:2568
#14 0x00007fce8eb076e4 in GenericManagerListJob::startNextJob (this=0x1d9c920) at ../../../plugins/genericprojectmanager/genericmanagerlistjob.cpp:61
#15 0x00007fce8eb077c8 in GenericManagerListJob::qt_metacall (this=0x1d9c920, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fce842cf5c0) at ./genericmanagerlistjob.moc:93
#16 0x00007fcea5a20bde in QObject::event (this=0x1d9c920, e=0x401fba0) at kernel/qobject.cpp:1219
#17 0x00007fcea4d75fdc in QApplicationPrivate::notify_helper (this=0xe96020, receiver=0x1d9c920, e=0x7fce84400e00) at kernel/qapplication.cpp:4396
#18 0x00007fcea4d7baed in QApplication::notify (this=0x7fff32ed23b0, receiver=0x1d9c920, e=0x7fce84400e00) at kernel/qapplication.cpp:4277
#19 0x00007fcea5f654d6 in KApplication::notify (this=0x7fff32ed23b0, receiver=0x1d9c920, event=0x7fce84400e00) at ../../kdeui/kernel/kapplication.cpp:310
#20 0x00007fcea5a0ecdc in QCoreApplication::notifyInternal (this=0x7fff32ed23b0, receiver=0x1d9c920, event=0x7fce84400e00) at kernel/qcoreapplication.cpp:732
#21 0x00007fcea5a11c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xe74e70) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xe74e70) at kernel/qcoreapplication.cpp:1373
#23 0x00007fcea5a3b653 in sendPostedEvents (s=0xe99c40) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0xe99c40) at kernel/qeventdispatcher_glib.cpp:277
#25 0x00007fce9e648342 in g_main_dispatch (context=0xe98d20) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#26 g_main_context_dispatch (context=0xe98d20) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#27 0x00007fce9e64c2a8 in g_main_context_iterate (context=0xe98d20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#28 0x00007fce9e64c45c in g_main_context_iteration (context=0xe98d20, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#29 0x00007fcea5a3b193 in QEventDispatcherGlib::processEvents (this=0xe745b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#30 0x00007fcea4e28a4e in QGuiEventDispatcherGlib::processEvents (this=0x401fba0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007fcea5a0da02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#32 0x00007fcea5a0ddec in QEventLoop::exec (this=0x7fff32ed2180, flags=) at kernel/qeventloop.cpp:201
#33 0x00007fcea5a11ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#34 0x0000000000408f01 in _start ()

Possible duplicates by query: bug 234804, bug 224337.

Reported using DrKonqi
Comment 1 Milian Wolff 2010-10-20 17:23:54 UTC

*** This bug has been marked as a duplicate of bug 224337 ***