Bug 254596 - remove tab bar plugin now that tabify plugin has been added
Summary: remove tab bar plugin now that tabify plugin has been added
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-18 22:45 UTC by Alexander van Loon
Modified: 2011-04-16 16:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander van Loon 2010-10-18 22:45:03 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

With Kate 3.5.1 (couldn’t choose this as the application version) on KDE SC 4.5.1 (Kubuntu 10.10), I have two different plugins: Tab Bar and Tabify. Both plugins give a tab bar, Tab Bar gives a custom tab bar widget, Tabify is new and gives the KTabBar widget. I suggest that the old Tab Bar plugin is removed, and that Tabify is renamed to a more descriptive name, Tab Bar like the old plugin for example. Right now we have two plugins duplicating functionality, and the old one is obviously inferior, there is no good reason for this. Fixing this will also close bug #184458.

Reproducible: Always
Comment 1 Dominik Haumann 2010-10-18 23:35:41 UTC
This is at best a wishlist, if not even a rejection. The problem is: I bet that there is 100% a person, who likes the multitabbar better than the standard tabbar. Removing the multitabbar will cause unhappy users as well. So if it works, let it live.

The only valid part here is:
- rename Tabify to Tab Bar
- rename Tab Bar Extention to Multiline Tab Bar (or similar)

Any takers?
Comment 2 Dominik Haumann 2011-04-16 16:39:47 UTC
Git commit abcfbf0368109c75bb35731a8517730257e08b05 by Dominik Haumann.
Committed on 16/04/2011 at 16:45.
Pushed by dhaumann into branch 'master'.

clarify tab bar plugin naming

Tabiry -> Tab Bar
Tab Bar -> Multirow Tab Bar

BUG: 254596

M  +2    -2    kate/plugins/tabbarextension/katetabbarextension.desktop     
M  +2    -2    kate/plugins/tabify/katetabifyplugin.desktop     

http://commits.kde.org/kate/abcfbf0368109c75bb35731a8517730257e08b05