Bug 254560 - Associate application as the default for all of its known compatible mimetypes
Summary: Associate application as the default for all of its known compatible mimetypes
Status: RESOLVED DUPLICATE of bug 232545
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_filetypes (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist with 70 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2010-10-18 18:07 UTC by Andrew Luecke
Modified: 2020-01-22 16:15 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Luecke 2010-10-18 18:07:08 UTC
Version:           unspecified (using KDE 4.4.5) 
OS:                Linux

There is currently no easy way to make an application the default application for all of it's known file types. The only way to do so, requires that you manually set each mimetype to the application.

Two such examples of where this is useful are: 
1) Handbrake (a movie converter app) currently sets itself as default for all movie files on fedora. Most users however probably want their default to be a movie player. 
2) A user who previously preferred Dragon may wish to switch to VLC as the default easily. 

Reproducible: Always

Steps to Reproduce:
Using (1) As an example
1) Dragon Player and handbrake are installed, Handbrake is the current default. The user doesn't want to uninstall handbrake, because they need it for their portable media player

Actual Results:  
1) System Settings
2) Notice, Default applications WONT work here, because it only deals with handlers
3) Go to advanced, file associations 
4) Expand Video.
5) Go through EVERY entry, select Dragon Player, move up, and apply.
6) Note, this doesn't scale well.. The more powerful an application is, the more difficult it is to set it default for everything. 

Expected Results:  
The better way is:
1)System Settings
2) Go to default Applications 
3) (New) Switch to the NEW "set preferred application" settings, from the basic handlers
4) (New) A listing of the applications from the menu are displayed. 
5) (New) Select your preferred application from the list
6) (New) Click set application as default (in this example, Dragon player). 
7) (New) KDE internally sets Dragon player as primary application for all compatible mimetypes. 
8) Note, regardless of how many mimetypes the app supports (could be hundreds), there are only 2 or 3 clicks, as opposed to hundreds potentially. 

Microsoft introduced this in Windows Vista(?), and it is used quite often: http://www.nirmaltv.com/2009/01/31/how-to-set-up-default-programs-in-windows-7/
Comment 1 Christoph Feck 2015-02-06 18:26:46 UTC
*** Bug 343859 has been marked as a duplicate of this bug. ***
Comment 2 Øystein Steffensen-Alværvik 2018-07-23 17:32:19 UTC
Such a feature would also have to *prevent* other applications in changing their mimetype associations, no? In other words, mimetypes associated with, for instance, Dragon Player would have to be changed manually by the user.

This is desirable because many applications will switch default associations upon install, without asking; leaving the user (me) frustrated because I have to change them back. I once had an install associate video files with Kate!
Comment 3 Øystein Steffensen-Alværvik 2018-08-07 17:38:14 UTC
*** Bug 396930 has been marked as a duplicate of this bug. ***
Comment 4 Karl Ove Hufthammer 2018-08-07 18:24:33 UTC
Windows actually has a nice UI for this feature. Example screenshot:

https://filestore.community.support.microsoft.com/api/images/29fc882f-a9e4-40fc-9dcf-65ad6be91492

Perhaps worth using as inspiration?
Comment 5 fire f. 2018-11-19 08:46:54 UTC
https://userbase.kde.org/Dolphin/File_Management#Change_a_File_Association_on-the-fly

now describes how to associate in single / multiple  mode.

unfortunately, the crucial feature

   InitialPreference=2
   X-KDE-InitialPreference=3

which would be needed to be no nuisance by kicking out the old apps did not work for me. 

Given that X-KDE-InitialPreference=3 can be made to work we're almost there.

Of course, a little GUI handling the .desktop files as suggested (like windows) would be awesome!
Comment 6 Nate Graham 2020-01-22 16:15:13 UTC
As requested, essentially a duplicate of Bug 232545.

*** This bug has been marked as a duplicate of bug 232545 ***