Bug 254445 - Nepomuk exits on signal 11
Summary: Nepomuk exits on signal 11
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-17 11:54 UTC by Vincent-Xavier JUMEL
Modified: 2011-01-17 17:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent-Xavier JUMEL 2010-10-17 11:54:49 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.2 (KDE 4.5.2) (Compiled from sources)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-gentoo-r9 x86_64
Distribution: "Gentoo Base System release 2.0.1"

-- Information about the crash:
A few minutes after starting my computer, Nepomuk token crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Jeton du service Nepomuk (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc9a00c2760 (LWP 5617))]

Thread 2 (Thread 0x7fc990edb710 (LWP 5636)):
[KCrash Handler]
#6  QString (this=0x7fc98c027800) at ../../include/QtCore/../../src/corelib/tools/qstring.h:727
#7  QDBusAbstractInterface::service (this=0x7fc98c027800) at qdbusabstractinterface.cpp:357
#8  0x00007fc999fa14c9 in Soprano::Client::DBusModel::executeQuery (this=0x9812a0, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>) at /var/tmp/portage/dev-libs/soprano-2.5.2/work/soprano-2.5.2/client/dbus/dbusmodel.cpp:110
#9  0x00007fc99e80892f in Nepomuk::MainModel::executeQuery (this=0x79b2f0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/nepomukmainmodel.cpp:212
#10 0x00007fc99a21e3d1 in Soprano::FilterModel::executeQuery (this=0x770ba0, query=<value optimized out>, language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /var/tmp/portage/dev-libs/soprano-2.5.2/work/soprano-2.5.2/soprano/filtermodel.cpp:164
#11 0x00007fc99e7fced2 in Nepomuk::ResourceData::determineUri (this=0x97bc80) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/resourcedata.cpp:580
#12 0x00007fc99e80c78a in Nepomuk::Resource::determineFinalResourceData (this=0x7fc990eda350) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/resource.cpp:885
#13 0x00007fc99e80e57b in Nepomuk::Resource::resourceUri (this=0x7fc98c027800) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/resource.cpp:165
#14 0x00007fc991563bf8 in FileMetaData (this=0x8db260, idx=0x7fc990eda9e0) at /var/tmp/portage/kde-base/nepomuk-4.5.2/work/nepomuk-4.5.2/nepomuk/strigibackend/nepomukindexwriter.cpp:190
#15 Strigi::NepomukIndexWriter::startAnalysis (this=0x8db260, idx=0x7fc990eda9e0) at /var/tmp/portage/kde-base/nepomuk-4.5.2/work/nepomuk-4.5.2/nepomuk/strigibackend/nepomukindexwriter.cpp:373
#16 0x00007fc991bd7dd2 in Nepomuk::IndexScheduler::analyzeFile (this=<value optimized out>, file=..., analyzer=0x7fc990edae10) at /var/tmp/portage/kde-base/nepomuk-4.5.2/work/nepomuk-4.5.2/nepomuk/services/strigi/indexscheduler.cpp:443
#17 0x00007fc991bd8dcc in Nepomuk::IndexScheduler::updateDir (this=<value optimized out>, dir=<value optimized out>, analyzer=<value optimized out>, flags=<value optimized out>) at /var/tmp/portage/kde-base/nepomuk-4.5.2/work/nepomuk-4.5.2/nepomuk/services/strigi/indexscheduler.cpp:413
#18 0x00007fc991bdaec4 in Nepomuk::IndexScheduler::run (this=0x7742c0) at /var/tmp/portage/kde-base/nepomuk-4.5.2/work/nepomuk-4.5.2/nepomuk/services/strigi/indexscheduler.cpp:314
#19 0x00007fc99facc47e in QThreadPrivate::start (arg=0x7742c0) at thread/qthread_unix.cpp:266
#20 0x00007fc99f83ad9a in start_thread (arg=<value optimized out>) at pthread_create.c:301
#21 0x00007fc99d54290d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fc9a00c2760 (LWP 5617)):
#0  0x00007fc99d539b93 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=8660) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc99c04bb30 in socket_do_iteration (transport=0x6dbfb0, flags=6, timeout_milliseconds=8660) at /var/tmp/portage/sys-apps/dbus-1.4.0/work/dbus-1.4.0/dbus/dbus-transport-socket.c:1125
#2  0x00007fc99c049d3d in _dbus_transport_do_iteration (transport=0x6dbfb0, flags=<value optimized out>, timeout_milliseconds=<value optimized out>) at /var/tmp/portage/sys-apps/dbus-1.4.0/work/dbus-1.4.0/dbus/dbus-transport.c:980
#3  0x00007fc99c03560d in _dbus_connection_do_iteration_unlocked (connection=0x6deff0, pending=0x0, flags=6, timeout_milliseconds=8660) at /var/tmp/portage/sys-apps/dbus-1.4.0/work/dbus-1.4.0/dbus/dbus-connection.c:1206
#4  0x00007fc99c037a81 in _dbus_connection_block_pending_call (pending=0x7fc98c03b0f0) at /var/tmp/portage/sys-apps/dbus-1.4.0/work/dbus-1.4.0/dbus/dbus-connection.c:2507
#5  0x00007fc99c03700d in dbus_connection_send_with_reply_and_block (connection=0x6deff0, message=0x7fc98c06d8e0, timeout_milliseconds=-1, error=0x7fff0b792fc0) at /var/tmp/portage/sys-apps/dbus-1.4.0/work/dbus-1.4.0/dbus/dbus-connection.c:3559
#6  0x00007fc99f5e47bc in q_dbus_connection_send_with_reply_and_block (this=0x6daec0, message=..., sendMode=<value optimized out>, timeout=-1) at qdbus_symbols_p.h:135
#7  QDBusConnectionPrivate::sendWithReply (this=0x6daec0, message=..., sendMode=<value optimized out>, timeout=-1) at qdbusintegrator.cpp:1844
#8  0x00007fc99f5d0683 in QDBusConnection::call (this=0x76fd00, message=..., mode=4294967295, timeout=0) at qdbusconnection.cpp:530
#9  0x00007fc99f5eecfd in QDBusAbstractInterface::callWithArgumentList (this=<value optimized out>, mode=QDBus::Block, method=<value optimized out>, args=<value optimized out>) at qdbusabstractinterface.cpp:444
#10 0x00007fc999f9e655 in Soprano::Client::DBusServerInterface::createModel (this=0x79b9f0, name=<value optimized out>) at /var/tmp/portage/dev-libs/soprano-2.5.2/work/soprano-2.5.2/client/dbus/dbusserverinterface.h:57
#11 0x00007fc999f9f189 in Soprano::Client::DBusClient::createModel (this=0x771e20, name=..., settings=<value optimized out>) at /var/tmp/portage/dev-libs/soprano-2.5.2/work/soprano-2.5.2/client/dbus/dbusclient.cpp:73
#12 0x00007fc99e8079fc in (anonymous namespace)::GlobalModelContainer::init (this=0x771e20, forced=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/nepomukmainmodel.cpp:92
#13 0x00007fc99e80aeea in Nepomuk::MainModel::init (this=0x79b2f0) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/nepomukmainmodel.cpp:176
#14 0x00007fc99e8016f0 in Nepomuk::ResourceManager::init (this=0x771bf0) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/resourcemanager.cpp:329
#15 0x00007fc99e8030e5 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x7704a0, success=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/nepomuk/core/resourcemanager.cpp:220
#16 0x00007fc99e8031c5 in Nepomuk::ResourceManager::qt_metacall (this=0x771bf0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0b793800) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2_build/nepomuk/resourcemanager.moc:90
#17 0x00007fc99f5df6c9 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#18 0x00007fc99f5e9f9f in QDBusCallDeliveryEvent::placeMetaCall (this=0x1, object=0x1) at qdbusintegrator_p.h:103
#19 0x00007fc99fbcedae in QObject::event (this=0x771bf0, e=0x7fff0b792d60) at kernel/qobject.cpp:1211
#20 0x00007fc99dcb552c in QApplicationPrivate::notify_helper (this=0x621490, receiver=0x771bf0, e=0xa2db20) at kernel/qapplication.cpp:4396
#21 0x00007fc99dcbb0ad in QApplication::notify (this=0x7fff0b7945e0, receiver=0x771bf0, e=0xa2db20) at kernel/qapplication.cpp:4277
#22 0x00007fc99eca9388 in KApplication::notify (this=0x7fff0b7945e0, receiver=0x771bf0, event=0xa2db20) at /var/tmp/portage/kde-base/kdelibs-4.5.2/work/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#23 0x00007fc99fbbd0eb in QCoreApplication::notifyInternal (this=0x7fff0b7945e0, receiver=0x771bf0, event=0xa2db20) at kernel/qcoreapplication.cpp:732
#24 0x00007fc99fbbfff5 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x60a8a0) at kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x60a8a0) at kernel/qcoreapplication.cpp:1373
#26 0x00007fc99fbe9553 in sendPostedEvents (s=0x6250c0) at kernel/qcoreapplication.h:220
#27 postEventSourceDispatch (s=0x6250c0) at kernel/qeventdispatcher_glib.cpp:277
#28 0x00007fc99cda6379 in g_main_dispatch (context=0x624120) at gmain.c:1960
#29 IA__g_main_context_dispatch (context=0x624120) at gmain.c:2513
#30 0x00007fc99cdaa120 in g_main_context_iterate (context=0x624120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#31 0x00007fc99cdaa2c2 in IA__g_main_context_iteration (context=0x624120, may_block=1) at gmain.c:2654
#32 0x00007fc99fbe903e in QEventDispatcherGlib::processEvents (this=0x609f90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#33 0x00007fc99dd66146 in QGuiEventDispatcherGlib::processEvents (this=0x7fff0b792d60, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007fc99fbbbe32 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#35 0x00007fc99fbbc1fd in QEventLoop::exec (this=0x7fff0b794410, flags=) at kernel/qeventloop.cpp:201
#36 0x00007fc99fbc025b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#37 0x0000000000404144 in main (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/nepomuk-4.5.2/work/nepomuk-4.5.2/nepomuk/servicestub/main.cpp:165

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-01-17 17:07:54 UTC

*** This bug has been marked as a duplicate of bug 245266 ***