Bug 254344 - New: plasmoid-networkmanager: uncheck / check the box Activate network manager crash
Summary: New: plasmoid-networkmanager: uncheck / check the box Activate network manage...
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-16 10:38 UTC by Bruno Friedmann
Modified: 2010-11-08 23:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2010-10-16 10:38:49 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.36-rc4-16-desktop x86_64
Distribution: "openSUSE 11.4 Milestone 2 of 6 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Looking around for wifi management, I uncheck the checkbox "Activate Network
management" ok. the button disappear. When I recheck ( put it on ). The crash
appears

Sorry this is the first crash, which give the crash of plasma reported in #254343

-- Backtrace:
Application: Démon de KDE (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f63376f2957 in QMetaObject::cast (this=0x7f631d0a3940, obj=0x969e70) at kernel/qmetaobject.cpp:266
#7  0x00007f631d31479a in qobject_cast<Knm::InterfaceConnection const*> (first=0x969e70, second=0x9723a0) at /usr/include/QtCore/qobject.h:468
#8  activatableLessThan (first=0x969e70, second=0x9723a0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#9  0x00007f631d315293 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=@0xbd8438, lessThan=0x7f631d314730 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:358
#10 0x00007f631d314b48 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#12 0x00007f631d305943 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:144
#13 0x00007f631d301308 in ActivatableList::qt_metacall (this=0x8a87f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffec687ba0) at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:74
#14 0x00007f6337701c6f in QMetaObject::activate (sender=0x95a6a0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#15 0x00007f631ce92341 in Knm::InterfaceConnection::setActivationState (this=0x95a6a0, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#16 0x00007f631d0dc12d in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0xb6c920, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#17 0x00007f631d0dc159 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0xb6c920, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#18 0x00007f631d0de297 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#19 0x00007f631d0dca96 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#20 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#21 0x00007f631d0b3eb0 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x950460, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffec687d60) at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#22 0x00007f6337701c6f in QMetaObject::activate (sender=0x944c20, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffec687d60) at kernel/qobject.cpp:3272
#23 0x00007f631e79f7ae in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:100
#24 0x00007f631e79f9c3 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x944c20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffec687eb0) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:83
#25 0x00007f631e79fd90 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x944c20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffec687eb0) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager_p.moc:76
#26 0x00007f6337701c6f in QMetaObject::activate (sender=0x92deb0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffec687eb0) at kernel/qobject.cpp:3272
#27 0x00007f631e37bb4e in Solid::Control::Ifaces::NetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/ifaces/networkmanager.moc:108
#28 0x00007f631c5cb30b in NMNetworkManager::qt_metacall (this=0x92deb0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffec688010) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/manager.moc:97
#29 0x00007f6337701c6f in QMetaObject::activate (sender=0x950d00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffec688010) at kernel/qobject.cpp:3272
#30 0x00007f631c5c2b81 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:176
#31 0x00007f631c5c7566 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x950d00, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fffec688240) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#32 0x00007f6334b04d28 in QDBusConnectionPrivate::deliverCall (this=0x93e340, object=0x950d00, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#33 0x00007f6334b0fdef in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#34 0x00007f63377008ea in QObject::event (this=0x950d00, e=<value optimized out>) at kernel/qobject.cpp:1211
#35 0x00007f63368a2f64 in QApplicationPrivate::notify_helper (this=0x6d0bb0, receiver=0x950d00, e=0x967120) at kernel/qapplication.cpp:4396
#36 0x00007f63368ab38a in QApplication::notify (this=<value optimized out>, receiver=0x950d00, e=0x967120) at kernel/qapplication.cpp:4277
#37 0x00007f6338366446 in KApplication::notify (this=0x7fffec688d20, receiver=0x950d00, event=0x967120) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#38 0x00007f63376eca9c in QCoreApplication::notifyInternal (this=0x7fffec688d20, receiver=0x950d00, event=0x967120) at kernel/qcoreapplication.cpp:732
#39 0x00007f63376f0245 in sendEvent (receiver=0x0, event_type=0, data=0x60f3e0) at kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f3e0) at kernel/qcoreapplication.cpp:1373
#41 0x00007f6337717603 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#43 0x00007f63332446e3 in g_main_dispatch (context=0x6d3520) at gmain.c:2149
#44 g_main_context_dispatch (context=0x6d3520) at gmain.c:2702
#45 0x00007f6333244ec0 in g_main_context_iterate (context=0x6d3520, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#46 0x00007f6333245160 in g_main_context_iteration (context=0x6d3520, may_block=1) at gmain.c:2843
#47 0x00007f633771779f in QEventDispatcherGlib::processEvents (this=0x616cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#48 0x00007f6336946e1e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007f63376ebed2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#50 0x00007f63376ec0e5 in QEventLoop::exec (this=0x7fffec688c70, flags=...) at kernel/qeventloop.cpp:201
#51 0x00007f63376f04fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#52 0x00007f6327f65657 in kdemain (argc=1, argv=0x6ab290) at /usr/src/debug/kdelibs-4.5.2/kded/kded.cpp:894
#53 0x00000000004074f9 in launch (argc=1, _name=0x40b3bb "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b257 "0") at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:723
#54 0x0000000000409d0a in main (argc=4, argv=0x7fffec689d18, envp=0x7fffec689d40) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1835

This bug may be a duplicate of or related to bug 254343.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:08:00 UTC

*** This bug has been marked as a duplicate of bug 210878 ***