Bug 254312 - KPresenter adds XML data to the list in slides
Summary: KPresenter adds XML data to the list in slides
Status: RESOLVED FIXED
Alias: None
Product: calligrastage
Classification: Applications
Component: opendocument (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR major (vote)
Target Milestone: ---
Assignee: T Zachmann
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-15 23:44 UTC by Zinchenko Andrij
Modified: 2010-12-29 11:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
XML data among list items (131.34 KB, image/png)
2010-10-15 23:44 UTC, Zinchenko Andrij
Details
presentation with which the bug happened (101.37 KB, application/octet-stream)
2010-10-15 23:55 UTC, Zinchenko Andrij
Details
Presentation with XML elements (buggy) (18.06 KB, application/octet-stream)
2010-10-18 23:47 UTC, Zinchenko Andrij
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zinchenko Andrij 2010-10-15 23:44:01 UTC
Created attachment 52553 [details]
XML data among list items

Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

KPresenter adds some kind of XML data (or data grbage) to lists that are used on slides. It happens when the document is repened.So, first I create a ODP document with lists and then some of the lists are filled with XML data that mixes up with text in the list.
This may be related to the fact that originally presentation had some edits in openoffice

Reproducible: Didn't try




OS: Linux (i686) release 2.6.35-ARCH
Compiler: gcc
Comment 1 Zinchenko Andrij 2010-10-15 23:55:26 UTC
Created attachment 52556 [details]
presentation with which the bug happened

For actual bug see slide 10
Comment 2 T Zachmann 2010-10-18 16:00:03 UTC
The presentation attached to the bug report is a html file and not a odp file. Can you please attach the otp file?
Comment 3 Zinchenko Andrij 2010-10-18 23:47:11 UTC
Created attachment 52664 [details]
Presentation with XML elements (buggy)

Suddenly when using KPresenter among the lists there arrive a whole bunch or XML data.
Comment 4 Sebastian Sauer 2010-11-01 15:28:00 UTC
Seems I cannot reproduce with r1191551 .

@Zinchenko Andrij

Can you still reproduce the problem with a more recent kpresenter? What version where you using btw?
Comment 5 Zinchenko Andrij 2010-11-01 16:37:25 UTC
I was using KOffice 2.3 Beta 2 when I have spotted this bug. Now I user
Koffice 2.3 Beta3 and it is still there :(

2010/11/1 Sebastian Sauer <sebsauer@kdab.com>

> https://bugs.kde.org/show_bug.cgi?id=254312
>
>
> Sebastian Sauer <sebsauer@kdab.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                 CC|                            |sebsauer@kdab.com
>
>
>
>
> --- Comment #4 from Sebastian Sauer <sebsauer kdab com>  2010-11-01
> 15:28:00 ---
> Seems I cannot reproduce with r1191551 .
>
> @Zinchenko Andrij
>
> Can you still reproduce the problem with a more recent kpresenter? What
> version
> where you using btw?
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 6 T Zachmann 2010-11-10 06:54:46 UTC
Do you still have the original presentation without it showing the xml?
Comment 7 Cyrille Berger 2010-12-29 11:33:50 UTC
SVN commit 1210066 by berger:

Fix saving of animation and RDF attributes.

BUG: 254312


 M  +31 -20    KoTextWriter.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1210066
Comment 8 Cyrille Berger 2010-12-29 11:45:45 UTC
SVN commit 1210068 by berger:

include the fix for saving of animation and RDF attributes in the 2.3.0 release.

BUG: 254312


 M  +31 -20    KoTextWriter.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1210068