Bug 254154 - Marble atmosphere is only shown on map theme change
Summary: Marble atmosphere is only shown on map theme change
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: 1.0 (KDE 4.6)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-14 14:45 UTC by Bastian Senst
Modified: 2010-10-14 22:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.5.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastian Senst 2010-10-14 14:45:36 UTC
Version:           unspecified (using Devel) 
OS:                Linux

If you start Marble or switch the map theme an atmosphere is shown around the planet (to be activated in View->Atmosphere). This atmosphere vanishes from the first move or zoom on.

Reproducible: Always
Comment 1 Bastian Senst 2010-10-14 22:06:38 UTC
SVN commit 1185961 by bholst:

Corrected Marble's atmosphere painting:
* We have to paint the atmosphere in any case (because we update the background, stars).
* We have to paint the atmosphere at the correct moment (between stars and ground).

BUG: 254154

 M  +0 -68     MarbleMap.cpp  
 M  +0 -3      MarbleMap_p.h  
 M  +51 -0     MarbleModel.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1185961
Comment 2 Bastian Senst 2010-10-14 22:22:43 UTC
SVN commit 1185965 by bholst:

Corrected Marble's atmosphere painting:
* We have to paint the atmosphere in any case (because we update the background, stars).
* We have to paint the atmosphere at the correct moment (between stars and ground).

BUG: 254154

backport r1185961

 M  +0 -69     MarbleMap.cpp  
 M  +0 -3      MarbleMap_p.h  
 M  +53 -0     MarbleModel.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1185965