Bug 254022 - Right click window border -> configure window behavoir displays incorrect setting dialog
Summary: Right click window border -> configure window behavoir displays incorrect set...
Status: RESOLVED DUPLICATE of bug 249706
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 02:06 UTC by Andrew Brouwers
Modified: 2010-10-13 02:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
SS of initial settings window (82.20 KB, image/png)
2010-10-13 02:06 UTC, Andrew Brouwers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Brouwers 2010-10-13 02:06:16 UTC
Created attachment 52469 [details]
SS of initial settings window

Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

I couldn't locate this bug anywhere on bugs.kde.org, so sorry if it's a dup.

Anyway, since KDE 4.5, if one right-clicks on the window border, and hits "configure window behavoir" from the drop-down, the default KDE control module loads "Desktop Effects," but actually loads the settings to configure the look-and-feel for window titles.  If I toggle down to another setting, and then back to "Desktop Effects," I get the expected desktop-effect settings menu.  Finally, if I close the window and perform the operation again, the bug is reproducable every time.

This bug was present in at least 4.5.1 as well; SS attached showing bug.

Reproducible: Didn't try

Steps to Reproduce:
1) Right click window border
2) Choose "Configure Window Behavoir"
3) Observe incorrect settings module loaded
Comment 1 Christoph Feck 2010-10-13 02:14:49 UTC

*** This bug has been marked as a duplicate of bug 249706 ***