Bug 253993 - Putting laptop in suspend, move to another network and wake up
Summary: Putting laptop in suspend, move to another network and wake up
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-12 19:37 UTC by Bruno Friedmann
Modified: 2010-11-08 23:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2010-10-12 19:37:32 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.36-rc4-16-desktop x86_64
Distribution: "openSUSE 11.4 Milestone 2 of 6 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: Reopening kde after a suspend.
I put the laptop in suspend when connected to network A.
Then I wake it up connect on network B.

Network was working, konverstation which was open before the suspend reconnect immediately and work.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Démon de KDE (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fd59675e967 in QMetaObject::cast (this=0x7fd57c2e9940, obj=0xaa95e0) at kernel/qmetaobject.cpp:266
#7  0x00007fd57c55a79a in qobject_cast<Knm::InterfaceConnection const*> (first=0xaa95e0, second=0xa50720) at /usr/include/QtCore/qobject.h:468
#8  activatableLessThan (first=0xaa95e0, second=0xa50720) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:184
#9  0x00007fd57c55b293 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., t=@0x953b50, lessThan=0x7fd57c55a730 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:358
#10 0x00007fd57c55ab48 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#12 0x00007fd57c54b943 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:144
#13 0x00007fd57c547308 in ActivatableList::qt_metacall (this=0x928c80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1b0757e0) at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:74
#14 0x00007fd59676dc7f in QMetaObject::activate (sender=0xa85b60, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#15 0x00007fd57c0d8341 in Knm::InterfaceConnection::setActivationState (this=0xa85b60, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#16 0x00007fd57c32213d in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0xa1be30, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#17 0x00007fd57c322169 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0xa1be30, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#18 0x00007fd57c3242a7 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#19 0x00007fd57c322aa6 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#20 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>) at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#21 0x00007fd57c2f9eb0 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x9444b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1b0759a0) at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#22 0x00007fd59676dc7f in QMetaObject::activate (sender=0x935720, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff1b0759a0) at kernel/qobject.cpp:3272
#23 0x00007fd57d9e57ae in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:100
#24 0x00007fd57d9e59c3 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x935720, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1b075af0) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager.moc:83
#25 0x00007fd57d9e5d90 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x935720, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1b075af0) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/networkmanager_p.moc:76
#26 0x00007fd59676dc7f in QMetaObject::activate (sender=0x912940, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff1b075af0) at kernel/qobject.cpp:3272
#27 0x00007fd57d5c1b4e in Solid::Control::Ifaces::NetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.2/build/libs/solid/control/ifaces/networkmanager.moc:108
#28 0x00007fd57b81130b in NMNetworkManager::qt_metacall (this=0x912940, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1b075c50) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/manager.moc:97
#29 0x00007fd59676dc7f in QMetaObject::activate (sender=0x944af0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff1b075c50) at kernel/qobject.cpp:3272
#30 0x00007fd57b808b81 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:176
#31 0x00007fd57b80d566 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x944af0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fff1b075e80) at /usr/src/debug/kdebase-workspace-4.5.2/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#32 0x00007fd593b6fd28 in QDBusConnectionPrivate::deliverCall (this=0x92f5f0, object=0x944af0, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#33 0x00007fd593b7adef in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#34 0x00007fd59676c8fa in QObject::event (this=0x944af0, e=<value optimized out>) at kernel/qobject.cpp:1211
#35 0x00007fd59590df64 in QApplicationPrivate::notify_helper (this=0x6d0990, receiver=0x944af0, e=0xc57500) at kernel/qapplication.cpp:4396
#36 0x00007fd59591638a in QApplication::notify (this=<value optimized out>, receiver=0x944af0, e=0xc57500) at kernel/qapplication.cpp:4277
#37 0x00007fd5973d2436 in KApplication::notify (this=0x7fff1b076960, receiver=0x944af0, event=0xc57500) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#38 0x00007fd596758aac in QCoreApplication::notifyInternal (this=0x7fff1b076960, receiver=0x944af0, event=0xc57500) at kernel/qcoreapplication.cpp:732
#39 0x00007fd59675c255 in sendEvent (receiver=0x0, event_type=0, data=0x60f3e0) at kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60f3e0) at kernel/qcoreapplication.cpp:1373
#41 0x00007fd596783633 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#43 0x00007fd5922b06e3 in g_main_dispatch (context=0x6d2a60) at gmain.c:2149
#44 g_main_context_dispatch (context=0x6d2a60) at gmain.c:2702
#45 0x00007fd5922b0ec0 in g_main_context_iterate (context=0x6d2a60, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#46 0x00007fd5922b1160 in g_main_context_iteration (context=0x6d2a60, may_block=1) at gmain.c:2843
#47 0x00007fd5967837cf in QEventDispatcherGlib::processEvents (this=0x616cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#48 0x00007fd5959b1efe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007fd596757ee2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#50 0x00007fd5967580f5 in QEventLoop::exec (this=0x7fff1b0768b0, flags=...) at kernel/qeventloop.cpp:201
#51 0x00007fd59675c50b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#52 0x00007fd586fd0657 in kdemain (argc=1, argv=0x6aad30) at /usr/src/debug/kdelibs-4.5.2/kded/kded.cpp:894
#53 0x00000000004074f9 in launch (argc=1, _name=0x40b3bb "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b257 "0") at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:723
#54 0x0000000000409d0a in main (argc=4, argv=0x7fff1b077958, envp=0x7fff1b077980) at /usr/src/debug/kdelibs-4.5.2/kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-08 23:08:25 UTC

*** This bug has been marked as a duplicate of bug 210878 ***