Bug 253921 - konqueror crashes when js closes the window
Summary: konqueror crashes when js closes the window
Status: RESOLVED DOWNSTREAM
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 256752 256753 270882 279344 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-12 08:35 UTC by Michal Hlavinka
Modified: 2011-08-04 12:55 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.17 KB, text/plain)
2010-10-12 10:23 UTC, Jaroslav Reznik
Details
VG log (319.70 KB, text/plain)
2010-10-12 11:02 UTC, Tommi Tervo
Details
New crash information added by DrKonqi (5.16 KB, text/plain)
2010-10-21 00:30 UTC, Martin Naď
Details
New crash information added by DrKonqi (4.00 KB, text/plain)
2010-12-05 21:24 UTC, Dyrver Eriksson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Hlavinka 2010-10-12 08:35:33 UTC
Application: konqueror (4.5.2 (KDE 4.5.2))
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35.6-39.fc14.x86_64 x86_64
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed:
1) open http://www.cyklomania.cz/velkyobrazek.php?url=/imgs/products/EtZpD/177416_main_large.jpg as the only window in konqueror

2) click on "kliknutím zavřete okno"

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f9f63c7cca5 in AdBlock::~AdBlock (this=0x17d13a0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/konq-plugins-4.4.0/adblock/adblock.cpp:109
#7  0x00007f9f63c7cd39 in AdBlock::~AdBlock (this=0x17d13a0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/konq-plugins-4.4.0/adblock/adblock.cpp:115
#8  0x00000032a9168d9f in QObjectPrivate::deleteChildren() () from /usr/lib64/libQtCore.so.4
#9  0x00000032a916ed10 in QObject::~QObject() () from /usr/lib64/libQtCore.so.4
#10 0x0000003db9a21fa2 in KParts::Part::~Part (this=0x1870de0, __vtt_parm=0x3dc2501b50, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kparts/part.cpp:189
#11 0x0000003dc1e246a3 in KHTMLPart::~KHTMLPart (this=0x1870de0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/khtml/khtml_part.cpp:540
#12 0x0000003dc1e24819 in KHTMLPart::~KHTMLPart (this=0x1870de0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/khtml/khtml_part.cpp:587
#13 0x00000032a9168c50 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#14 0x0000003db33b360c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#15 0x0000003db33b8c5d in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x0000003db5e20416 in KApplication::notify (this=0x7fffa2f10350, receiver=0x1870de0, event=0x1b8a510) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#17 0x00000032a91579bc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#18 0x00000032a915afd2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#19 0x00000032a917fec3 in ?? () from /usr/lib64/libQtCore.so.4
#20 0x000000329e441e33 in g_main_dispatch (context=0x14305f0) at gmain.c:2149
#21 g_main_context_dispatch (context=0x14305f0) at gmain.c:2702
#22 0x000000329e442610 in g_main_context_iterate (context=0x14305f0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#23 0x000000329e4428ad in g_main_context_iteration (context=0x14305f0, may_block=1) at gmain.c:2843
#24 0x00000032a917fa03 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#25 0x0000003db345452e in ?? () from /usr/lib64/libQtGui.so.4
#26 0x00000032a9156802 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#27 0x00000032a9156adc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#28 0x00000032a915b259 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#29 0x0000003db26b28da in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-4.5.2/apps/konqueror/src/konqmain.cpp:219
#30 0x000000329e81ee7d in __libc_start_main (main=0x400880 <main(int, char**)>, argc=4, ubp_av=0x7fffa2f10bf8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffa2f10be8) at libc-start.c:226
#31 0x00000000004007a9 in _start ()

Reported using DrKonqi
Comment 1 Jaroslav Reznik 2010-10-12 10:23:46 UTC
Created attachment 52433 [details]
New crash information added by DrKonqi

konqueror (4.5.1 (KDE 4.5.1)) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:

http://www.kde-apps.org/ and select some application, click on screenshot thumbnail and then close "screenshots" window.

-- Backtrace (Reduced):
#6  0x00007fdb67f8cca5 in AdBlock::~AdBlock (this=0x3a3acd0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/konq-plugins-4.4.0/adblock/adblock.cpp:109
#7  0x00007fdb67f8cd39 in AdBlock::~AdBlock (this=0x3a3acd0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/konq-plugins-4.4.0/adblock/adblock.cpp:115
#8  0x00000032acd6e224 in QObjectPrivate::deleteChildren (this=0x3ace7e0) at kernel/qobject.cpp:1949
#9  0x00000032acd72d62 in QObject::~QObject (this=0x3ace630, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#10 0x00000032bd221a92 in KParts::Part::~Part (this=0x3ace630, __vtt_parm=0x32c8302510, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.1/kparts/part.cpp:189
Comment 2 Tommi Tervo 2010-10-12 11:02:16 UTC
Created attachment 52439 [details]
VG log
Comment 3 Maksim Orlovich 2010-10-12 17:20:22 UTC
@ Tommi: that looks different.

The issue here is the same as a c15 on bug #234624... Which I thought I fixed, but apparently didn't.
Comment 4 Maksim Orlovich 2010-10-12 17:49:04 UTC
SVN commit 1185208 by orlovich:

Fix the regression due to the 'don't forget to delete the label' fix --- the label may also get deleted before us 
in the window.close case, so guard against that.

This cleanup order thing sure is messy (and not just here, also with view vs. part, etc.) :(

CCBUG: 234624
CCBUG: 253921


 M  +15 -13    adblock.cpp  
 M  +2 -1      adblock.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1185208
Comment 5 Tommi Tervo 2010-10-12 18:08:39 UTC
Weird, I'll get that adblock bt on bug: 234624#15 which is now fixed, but here I'll get an assert:

konqueror: /home/teve/kde/kdelibs/kjs/interpreter.cpp:269: virtual
KJS::Interpreter::~Interpreter(): Assertion `m_startTimeoutCheckCount == 0'
failed.

similar assert (bug: 230122) which I cannot reproduce anymore .. Oh well
Comment 6 Martin Naď 2010-10-21 00:30:02 UTC
Created attachment 52709 [details]
New crash information added by DrKonqi

konqueror (4.5.2 (KDE 4.5.2)) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

- What I was doing when the application crashed:
close window with picture (click to picture) on page
http://kde-look.org/content/show.php/Tenuto-Light+KDE4+KDE3+GTK++theme?content=121885

- Unusual behavior I noticed:
KDE desktop is too slow (but this doing all the time when is open more window)
for example open new tab  it takes 5s (normal is 1s)

-- Backtrace (Reduced):
#6  0x00007f5b6fc1dca5 in AdBlock::~AdBlock (this=0xbfa3630, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/konq-plugins-4.4.0/adblock/adblock.cpp:109
#7  0x00007f5b6fc1dd39 in AdBlock::~AdBlock (this=0xbfa3630, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/konq-plugins-4.4.0/adblock/adblock.cpp:115
#8  0x0000003b1636e224 in QObjectPrivate::deleteChildren (this=0xc2a4c10) at kernel/qobject.cpp:1949
#9  0x0000003b16372d62 in QObject::~QObject (this=0xc2a4ad0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#10 0x0000003b22821fa2 in KParts::Part::~Part (this=0xc2a4ad0, __vtt_parm=0x3b2e701b50, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kparts/part.cpp:189
Comment 7 Frank Reininghaus 2010-11-13 12:02:40 UTC
*** Bug 256752 has been marked as a duplicate of this bug. ***
Comment 8 Frank Reininghaus 2010-11-13 12:02:49 UTC
*** Bug 256753 has been marked as a duplicate of this bug. ***
Comment 9 Dyrver Eriksson 2010-12-05 21:24:35 UTC
Created attachment 54181 [details]
New crash information added by DrKonqi

konqueror (4.5.4 (KDE 4.5.4)) on KDE Platform 4.5.4 (KDE 4.5.4) using Qt 4.7.1

- What I was doing when the application crashed: It happens on both kde-look.org and other sites that open a pop-up javascript window example the bigger previews of themes. If I remember to close the window by clicking the close-button in the Window Decoration it won't crash, but as soon as I even touch the word "CLOSE" or the picture itself it closes down.

- Custom settings of the application: VLC or Gstreamer or Xine as backend makes no difference here.

-- Backtrace (Reduced):
#9  0xb6f1d0f7 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#10 0xb6f2198f in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#11 0xb4f19d05 in KParts::Part::~Part() () from /usr/lib/libkparts.so.4
#12 0xb4f1b00a in KParts::ReadOnlyPart::~ReadOnlyPart() () from /usr/lib/libkparts.so.4
#13 0xaeb4b2f7 in KHTMLPart::~KHTMLPart() () from /usr/lib/libkhtml.so.5
Comment 10 Christoph Feck 2011-04-19 19:54:12 UTC
Starting with KDE 4.5, the Konqueror extensions ("konq-plugins") are shipped
part of Konqueror. Please uninstall any old konq-plugins packages (they are still from 4.4 version, as seen in the backtrace).

If your distribution still ships them separately, make sure you update them to
the correct version.
Comment 11 Christoph Feck 2011-04-19 19:54:26 UTC
*** Bug 270882 has been marked as a duplicate of this bug. ***
Comment 12 Martin Koller 2011-08-04 12:55:20 UTC
*** Bug 279344 has been marked as a duplicate of this bug. ***