Bug 253810 - Bluetooth kio slave does not list device, obexftp works
Summary: Bluetooth kio slave does not list device, obexftp works
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: bluetooth-kio-bt (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-11 06:46 UTC by Todd
Modified: 2011-07-17 01:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 1.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2010-10-11 06:46:07 UTC
Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

I am using an LG Env Touch.  If I click the "Bluetooth" place in dolphin with the phone attached, I get an empty folder.  However, if I right click on the bluetooth system tray icon, select the device, and click "Browse Device", the obexftp: kio slave opens just fine and show the device's folders.  I can even add the device to the place panel.  However, even when the device is paired, the obexftp kio slave is open, and it is transferring files off the phone, there is still nothing displayed in the Bluetooth kio slave.

Reproducible: Didn't try

Steps to Reproduce:
1. Make sure phone is connected
2. Open Dolphin
3. Click the "Bluetooth" place.

Actual Results:  
Device is not shown in the folder

Expected Results:  
Device is shown in the folder
Comment 1 Alex Fiestas 2010-10-11 21:37:44 UTC
It may be because your cell phone is not announcing the services it has, can you check it? maybe there is an option like "Make this cell phone visible", and is only in these moments where the services (browse files, send files, etc) are visibles to others.
Comment 2 Todd 2010-10-12 00:07:26 UTC
The bluedevil system tray entry has a "browse device" entry, so bluedevil knows it can browse for files on the device.  If the bluedevil system tray entry knows the device is browseable, should the bluetooth kio slave know as well?

But to answer your question, yes, when I set the phone to visible it appears.  

However, since many if not most devices are only visible for a short while, requiring the device to be visible before it appears in the bluetooth kio slave means it isn't very useful in many cases.  Shouldn't it display the same list of devices as the system tray icon?
Comment 3 Alex Fiestas 2010-10-12 11:23:05 UTC
Yes it should, and it will in 1.1/2, but for 1.0 kiobluetooth execute a scan, so all the data you get is the data that it can get "on the fly".

I'm going to set this as a wish, to do not forget it and implement it in the next versions.

Thanks for the feedback.
Comment 4 Alex Fiestas 2011-07-17 01:13:07 UTC
Git commit a8e7dc5ab8f48d70783c30522268d406bc691577 by Alex Fiestas.
Committed on 17/07/2011 at 02:42.
Pushed by afiestas into branch 'master'.

Show always the knownDevices while running a discovery at the background

This fixes one of the most hated behaviors of kio_bluetooth, before this
commit we were scanning always for new devices so in order to use your
device via kio_bluetooth it had to be in discoverable mode (and of
of course you had to wait a bit).
Now, we're showing always the knownDevices first, and start a
discovery each 20s. If a folder is acceed the discovery is stopped.

BUG: 253810
FIXED-IN: 1.2

M  +8    -3    src/daemon/kded/BlueDevilDaemon.h
M  +50   -7    src/daemon/kded/BlueDevilDaemon.cpp
M  +2    -0    src/kio/bluetooth/kded_bluedevil.xml
M  +3    -1    src/kio/bluetooth/kiobluetooth.cpp

http://commits.kde.org/bluedevil/a8e7dc5ab8f48d70783c30522268d406bc691577