Bug 253767 - Preview mode shows PDF, doesn't let one print or open with another program like okular/acroread
Summary: Preview mode shows PDF, doesn't let one print or open with another program li...
Status: RESOLVED DUPLICATE of bug 179066
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.15
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-10 18:45 UTC by Achim Herwig
Modified: 2010-10-21 01:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Achim Herwig 2010-10-10 18:45:05 UTC
Version:           2.15 (using KDE 4.5.2) 
OS:                Linux

I got a Mail with an attached zip file containing a PDF. When I clicked on it, ark opened and I had the possibiliity to click on the PDF. This opens a viewer that leave one without any options except paging back/forth. The is no possibility to open a file in another program. The only options is to unpack the archive to one of the already listed destinations, no possibility to freely choose a destination.

Reproducible: Always

Steps to Reproduce:
1. open zip file containing PDF
2. find a way to print it.

Actual Results:  
I found none.

Expected Results:  
Having the ability to open each file in the archive with a a selectable application. Alternatively, ability to extract the archive to a freely choosable destination.

OS: Linux (x86_64) release 2.6.31.14-0.1-desktop
Compiler: gcc
Comment 1 Raphael Kubo da Costa 2010-10-21 01:32:34 UTC
You can choose to extract the selected files to whatever destination you want by clicking the "Extract" button on the toolbar, pressing Ctrl+E or, from KDE SC 4.6.0 on, by choosing the "Extract..." option on the menu.

As for previewing a file with a separate application, that's a known wish.

Thanks for the report.

*** This bug has been marked as a duplicate of bug 179066 ***