Bug 253699 - settings/Channel visibility needs to supply a hint
Summary: settings/Channel visibility needs to supply a hint
Status: CLOSED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
: 261328 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-09 21:56 UTC by Karl
Modified: 2012-08-04 17:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl 2010-10-09 21:56:30 UTC
Version:           3.6 (using KDE 4.4.5) 
OS:                Linux

I figured this out - to change an "available Channel" to a "Visible Channel" is quite simple - just drag. But nothing hinted to this function. 

I left-clicked, Right-clicked, center-clicked, hit tabs and arrow keys with no joy.  Resorting to Google I found many others also puzzled with the interface.

The text on the Configure-kmix dialog says:

"Configuration of the channels."

If the text instead said:

"Configuration of the channels - Drag icon to update" 

All would be wonderful. 

Reproducible: Always
Comment 1 Burkhard Lück 2010-10-10 21:55:30 UTC
Confirmed, it is not obvious for Joe User how to change an "available Channel" to a "Visible Channel".
Comment 2 Martin Koller 2010-12-26 23:26:13 UTC
*** Bug 261328 has been marked as a duplicate of this bug. ***
Comment 3 Christian Esken 2012-08-04 17:54:05 UTC
Git commit 2c8d6e748eb228e33886e88548bb137af2e5f332 by Christian Esken.
Committed on 04/08/2012 at 19:51.
Pushed by esken into branch 'master'.

Give a usage hint in the dialog that configures the Controls in the View.

M  +1    -1    gui/dialogviewconfiguration.cpp

http://commits.kde.org/kmix/2c8d6e748eb228e33886e88548bb137af2e5f332