Bug 253567 - K3B Crashes when I open the settings menu [QFontDatabase::load]
Summary: K3B Crashes when I open the settings menu [QFontDatabase::load]
Status: RESOLVED DUPLICATE of bug 238819
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdeui (show other bugs)
Version: 4.5
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-08 07:26 UTC by Unknown
Modified: 2010-10-22 16:17 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (35.44 KB, application/bzip2)
2010-10-08 07:28 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2010-10-08 07:26:53 UTC
Version:           2.0.1 (using KDE 4.5.1) 
OS:                Linux

I opened the settings menu and the application crashed.

Here is the head of the log file:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff2daead7 in QFontDatabase::load (d=0xfeeb50, script=0) at text/qfontdatabase_x11.cpp:1905
1905    text/qfontdatabase_x11.cpp: Nincs ilyen fájl vagy könyvtár.
        in text/qfontdatabase_x11.cpp

#0  0x00007ffff2daead7 in QFontDatabase::load (d=0xfeeb50, script=0) at text/qfontdatabase_x11.cpp:1905
#1  0x00007ffff2d8cc27 in QFontPrivate::engineForScript (this=0xfeeb50, script=0) at text/qfont.cpp:270
#2  0x00007ffff2da0768 in QFontMetrics::height (this=<value optimized out>) at text/qfontmetrics.cpp:329
#3  0x00007ffff40cf550 in KCategoryDrawer::categoryHeight (this=<value optimized out>, index=<value optimized out>, option=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorydrawer.cpp:167

And after that, 22.100 times (!!!) the following:
#4  0x00007ffff41c9065 in KCategorizedView::Private::blockPosition (this=0xfe9820, category=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:219
#5  0x00007ffff41cc998 in KCategorizedView::visualRect (this=0xfe44e0, index=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:568
#6  0x00007ffff41c8bfa in KCategorizedView::Private::blockHeight (this=0xfe9820, category=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:247


Reproducible: Always




OS: Linux (x86_64) release 2.6.34.7-0.3-desktop
Compiler: gcc
Comment 1 Unknown 2010-10-08 07:28:54 UTC
Created attachment 52329 [details]
Backtrace

Qt: 4.7.0
KDE Development Platform: 4.5.2 (KDE 4.5.2)
K3b: 2.0.1
Comment 2 Pino Toscano 2010-10-08 10:36:21 UTC
From the backtrace:

#0  0x00007ffff2daead7 in QFontDatabase::load (d=0xfeeb50, script=0) at text/qfontdatabase_x11.cpp:1905
#1  0x00007ffff2d8cc27 in QFontPrivate::engineForScript (this=0xfeeb50, script=0) at text/qfont.cpp:270
#2  0x00007ffff2da0768 in QFontMetrics::height (this=<value optimized out>) at text/qfontmetrics.cpp:329
#3  0x00007ffff40cf550 in KCategoryDrawer::categoryHeight (this=<value optimized out>, index=<value optimized out>, option=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorydrawer.cpp:167
#4  0x00007ffff41c9065 in KCategorizedView::Private::blockPosition (this=0xfe9820, category=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:219
#5  0x00007ffff41cc998 in KCategorizedView::visualRect (this=0xfe44e0, index=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:568
#6  0x00007ffff41c8bfa in KCategorizedView::Private::blockHeight (this=0xfe9820, category=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:247
#7  0x00007ffff41c909a in KCategorizedView::Private::blockPosition (this=0xfe9820, category=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:223
[...]
#22104 0x00007ffff41c8bc9 in KCategorizedView::Private::blockHeight (this=0xfe9820, category=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:246
#22105 0x00007ffff41c909a in KCategorizedView::Private::blockPosition (this=0xfe9820, category=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:223
#22106 0x00007ffff41cc998 in KCategorizedView::visualRect (this=0xfe44e0, index=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/itemviews/kcategorizedview.cpp:568

Looks like a problem within KCategoryView, moving to kdelibs.
Comment 3 Christoph Feck 2010-10-08 13:07:49 UTC
> using KDE 4.5.1
[...]
> at /usr/src/debug/kdelibs-4.5.2

This bug should be fixed in the official 4.5.2 release.

Could you please ask your distribution which kdelibs version you have? You need at least r1181739 (which is after the initial 4.5.2 tag, but before retagging for release).

*** This bug has been marked as a duplicate of bug 238819 ***
Comment 4 Andrew Brouwers 2010-10-22 16:17:54 UTC
(In reply to comment #3)
> > using KDE 4.5.1
> [...]
> > at /usr/src/debug/kdelibs-4.5.2
> 
> This bug should be fixed in the official 4.5.2 release.
> 
> Could you please ask your distribution which kdelibs version you have? You need
> at least r1181739 (which is after the initial 4.5.2 tag, but before retagging
> for release).

Hello,

In the repository mentioned for the 4.5.2 packages, they were definitely built using the final 4.5.2 tarball; I have checked and confirmed our sources, and all seems well:

9f2ad67a40f233a72d374800e1c2d2e2  kdelibs-4.5.2.tar.bz2
9f2ad67a40f233a72d374800e1c2d2e2  kdelibs-4.5.2_suse.tar.bz2