Bug 253521 - knetwork-manager crash with segfault
Summary: knetwork-manager crash with segfault
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: knetworkmanager (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 17:34 UTC by cacao74
Modified: 2010-11-08 23:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
some hardware info (9.80 KB, text/plain)
2010-10-07 17:39 UTC, cacao74
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cacao74 2010-10-07 17:34:24 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.3-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
this error always occur on my laptop "sony vaio vpceb2b4e".
ethernet connection automatically works.
wireless connection remains down.

The crash can be reproduced every time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  0x00000000008430f0 in ?? ()
#6  0x00007f37a62eb7a9 in QMetaObject::cast(QObject*) const () from /usr/lib64/libQtCore.so.4
#7  0x00007f37a6d18a8a in qobject_cast<Knm::InterfaceConnection const*> (first=0x7a9500, second=0x7c0330) at /usr/include/QtCore/qobject.h:468
#8  activatableLessThan (first=0x7a9500, second=0x7c0330) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:183
#9  0x00007f37a6d1951a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x777d80, lessThan=0x7f37a6d18a20 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#10 0x00007f37a6d193d8 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:105
#12 0x00007f37a6d0a363 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:124
#13 0x00007f37a6d06030 in ActivatableList::qt_metacall (this=0x7818b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_activatablelist.cpp:72
#14 0x00007f37a62f9a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#15 0x00007f37a6f50991 in Knm::InterfaceConnection::setActivationState (this=0x7b74a0, state=<value optimized out>) at /usr/src/debug/networkmanagement/libs/internals/interfaceconnection.cpp:82
#16 0x00007f37a6ae13fd in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x7b7e50, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#17 0x00007f37a6ae1429 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x7b7e50, __in_chrg=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#18 0x00007f37a6ae2ddf in NMDBusActiveConnectionMonitor::handleRemove (this=<value optimized out>, removed=0x7b74a0)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:235
#19 0x00007f37a6d0a2a8 in ActivatableList::removeActivatable (this=<value optimized out>, activatable=0x7b74a0) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:112
#20 0x00007f37a6d0b850 in NetworkInterfaceActivatableProvider::handleRemove (this=0x7b7240, removedConnection=0x7c1180)
    at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:197
#21 0x00007f37a6d06cf6 in ConnectionList::removeConnection (this=<value optimized out>, connection=0x7c1180) at /usr/src/debug/networkmanagement/libs/service/connectionlist.cpp:136
#22 0x00007f37a6ae3f8f in NMDBusSettingsConnectionProvider::onRemoteConnectionRemoved (this=<value optimized out>)
    at /usr/src/debug/networkmanagement/backends/NetworkManager/nmdbussettingsconnectionprovider.cpp:130
#23 0x00007f37a6ab9eec in NMDBusSettingsConnectionProvider::qt_metacall (this=0x7af4b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff58455410)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nmdbussettingsconnectionprovider.cpp:82
#24 0x00007f37a62f9a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#25 0x00007f37a6aba6e0 in OrgFreedesktopNetworkManagerSettingsConnectionInterface::qt_metacall (this=0x79f820, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff58455750)
    at /usr/src/debug/networkmanagement/build/backends/NetworkManager/moc_nm-exported-connectioninterface.cpp:83
#26 0x00007f37a661d188 in QDBusConnectionPrivate::deliverCall (this=0x7663c0, object=0x79f820, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#27 0x00007f37a6629ecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#28 0x00007f37a62f7509 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#29 0x00007f37a56d74d4 in QApplicationPrivate::notify_helper (this=0x65b300, receiver=0x79f820, e=0x6b3640) at kernel/qapplication.cpp:4302
#30 0x00007f37a56dfaca in QApplication::notify (this=<value optimized out>, receiver=0x79f820, e=0x6b3640) at kernel/qapplication.cpp:4185
#31 0x00007f37a75f9c06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#32 0x00007f37a62e5e4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#33 0x00007f37a62e95ba in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#34 0x00007f37a630e173 in ?? () from /usr/lib64/libQtCore.so.4
#35 0x00007f37a17a8a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f37a17a9270 in ?? () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f37a17a9510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f37a630e67f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#39 0x00007f37a577814e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f37a62e5292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f37a62e5495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#42 0x00007f37a62e988b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#43 0x000000000040e88f in _start ()

Possible duplicates by query: bug 252410, bug 250798, bug 250541, bug 246485, bug 245614.

Reported using DrKonqi
Comment 1 cacao74 2010-10-07 17:39:02 UTC
Created attachment 52318 [details]
some hardware info
Comment 2 Christoph Feck 2010-11-08 23:08:56 UTC

*** This bug has been marked as a duplicate of bug 210878 ***