Bug 253496 - Fedora 10: Valgrind doesn't build anymore
Summary: Fedora 10: Valgrind doesn't build anymore
Status: RESOLVED FIXED
Alias: None
Product: valgrind
Classification: Developer tools
Component: general (show other bugs)
Version: 3.6 SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 12:56 UTC by Bart Van Assche
Modified: 2010-10-08 17:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bart Van Assche 2010-10-07 12:56:39 UTC
Version:           3.6 SVN (using Devel) 
OS:                Linux

Valgrind version: r11410
gcc version: gcc version 4.3.2 20081105 (Red Hat 4.3.2-7) (GCC)
binutils version: 2.18.50.0.9-8.fc10 20080822

Output of make -s:
[ ... ]
Making all in drd
Making all in .
drd_pthread_intercepts.c: Assembler messages:
drd_pthread_intercepts.c:1227: Error: CFI instruction used without previous .cfi
_startproc
drd_pthread_intercepts.c:1230: Error: CFI instruction used without previous .cfi
_startproc
[ ... ]


Reproducible: Always




Happens since r11402 (amd64-linux: add suitable CFI annotations).
Comment 1 Bart Van Assche 2010-10-08 17:55:40 UTC
Fixed in r11415.