Bug 253469 - KWin crashes on login after KDE update
Summary: KWin crashes on login after KDE update
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 05:15 UTC by Ignat Semenov
Modified: 2010-10-31 15:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ignat Semenov 2010-10-07 05:15:53 UTC
Application: kwin (4.5.2 (KDE 4.5.2))
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.33.8-149.fc13.x86_64 x86_64
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
- What I was doing when the application crashed:
After updating to KDE 4.5.2 from kde-testing (RedHat KDE project repository) KWin crashes every time on login and continues crashing repeatedly with the same backtrace. So the KDE desktop is unusable at the moment for me. KWin does work stable for a few seconds however every time it restarts, but this isn't enough even to close the crash handler.

- Custom settings of the application:

None, compositing is off.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x0000003c5b21dff2 in ?? () from /usr/lib64/libkdecore.so.5
#7  0x0000003c5b21f1f3 in KSharedDataCache::insert(QString const&, QByteArray const&) () from /usr/lib64/libkdecore.so.5
#8  0x0000003c5c48966d in KImageCache::insertImage(QString const&, QImage const&) () from /usr/lib64/libkdeui.so.5
#9  0x0000003c5c489a36 in KImageCache::insertPixmap(QString const&, QPixmap const&) () from /usr/lib64/libkdeui.so.5
#10 0x0000003c611b5f42 in ?? () from /usr/lib64/libplasma.so.3
#11 0x0000003c611bc064 in Plasma::Theme::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libplasma.so.3
#12 0x00007feb77556117 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#13 0x00007feb77550949 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#14 0x00007feb766d460c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#15 0x00007feb766d9c5d in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x0000003c5c41d126 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#17 0x00007feb7753f9bc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#18 0x00007feb7756a60a in ?? () from /usr/lib64/libQtCore.so.4
#19 0x00007feb7756a74c in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#20 0x00007feb767763ff in ?? () from /usr/lib64/libQtGui.so.4
#21 0x00007feb7753e802 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#22 0x00007feb7753eadc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#23 0x00007feb77543259 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#24 0x0000003c5ec4f906 in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#25 0x00000038cdc1ec5d in __libc_start_main () from /lib64/libc.so.6
#26 0x0000000000400839 in _start ()

This bug may be a duplicate of or related to bug 245172.

Possible duplicates by query: bug 245172.

Reported using DrKonqi
Comment 1 Martin Flöser 2010-10-07 08:14:54 UTC
The backtrace is rather useless as the debugging symbols are missing. Please attach a new backtrace.

From reading the possible duplicate: is it possible that your harddisk is full?
Comment 2 Ignat Semenov 2010-10-12 11:18:14 UTC
Hello Martin!

Sorry for the long delay, I solved this and forgot about it. Deleting the cache in /var/tmp/kdecache-$USERNAME (a method recommended by some guy on a blog or maybe by the developer of the cache himself) did help, the crashes stopped indeed, but now to trigger a crash I have to restore those files (PhotoRec maybe?). Unfortunately, the cache got overwritten in process (I'm mostly sure since it's in the same dir and even the same file name), so there's next to no chance of getting the old cache and thus reproducing the crash again. Is it possible to install the debug symbols and get the missing line?

There was a change in KPixmapCache that went into 4.5.2. See Michael Pyne's blog for details. That should be the last post.

As far as the hard disk being full, I'm sure it's not. No movies or music you see :)
Comment 3 Christoph Feck 2010-10-31 15:34:27 UTC

*** This bug has been marked as a duplicate of bug 253795 ***