Bug 253464 - KDE 4.5.2 crash after login
Summary: KDE 4.5.2 crash after login
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 02:28 UTC by Geraldo Augusto Vecchiato
Modified: 2010-10-18 19:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geraldo Augusto Vecchiato 2010-10-07 02:28:35 UTC
Application: krunner (0.1)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

I was trying to login into KDE.

- Unusual behavior I noticed:

Some times I can login but KDE opens Dr. Konqi several times but everything continues running. Some times, after login, KDE opens Dr. Konqi about 6 times and nothing works, I only get a black screen. No taskbar and no Desktop.

The crash can be reproduced every time.

-- Backtrace:
Application: Interface de execução de comandos (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fb41841b1f3 in SharedMemory::removeEntry (this=0x7fb3fec40000, index=1933) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1160
#7  0x00007fb41841c688 in KSharedDataCache::insert (this=0x1c526a0, key=..., data=...) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1269
#8  0x00007fb418c7d64d in KImageCache::insertImage (this=0x1c526a0, key=..., image=...) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:86
#9  0x00007fb418c7dcb6 in KImageCache::insertPixmap (this=0x1c526a0, key=..., pixmap=...) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:105
#10 0x00007fb40f8c5b45 in Plasma::ThemePrivate::scheduledCacheUpdate (this=0x1c77310) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/plasma/theme.cpp:272
#11 0x00007fb40f8c8192 in Plasma::Theme::qt_metacall (this=0x1c507b0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x7fffb60cc4c0) at /home/geraldoav/abs/kdelibs/src/build/plasma/theme.moc:119
#12 0x00007fb417edb2ff in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#13 0x00007fb417ed9e89 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#14 0x00007fb417079564 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x00007fb41707dfda in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007fb418c0f1f6 in KApplication::notify (this=0x1b48760, receiver=0x1c605b0, event=0x7fffb60ccc10) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#17 0x00007fb417ec5eac in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0x00007fb417ef3a22 in ?? () from /usr/lib/libQtCore.so.4
#19 0x00007fb417ef0834 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007fb413c26bf3 in g_main_dispatch (context=0x1b4b120) at gmain.c:2149
#21 g_main_context_dispatch (context=0x1b4b120) at gmain.c:2702
#22 0x00007fb413c273d0 in g_main_context_iterate (context=0x1b4b120, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#23 0x00007fb413c2766d in g_main_context_iteration (context=0x1b4b120, may_block=1) at gmain.c:2843
#24 0x00007fb417ef0f1f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007fb41711d29e in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007fb417ec5242 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007fb417ec548c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007fb417ec994b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x00007fb40b5b88f6 in kdemain () from /usr/lib/libkdeinit4_krunner.so
#30 0x0000000000406ae3 in launch (argc=1, _name=0x1b18798 "/usr/bin/krunner", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40aa62 "0") at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kinit/kinit.cpp:723
#31 0x0000000000407640 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kinit/kinit.cpp:1215
#32 0x0000000000407d35 in handle_requests (waitForPid=<value optimized out>) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kinit/kinit.cpp:1408
#33 0x0000000000408950 in main (argc=4, argv=0x7fffb60ce1c8, envp=0x7fffb60ce1f0) at /home/geraldoav/abs/kdelibs/src/kdelibs-4.5.2/kinit/kinit.cpp:1892

Reported using DrKonqi
Comment 1 Geraldo Augusto Vecchiato 2010-10-18 19:49:56 UTC

*** This bug has been marked as a duplicate of bug 253795 ***