Bug 253366 - klipper opens 2 directories in dolphin for one marked directory
Summary: klipper opens 2 directories in dolphin for one marked directory
Status: RESOLVED FIXED
Alias: None
Product: klipper
Classification: Unclassified
Component: general (show other bugs)
Version: 0.2
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-06 10:11 UTC by Toralf Förster
Modified: 2011-12-25 18:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster 2010-10-06 10:11:17 UTC
Version:           0.2 (using KDE 4.4.6) 
OS:                Linux

If I mark a string like /var/tmp/g-cpan within a window of KMail, then Klippers offers me to open it with Dolphin. If I choose that choice Dolphin shows 2 directories, the first is called "$HOME/%i", the 2nd is the expected "/var/tmp/g-cpan".


Reproducible: Didn't try




OS: Linux (i686) release 2.6.35.5
Compiler: i686-pc-linux-gnu-gcc
Comment 1 Toralf Förster 2011-03-09 11:18:21 UTC
issue still present in KDE 4.6.1
Comment 2 Jekyll Wu 2011-11-06 18:13:33 UTC
I can reproduce this every time with klipper 0.9.7 in KDE 4.7.3
Comment 3 Jekyll Wu 2011-11-06 18:59:39 UTC
And this sounds similar to or related with bug 262367
Comment 4 Jekyll Wu 2011-12-14 14:20:35 UTC
Mark it as duplicate of bug 262367, which contains more useful information.

*** This bug has been marked as a duplicate of bug 262367 ***
Comment 5 Jekyll Wu 2011-12-25 18:08:06 UTC
Git commit 45be8bcb3319a05305c19f9a9a6b18b611f6f6f3 by Jekyll Wu.
Committed on 25/12/2011 at 18:41.
Pushed by jekyllwu into branch 'KDE/4.8'.

Support the %i and %c filed codes in the Exec key of .desktop file

The code is not ideal. But it works in practice.
Related: bug 253366
FIXED-IN:4.8.0

M  +10   -1    klipper/urlgrabber.cpp

http://commits.kde.org/kde-workspace/45be8bcb3319a05305c19f9a9a6b18b611f6f6f3