Bug 253196 - kded crashes when service network-manager is re-started
Summary: kded crashes when service network-manager is re-started
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-04 04:18 UTC by Florian
Modified: 2010-11-08 23:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian 2010-10-04 04:18:47 UTC
Application: kded4 ($Id: kded.cpp 1031637 2009-10-05 16:58:19Z lunakl $)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
When I stop network-manager (# service network-manager stop) and start it again (# service network-manager start), kded crashes. It's not possible to access any wifi network again.

The crash can be reproduced every time.

 -- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f56b2461760 (LWP 6713))]

Thread 2 (Thread 0x7f5696eba710 (LWP 6985)):
#0  0x00007f56af44df83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f56abe104a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f56abe108fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f56b0a56406 in QEventDispatcherGlib::processEvents (this=0x2a1a0b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f56b0a2b6c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f56b0a2ba9c in QEventLoop::exec (this=0x7f5696eb9db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f56b093a8db in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f56b0a0bdd8 in QInotifyFileSystemWatcherEngine::run (this=0x2a1d740) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f56b093cf95 in QThreadPrivate::start (arg=0x2a1d740) at thread/qthread_unix.cpp:248
#9  0x00007f56b06ac9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f56af45a6fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f56b2461760 (LWP 6713)):
[KCrash Handler]
#5  0x0000000002988c10 in ?? ()
#6  0x00007f56b0a31b19 in QMetaObject::cast (this=0x7f569f38b8e0, obj=0x28a68f0) at kernel/qmetaobject.cpp:266
#7  0x00007f569ef3d1ca in qobject_cast<Knm::InterfaceConnection const*> (first=0x28a68f0, second=0x29c82f0) at /usr/include/qt4/QtCore/qobject.h:468
#8  activatableLessThan (first=0x28a68f0, second=0x29c82f0) at ../../../libs/service/sortedactivatablelist.cpp:183
#9  0x00007f569ef3d4ae in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=)
    at /usr/include/qt4/QtCore/qalgorithms.h:366
#10 0x00007f569ef3d5c1 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>)
    at /usr/include/qt4/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleUpdate (this=<value optimized out>) at ../../../libs/service/sortedactivatablelist.cpp:105
#12 0x00007f569ef2d8f3 in ActivatableList::activatableChanged (this=<value optimized out>) at ../../../libs/service/activatablelist.cpp:124
#13 0x00007f569ef28fa0 in ActivatableList::qt_metacall (this=0x266ec60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at moc_activatablelist.cpp:72
#14 0x00007f56b0a40036 in QMetaObject::activate (sender=0x29519b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4) at kernel/qobject.cpp:3295
#15 0x00007f569f176fa1 in Knm::InterfaceConnection::setActivationState (this=0x29519b0, state=42625264) at ../../../libs/internals/interfaceconnection.cpp:82
#16 0x00007f569ed03d1d in ~NMDBusActiveConnectionProxy (this=0x2b1e490, __in_chrg=<value optimized out>) at ../../../backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#17 0x00007f569ed03f7e in NMDBusActiveConnectionMonitor::handleRemove (this=<value optimized out>, removed=0x29519b0) at ../../../backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:235
#18 0x00007f569ef2db26 in ActivatableList::removeActivatable (this=<value optimized out>, activatable=<value optimized out>) at ../../../libs/service/activatablelist.cpp:112
#19 0x00007f569ef2f46a in NetworkInterfaceActivatableProvider::handleRemove (this=<value optimized out>, removedConnection=0x2977e60)
    at ../../../libs/service/networkinterfaceactivatableprovider.cpp:197
#20 0x00007f569ef2aa4e in ConnectionList::removeConnection (this=<value optimized out>, connection=0x2977e60) at ../../../libs/service/connectionlist.cpp:136
#21 0x00007f569ed0723e in NMDBusSettingsConnectionProvider::onRemoteConnectionRemoved (this=<value optimized out>) at ../../../backends/NetworkManager/nmdbussettingsconnectionprovider.cpp:130
#22 0x00007f569ecd855c in NMDBusSettingsConnectionProvider::qt_metacall (this=0x2556220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffee102000)
    at moc_nmdbussettingsconnectionprovider.cpp:82
#23 0x00007f56b0a40036 in QMetaObject::activate (sender=0x29779f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4) at kernel/qobject.cpp:3295
#24 0x00007f569ecd8465 in OrgFreedesktopNetworkManagerSettingsConnectionInterface::qt_metacall (this=0x29779f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffee102370)
    at moc_nm-exported-connectioninterface.cpp:83
#25 0x00007f56aedef5a6 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#26 0x00007f56aedf9fef in QDBusCallDeliveryEvent::placeMetaCall (this=0x2a37300, object=0x28a68f0) at qdbusintegrator_p.h:101
#27 0x00007f56b0a3cb79 in QObject::event (this=0x29779f0, e=0x27cfb50) at kernel/qobject.cpp:1248
#28 0x00007f56afbc9c0c in QApplicationPrivate::notify_helper (this=0x2467480, receiver=0x29779f0, e=0x27cfb50) at kernel/qapplication.cpp:4302
#29 0x00007f56afbd00eb in QApplication::notify (this=0x7fffee102e60, receiver=0x29779f0, e=0x27cfb50) at kernel/qapplication.cpp:4185
#30 0x00007f56b0f75a16 in KApplication::notify (this=0x7fffee102e60, receiver=0x29779f0, event=0x27cfb50) at ../../kdeui/kernel/kapplication.cpp:302
#31 0x00007f56b0a2cd9c in QCoreApplication::notifyInternal (this=0x7fffee102e60, receiver=0x29779f0, event=0x27cfb50) at kernel/qcoreapplication.cpp:726
#32 0x00007f56b0a30454 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x23d6c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x23d6c30) at kernel/qcoreapplication.cpp:1367
#34 0x00007f56b0a56873 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#35 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#36 0x00007f56abe0c8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#37 0x00007f56abe10748 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007f56abe108fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#39 0x00007f56b0a563b3 in QEventDispatcherGlib::processEvents (this=0x23d8140, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#40 0x00007f56afc7a18e in QGuiEventDispatcherGlib::processEvents (this=0x28a68f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f56b0a2b6c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007f56b0a2ba9c in QEventLoop::exec (this=0x7fffee102db0, flags=) at kernel/qeventloop.cpp:201
#43 0x00007f56b0a3073b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#44 0x00007f56a5a8dd47 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kded.cpp:932
#45 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#46 0x000000000040902f in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1788

Reported using DrKonqi
Comment 1 e-kde 2010-10-07 02:27:21 UTC
I can confirm this bug.
It happens to me every time i stop networkmanager.
I am running KDE 4.5.2 on gentoo.
Comment 2 Christoph Feck 2010-11-08 23:09:06 UTC

*** This bug has been marked as a duplicate of bug 210878 ***