Bug 252995 - "sudo restart network-manager"causes crash
Summary: "sudo restart network-manager"causes crash
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-02 07:11 UTC by Tom Sutherland
Modified: 2010-10-23 16:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Sutherland 2010-10-02 07:11:33 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu maverick (development branch)

-- Information about the crash:
Wireless connection seemed to stop working, in an attempt to fix, I ran "sudo restart network-manager"  which resulted in a crash.

syslog does seems to indicate that the actual service shut down and started up gracefully.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fab531a9760 (LWP 2659))]

Thread 2 (Thread 0x7fab3bb45710 (LWP 2662)):
#0  0x00007fab4fec61e3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fab4d0be009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fab4d0be45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fab51c031e6 in QEventDispatcherGlib::processEvents (this=0x1174940, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fab51bd5a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fab51bd5dec in QEventLoop::exec (this=0x7fab3bb44df0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fab51ae02fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fab51ae327e in QThreadPrivate::start (arg=0x11852a0) at thread/qthread_unix.cpp:266
#8  0x00007fab51858971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007fab4fed292d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fab531a9760 (LWP 2659)):
[KCrash Handler]
#6  0x00007fab3a0d56aa in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0x00007fab39e9be07 in ?? () from /usr/lib/libknmservice.so.4
#8  0x00007fab39e9bf03 in ?? () from /usr/lib/libknmservice.so.4
#9  0x00007fab39e9c15e in ?? () from /usr/lib/libknmservice.so.4
#10 0x00007fab39e9c490 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0x00007fab39e8bd4b in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x00007fab39e90282 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#13 0x00007fab39e8db81 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#14 0x00007fab39e8cb60 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#15 0x00007fab39e8696d in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#16 0x00007fab51beeb27 in QMetaObject::activate (sender=0x11ca8f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x29) at kernel/qobject.cpp:3280
#17 0x00007fab3cc95f05 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x7fff0a96efb0, _t1=<value optimized out>) at ./networkmanager.moc:107
#18 0x00007fab3cc968bc in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x11ca8f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0a96f720) at ./networkmanager_p.moc:81
#19 0x00007fab51beeb27 in QMetaObject::activate (sender=0x11c9df0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x29) at kernel/qobject.cpp:3280
#20 0x00007fab3c8729d5 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x7fff0a96efb0, _t1=<value optimized out>) at ./networkmanager.moc:115
#21 0x00007fab3937adea in NMNetworkManager::deviceAdded (this=0x11c9df0, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#22 0x00007fab3937eae9 in NMNetworkManager::qt_metacall (this=0x11c9df0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0a96f900) at ./manager.moc:95
#23 0x00007fab51beeb27 in QMetaObject::activate (sender=0x11d9b50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x29) at kernel/qobject.cpp:3280
#24 0x00007fab39388802 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x7fff0a96efb0, _t1=<value optimized out>) at ./nm-manager-clientinterface.moc:155
#25 0x00007fab39388c74 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x11d9b50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff0a96fd60) at ./nm-manager-clientinterface.moc:102
#26 0x00007fab51f2d0ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#27 0x00007fab51f380ef in QDBusCallDeliveryEvent::placeMetaCall (this=0x7fff0a96efb0, object=0x1279610) at qdbusintegrator_p.h:103
#28 0x00007fab51be8bde in QObject::event (this=0x11d9b50, e=0x7fff0a96efb0) at kernel/qobject.cpp:1219
#29 0x00007fab50ac5fdc in QApplicationPrivate::notify_helper (this=0x104c6d0, receiver=0x11d9b50, e=0x123c9b0) at kernel/qapplication.cpp:4396
#30 0x00007fab50acbaed in QApplication::notify (this=0x7fff0a970850, receiver=0x11d9b50, e=0x123c9b0) at kernel/qapplication.cpp:4277
#31 0x00007fab52ba8156 in KApplication::notify (this=0x7fff0a970850, receiver=0x11d9b50, event=0x123c9b0) at ../../kdeui/kernel/kapplication.cpp:310
#32 0x00007fab51bd6cdc in QCoreApplication::notifyInternal (this=0x7fff0a970850, receiver=0x11d9b50, event=0x123c9b0) at kernel/qcoreapplication.cpp:732
#33 0x00007fab51bd9c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xfafb00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xfafb00) at kernel/qcoreapplication.cpp:1373
#35 0x00007fab51c03653 in sendPostedEvents (s=0x1050140) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#36 postEventSourceDispatch (s=0x1050140) at kernel/qeventdispatcher_glib.cpp:277
#37 0x00007fab4d0ba342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#38 0x00007fab4d0be2a8 in ?? () from /lib/libglib-2.0.so.0
#39 0x00007fab4d0be45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#40 0x00007fab51c03193 in QEventDispatcherGlib::processEvents (this=0xfb1d30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#41 0x00007fab50b78a6e in QGuiEventDispatcherGlib::processEvents (this=0x7fff0a96efb0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007fab51bd5a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#43 0x00007fab51bd5dec in QEventLoop::exec (this=0x7fff0a9707a0, flags=) at kernel/qeventloop.cpp:201
#44 0x00007fab51bd9ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#45 0x00007fab438dbbf7 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kded.cpp:894
#46 0x0000000000407713 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40ab27 "0") at ../../kinit/kinit.cpp:723
#47 0x000000000040970f in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1835

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-23 16:03:35 UTC

*** This bug has been marked as a duplicate of bug 210878 ***