Bug 252840 - Kontact does not really quit at exit, and it cannot be restarted
Summary: Kontact does not really quit at exit, and it cannot be restarted
Status: RESOLVED DUPLICATE of bug 222878
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-30 11:11 UTC by Claudio Barbiero
Modified: 2011-04-06 16:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Barbiero 2010-09-30 11:11:22 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
In kontact, in Kmail, dopo aver richiesto la ricerca di nuovi messaggi per un account,Kontact esegue la ricerca e resta su di essa, senza terminarla; anche dopo
la chiusura manuale reata attivo e non permette il riavvio

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7874990 (LWP 1553))]

Thread 2 (Thread 0xb15deb70 (LWP 1576)):
#0  0x01190344 in __pthread_mutex_unlock_usercnt () from /lib/tls/i686/cmov/libpthread.so.0
#1  0x044d9be6 in pthread_mutex_unlock () from /lib/tls/i686/cmov/libc.so.6
#2  0x02c741eb in g_main_context_release () from /lib/libglib-2.0.so.0
#3  0x02c760e3 in ?? () from /lib/libglib-2.0.so.0
#4  0x02c764b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x007f660f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x007c9059 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x007c94aa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x006c55a8 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x007a8c1b in ?? () from /usr/lib/libQtCore.so.4
#10 0x006c832e in ?? () from /usr/lib/libQtCore.so.4
#11 0x0118c96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x044cca4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7874990 (LWP 1553)):
[KCrash Handler]
#6  0xb353e7a3 in KMKernel::config() () from /usr/lib/libkmailprivate.so.4
#7  0xb3621402 in KMMainWidget::writeConfig() () from /usr/lib/libkmailprivate.so.4
#8  0xb3619690 in KMMainWidget::destruct() () from /usr/lib/libkmailprivate.so.4
#9  0xb361aefe in KMMainWidget::~KMMainWidget() () from /usr/lib/libkmailprivate.so.4
#10 0x007da18f in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#11 0x06df7873 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#12 0x007da18f in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#13 0x06df83d3 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#14 0x071ed2d1 in QFrame::~QFrame() () from /usr/lib/libQtGui.so.4
#15 0x07259515 in QStackedWidget::~QStackedWidget() () from /usr/lib/libQtGui.so.4
#16 0x007da18f in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#17 0x06df83d3 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#18 0x071ed2d1 in QFrame::~QFrame() () from /usr/lib/libQtGui.so.4
#19 0x07258163 in QSplitter::~QSplitter() () from /usr/lib/libQtGui.so.4
#20 0x007da18f in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#21 0x06df7873 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#22 0x007da18f in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#23 0x06df83d3 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#24 0x0720b041 in QMainWindow::~QMainWindow() () from /usr/lib/libQtGui.so.4
#25 0x00f9cc34 in KMainWindow::~KMainWindow() () from /usr/lib/libkdeui.so.5
#26 0x00fe1ff8 in KXmlGuiWindow::~KXmlGuiWindow() () from /usr/lib/libkdeui.so.5
#27 0x001332e9 in KParts::MainWindow::~MainWindow() () from /usr/lib/libkparts.so.4
#28 0x0015b120 in KontactInterface::Core::~Core() () from /usr/lib/libkontactinterface.so.4
#29 0x00ae62ee in Kontact::MainWindow::~MainWindow() () from /usr/lib/libkontactprivate.so.4
#30 0x007d9d65 in qDeleteInEventHandler(QObject*) () from /usr/lib/libQtCore.so.4
#31 0x007db428 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#32 0x06df0326 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#33 0x0720bbc7 in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#34 0x00f9ab04 in KMainWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#35 0x00fe288f in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#36 0x06d924dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#37 0x06d990f9 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#38 0x00ea8f2a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#39 0x007caa3b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#40 0x007cd473 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#41 0x007cd5dd in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#42 0x007f6adf in ?? () from /usr/lib/libQtCore.so.4
#43 0x02c725e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0x02c762d8 in ?? () from /lib/libglib-2.0.so.0
#45 0x02c764b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0x007f65d5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0x06e52135 in ?? () from /usr/lib/libQtGui.so.4
#48 0x007c9059 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#49 0x007c94aa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#50 0x007cd69f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#51 0x06d92577 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#52 0x0804b472 in _start ()

Reported using DrKonqi
Comment 1 Pino Toscano 2010-09-30 12:02:30 UTC
(In reply to comment #0)
> In kontact, in Kmail, dopo aver richiesto la ricerca di nuovi messaggi per un
> account,Kontact esegue la ricerca e resta su di essa, senza terminarla; anche
> dopo
> la chiusura manuale reata attivo e non permette il riavvio

Kmail embedded in kontact: after started the new email check for an account, the check does not really terminate (literally "it stay on the email check"); after exiting kontact it does not really quit, not allowing it to be restarted.

PS: please report bugs in English.
Comment 2 Jan-Willem van de Meent 2010-11-11 12:24:32 UTC
I am experiencing this bug as well. If kontact is exited while an e-mail check (cached imap) is in progress, the window is closed but the kontact process does not terminate and needs to be killed manually.

This behaviour is in itself annoying enough -- since most users may not realise the reason why kontact fails to restart. What is worse is that the imap cache occasionally seems to get corrupted. Every month or so I need to re-download my 1 GB archive from gmail, which takes a long time.

Since the kdepim 4.5 release still seems some time off, is there any chance of getting a fix for this on a point release?
Comment 3 Christophe Marin 2011-04-06 16:18:11 UTC

*** This bug has been marked as a duplicate of bug 222878 ***