Bug 252771 - XGetErrorDatabaseText crash (XrmQGetResource, NETWinInfo::update)
Summary: XGetErrorDatabaseText crash (XrmQGetResource, NETWinInfo::update)
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 253326 257454 260273 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-29 17:01 UTC by mps
Modified: 2018-11-28 04:56 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mps 2010-09-29 17:01:12 UTC
Application: kalarm (2.4.7)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-56.fc13.x86_64 x86_64
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
- What I was doing when the application crashed:

Create a new display alarm 20 mins from now. Add a sound file (any of the KDE .oggs). Click play to test the sound. Click on in the add sound fie dialog. Boom.

The crash can be reproduced every time.

-- Backtrace:
Application: KAlarm (kalarm), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f2274dec820 (LWP 2705))]

Thread 2 (Thread 0x7f22698c7710 (LWP 14755)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000030cc02f1f2 in LoopRequest (data=0x315e630) at playlist/thread.c:539
#2  Thread (data=0x315e630) at playlist/thread.c:586
#3  0x00000030de607761 in start_thread (arg=0x7f22698c7710) at pthread_create.c:301
#4  0x00000030ddae14ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f2274dec820 (LWP 2705)):
[KCrash Handler]
#6  __pthread_mutex_lock (mutex=0x0) at pthread_mutex_lock.c:50
#7  0x00000030e0649b37 in XrmQGetResource (db=0x3276c90, names=<value optimized out>, classes=<value optimized out>, pType=0x7fffaadabd1c, pValue=0x7fffaadabd60) at Xrm.c:2538
#8  0x00000030e064a4dc in XrmGetResource (db=0x3276c90, name_str=<value optimized out>, class_str=0x30e06aba10 "ErrorType.ErrorNumber", pType_str=0x7fffaadabd78, pValue=<value optimized out>)
    at Xrm.c:2580
#9  0x00000030e0623a4b in XGetErrorDatabaseText (dpy=<value optimized out>, name=0x30e06aba26 "XProtoError", type=0x7fffaadaddd0 "3", defaultp=0x30e06aba7d "BadWindow", buffer=
    0x7fffaadae1c0 "\340\024\177\002", nbytes=256) at ErrDes.c:197
#10 0x00000030e0623d8e in XGetErrorText (dpy=0x2084110, code=3, buffer=0x7fffaadae1c0 "\340\024\177\002", nbytes=256) at ErrDes.c:116
#11 0x000000383501cd04 in qt_x_errhandler (dpy=0x2084110, err=0x7fffaadae340) at kernel/qapplication_x11.cpp:684
#12 0x0000003837e1bca3 in KApplication::xErrhandler (this=0x204a0c0, dpy=0x2084110, err_=0x7fffaadae340) at /usr/src/debug/kdelibs-4.5.1/kdeui/kernel/kapplication.cpp:432
#13 0x00000030e0646b24 in _XError (dpy=0x2084110, rep=0x2c19670) at XlibInt.c:3103
#14 0x00000030e064d6a6 in _XReply (dpy=0x2084110, rep=<value optimized out>, extra=0, discard=0) at xcb_io.c:513
#15 0x00000030e062a457 in XGetWindowProperty (dpy=0x2084110, w=58794337, property=304, offset=0, length=1, delete=<value optimized out>, req_type=304, actual_type=0x7fffaadae610, actual_format=
    0x7fffaadae61c, nitems=0x7fffaadae608, bytesafter=0x7fffaadae600, prop=0x7fffaadae5f8) at GetProp.c:64
#16 0x0000003837f4361b in NETWinInfo::update (this=0x7fffaadae830, dirty_props=<value optimized out>) at /usr/src/debug/kdelibs-4.5.1/kdeui/windowmanagement/netwm.cpp:3921
#17 0x0000003837f44c76 in NETWinInfo::event (this=0x7fffaadae830, event=0x7fffaadaeef0, properties=0x7fffaadae800, properties_size=2)
    at /usr/src/debug/kdelibs-4.5.1/kdeui/windowmanagement/netwm.cpp:3886
#18 0x0000003837f3b920 in KWindowSystemPrivate::x11Event (this=0x299e960, ev=0x7fffaadaeef0) at /usr/src/debug/kdelibs-4.5.1/kdeui/windowmanagement/kwindowsystem_x11.cpp:162
#19 0x0000003837e1b97e in publicx11Event (this=<value optimized out>, _event=0x7fffaadaeef0) at /usr/src/debug/kdelibs-4.5.1/kdeui/kernel/kapplication.cpp:915
#20 KApplication::x11EventFilter (this=<value optimized out>, _event=0x7fffaadaeef0) at /usr/src/debug/kdelibs-4.5.1/kdeui/kernel/kapplication.cpp:966
#21 0x000000383501bcd1 in qt_x11EventFilter (ev=0x7fffaadaeef0) at kernel/qapplication_x11.cpp:408
#22 0x000000383502b1a0 in QApplication::x11ProcessEvent (this=0x204a0c0, event=0x7fffaadaeef0) at kernel/qapplication_x11.cpp:3248
#23 0x00000038350548d2 in x11EventSourceDispatch (s=0x2056120, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#24 0x00000030dfa3bd02 in g_main_dispatch (context=0x2054620) at gmain.c:1960
#25 IA__g_main_context_dispatch (context=0x2054620) at gmain.c:2513
#26 0x00000030dfa3fae8 in g_main_context_iterate (context=0x2054620, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#27 0x00000030dfa3fc9c in IA__g_main_context_iteration (context=0x2054620, may_block=1) at gmain.c:2654
#28 0x000000383377f953 in QEventDispatcherGlib::processEvents (this=0x201fe80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#29 0x000000383505444e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x0000003833756752 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x0000003833756a2c in QEventLoop::exec (this=0x7fffaadaf220, flags=...) at kernel/qeventloop.cpp:201
#32 0x0000003835455f0e in QDialog::exec (this=0x26379c0) at dialogs/qdialog.cpp:552
#33 0x00000000004d2325 in KAlarm::execNewAlarmDlg (editDlg=0x26379c0, alreadyExecuted=<value optimized out>) at /usr/src/debug/kdepim-4.4.5/kalarm/functions.cpp:939
#34 0x00000000004d26e0 in KAlarm::editNewAlarm (type=<value optimized out>, parent=<value optimized out>) at /usr/src/debug/kdepim-4.4.5/kalarm/functions.cpp:883
#35 0x000000000049677c in slotNew (this=0x22a6220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffaadaf410) at /usr/src/debug/kdepim-4.4.5/kalarm/mainwindow.cpp:673
#36 slotNewDisplay (this=0x22a6220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffaadaf410) at /usr/src/debug/kdepim-4.4.5/kalarm/mainwindow.h:99
#37 MainWindow::qt_metacall (this=0x22a6220, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffaadaf410)
    at /usr/src/debug/kdepim-4.4.5/x86_64-redhat-linux-gnu/kalarm/mainwindow.moc:149
#38 0x000000383376e067 in QMetaObject::activate (sender=0x23ac690, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffaadaf410) at kernel/qobject.cpp:3272
#39 0x0000003834fad412 in QAction::triggered (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#40 0x0000003834fae84b in QAction::activate (this=0x23ac690, event=<value optimized out>) at kernel/qaction.cpp:1256
#41 0x00000038353d2989 in QMenuPrivate::activateCausedStack (this=0x23aca50, causedStack=..., action=0x23ac690, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:993
#42 0x00000038353d80fa in QMenuPrivate::activateAction (this=0x23aca50, action=0x23ac690, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1085
#43 0x0000003837ee67be in KMenu::mouseReleaseEvent (this=0x23abcc0, e=<value optimized out>) at /usr/src/debug/kdelibs-4.5.1/kdeui/widgets/kmenu.cpp:471
#44 0x0000003834ffe326 in QWidget::event (this=0x23abcc0, event=0x7fffaadb0060) at kernel/qwidget.cpp:8187
#45 0x00000038353d96bb in QMenu::event (this=0x23abcc0, e=0x7fffaadb0060) at widgets/qmenu.cpp:2410
#46 0x0000003834fb360c in QApplicationPrivate::notify_helper (this=0x2057a50, receiver=0x23abcc0, e=0x7fffaadb0060) at kernel/qapplication.cpp:4396
#47 0x0000003834fb948e in QApplication::notify (this=<value optimized out>, receiver=0x23abcc0, e=0x7fffaadb0060) at kernel/qapplication.cpp:3959
#48 0x0000003837e1be66 in KApplication::notify (this=0x204a0c0, receiver=0x23abcc0, event=0x7fffaadb0060) at /usr/src/debug/kdelibs-4.5.1/kdeui/kernel/kapplication.cpp:310
#49 0x000000383375790c in QCoreApplication::notifyInternal (this=0x204a0c0, receiver=0x23abcc0, event=0x7fffaadb0060) at kernel/qcoreapplication.cpp:732
#50 0x0000003834fb80ce in sendEvent (receiver=0x23abcc0, event=0x7fffaadb0060, alienWidget=0x0, nativeWidget=0x23abcc0, buttonDown=0x3835a6c898, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#51 QApplicationPrivate::sendMouseEvent (receiver=0x23abcc0, event=0x7fffaadb0060, alienWidget=0x0, nativeWidget=0x23abcc0, buttonDown=0x3835a6c898, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3058
#52 0x000000383502d3ad in QETWidget::translateMouseEvent (this=0x23abcc0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4337
#53 0x000000383502b928 in QApplication::x11ProcessEvent (this=0x204a0c0, event=0x7fffaadb0980) at kernel/qapplication_x11.cpp:3536
#54 0x00000038350548d2 in x11EventSourceDispatch (s=0x2056120, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#55 0x00000030dfa3bd02 in g_main_dispatch (context=0x2054620) at gmain.c:1960
#56 IA__g_main_context_dispatch (context=0x2054620) at gmain.c:2513
#57 0x00000030dfa3fae8 in g_main_context_iterate (context=0x2054620, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#58 0x00000030dfa3fc9c in IA__g_main_context_iteration (context=0x2054620, may_block=1) at gmain.c:2654
#59 0x000000383377f953 in QEventDispatcherGlib::processEvents (this=0x201fe80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#60 0x000000383505444e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x0000003833756752 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#62 0x0000003833756a2c in QEventLoop::exec (this=0x7fffaadb0cb0, flags=...) at kernel/qeventloop.cpp:201
#63 0x000000383375b1a9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#64 0x00000000004576ef in main (argc=3, argv=0x7fffaadb1be8) at /usr/src/debug/kdepim-4.4.5/kalarm/main.cpp:127

Reported using DrKonqi
Comment 1 David Jarvie 2010-10-04 14:23:28 UTC
I assume you mean that it crashes when you "click OK in the add sound file dialog". I can't reproduce the bug.

This looks like it could be a packaging fault - the crash occurs within the KDE window management and X Windows libraries - so I suggest you report it to Fedora. Please add a link in the KDE bug report to point to the Fedora bug report, so that we can monitor progress.
Comment 2 Christoph Feck 2010-12-19 16:11:08 UTC
*** Bug 253326 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2010-12-19 16:11:37 UTC
*** Bug 257454 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2010-12-19 16:12:11 UTC
*** Bug 260273 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2011-10-14 14:23:00 UTC
According to https://bugs.freedesktop.org/show_bug.cgi?id=4373 this could be related to libxine. Are you using the xine Phonon backend?
Comment 6 Andrew Crouthamel 2018-10-29 22:35:47 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Bug Janitor Service 2018-11-13 14:28:13 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Bug Janitor Service 2018-11-28 04:56:55 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!