Bug 252668 - Can't connect to WPA Enterprise networks
Summary: Can't connect to WPA Enterprise networks
Status: RESOLVED DUPLICATE of bug 209673
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-28 17:59 UTC by niburu1
Modified: 2011-07-21 01:58 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description niburu1 2010-09-28 17:59:15 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

I can't connect to eduroam networks using knetworkmanager. However, I CAN connect using nm-applet instead (with the same settings).

Reproducible: Always
Comment 1 Ben Cooksley 2010-11-16 07:38:10 UTC
Updating based on further details obtained via KDE Forums:

http://forum.kde.org/viewtopic.php?f=18&t=91270
http://forum.kde.org/viewtopic.php?f=18&t=91441
Comment 2 Daniel Lee 2010-11-16 11:42:42 UTC
Have the same problem. It seems the certificate can't be parsed. Here's the output from /var/log/wpa_supplicant.log:

Trying to associate with 00:14:a8:14:7d:60 (SSID='UMRnet_students' freq=2462 MHz)
Association request to the driver failed
Associated with 00:14:a8:14:7d:60
CTRL-EVENT-EAP-STARTED EAP authentication started
CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
OpenSSL: tls_connection_ca_cert - Failed to parse ca_cert_blob error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
OpenSSL: pending error: error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
TLS: Failed to set TLS connection parameters
EAP-TTLS: Failed to initialize SSL.
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Authentication with 00:00:00:00:00:00 timed out.
Comment 3 niburu1 2010-11-16 12:36:09 UTC
Running "cat cacert.pem | grep -v "CERTIFICATE" | base64 -d > cacert.dem", where cacert.pem is the input certificate, and cacert.dem is the output, worked for me. This requires having a local copy of the certificate. The workaround is described in the bug https://bugs.kde.org/show_bug.cgi?id=209673.
Comment 4 markuss 2011-03-29 01:20:24 UTC
(In reply to comment #0)

> I can't connect to eduroam networks using knetworkmanager. However, I CAN
> connect using nm-applet instead (with the same settings).

Works for me. However I found that in KNM you have to enter "Anonymous Identity" whereas in nm-applet that's not always needed.
Comment 5 Lamarque V. Souza 2011-07-21 01:58:10 UTC

*** This bug has been marked as a duplicate of bug 209673 ***