Bug 252377 - I go to "http://www.xiph.org/video/vid1.shtml" and konqueror crash
Summary: I go to "http://www.xiph.org/video/vid1.shtml" and konqueror crash
Status: RESOLVED DOWNSTREAM
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-25 21:23 UTC by Gali
Modified: 2010-09-25 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gali 2010-09-25 21:23:57 UTC
Version:           unspecified (using KDE 4.4.5) 
OS:                Linux

Application: Konqueror (konqueror), signal: Segmentation fault
pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S
[Current thread is 1 (Thread 0x7ffdacd77760 (LWP 362))]

Thread 10 (Thread 0x7ffd8ee45710 (LWP 417)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007ffd8f370f41 in ?? () from /usr/lib/libxine.so.1
#2  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7ffd84d75710 (LWP 418)):
#0  0x00007ffdac6218d3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007ffd8f399c25 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007ffd8f37e969 in ?? () from /usr/lib/libxine.so.1
#3  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7ffd84574710 (LWP 419)):
[KCrash Handler]
#5  0x00007ffd8f384cbf in xine_event_dispose_queue () from /usr/lib/libxine.so.1
#6  0x00007ffd7ab9f594 in ?? () from /usr/lib/xine/plugins/1.29/xineplug_dmx_matroska.so
#7  0x00007ffd8f37a0f0 in ?? () from /usr/lib/libxine.so.1
#8  0x00007ffd8f36f4db in xine_open () from /usr/lib/libxine.so.1
#9  0x00007ffd8f60b81d in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x00007ffd8f60fdb6 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#11 0x00007ffda952b32c in QApplicationPrivate::notify_helper (this=0xb1b4f0, receiver=0x19dc4f0, e=0x2abc850) at kernel/qapplication.cpp:4302
#12 0x00007ffda953180b in QApplication::notify (this=0x7fff0f7bd170, receiver=0x19dc4f0, e=0x2abc850) at kernel/qapplication.cpp:4185
#13 0x00007ffdaadee836 in KApplication::notify (this=0x7fff0f7bd170, receiver=0x19dc4f0, event=0x2abc850) at ../../kdeui/kernel/kapplication.cpp:302
#14 0x00007ffdaa4060bc in QCoreApplication::notifyInternal (this=0x7fff0f7bd170, receiver=0x19dc4f0, event=0x2abc850) at kernel/qcoreapplication.cpp:726
#15 0x00007ffdaa409764 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x19db0b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x19db0b0) at kernel/qcoreapplication.cpp:1367
#17 0x00007ffdaa42fb93 in sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#18 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#19 0x00007ffda57536f2 in g_main_dispatch (context=0x19db5a0) at /scratch/build-area/glib2.0-2.24.2/glib/gmain.c:1960
#20 IA__g_main_context_dispatch (context=0x19db5a0) at /scratch/build-area/glib2.0-2.24.2/glib/gmain.c:2513
#21 0x00007ffda5757568 in g_main_context_iterate (context=0x19db5a0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /scratch/build-area/glib2.0-2.24.2/glib/gmain.c:2591
#22 0x00007ffda575771c in IA__g_main_context_iteration (context=0x19db5a0, may_block=1) at /scratch/build-area/glib2.0-2.24.2/glib/gmain.c:2654
#23 0x00007ffdaa42f6d3 in QEventDispatcherGlib::processEvents (this=0x11b5fc0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#24 0x00007ffdaa4049e2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#25 0x00007ffdaa404dbc in QEventLoop::exec (this=0x7ffd84573dc0, flags=) at kernel/qeventloop.cpp:201
#26 0x00007ffdaa31477b in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#27 0x00007ffd8f602400 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#28 0x00007ffdaa316e15 in QThreadPrivate::start (arg=0x19daeb0) at thread/qthread_unix.cpp:248
#29 0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#30 0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#31 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7ffd83b6f710 (LWP 420)):
#0  0x00007ffdac61d113 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffd9429fadf in ?? () from /usr/lib/libpulse.so.0
#2  0x00007ffd9428fb76 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007ffd94290f59 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007ffd94291010 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007ffd9429f8eb in ?? () from /usr/lib/libpulse.so.0
#6  0x00007ffd93e59700 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#8  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ffd7f36d710 (LWP 421)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffd8f381aab in ?? () from /usr/lib/libxine.so.1
#2  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7ffd7914b710 (LWP 425)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007ffdaa317dd2 in wait (this=<value optimized out>, mutex=0x18855e0, time=30000) at thread/qwaitcondition_unix.cpp:85
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x18855e0, time=30000) at thread/qwaitcondition_unix.cpp:159
#3  0x00007ffdaa30ce01 in QThreadPoolThread::run (this=0x18ce440) at concurrent/qthreadpool.cpp:140
#4  0x00007ffdaa316e15 in QThreadPrivate::start (arg=0x18ce440) at thread/qthread_unix.cpp:248
#5  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ffd7eb6c710 (LWP 426)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffd8f37476b in ?? () from /usr/lib/libxine.so.1
#2  0x00007ffd8f37a68d in ?? () from /usr/lib/libxine.so.1
#3  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ffd7e36b710 (LWP 427)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffd8f37476b in ?? () from /usr/lib/libxine.so.1
#2  0x00007ffd8f37b6e5 in ?? () from /usr/lib/libxine.so.1
#3  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffd7db44710 (LWP 429)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffd8f384beb in ?? () from /usr/lib/libxine.so.1
#2  0x00007ffda5e038ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007ffdac62802d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffdacd77760 (LWP 362)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x00007ffdaa316795 in thread_sleep (ti=0x7fff0f7bcb70) at thread/qthread_unix.cpp:398
#2  0x00007ffdaa3168f0 in QThread::msleep (msecs=<value optimized out>) at thread/qthread_unix.cpp:424
#3  0x00007ffd8f629b1a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#4  0x00007ffd946f5887 in ?? () from /usr/lib/libphonon.so.4
#5  0x00007ffdac58f5e2 in __run_exit_handlers (status=1, listp=0x7ffdac8b44a8, run_list_atexit=true) at exit.c:78
#6  0x00007ffdac58f635 in exit (status=259771124) at exit.c:100
#7  0x00007ffda1349fa6 in gdk_x_io_error (display=0x7ffdac67df0a) at /build/buildd-gtk+2.0_2.20.1-1+b1-amd64-3ZYTFH/gtk+2.0-2.20.1/gdk/x11/gdkmain-x11.c:524
#8  0x00007ffdaadee258 in KApplication::xioErrhandler (this=0x7fff0f7bd170, dpy=0xb31dd0) at ../../kdeui/kernel/kapplication.cpp:408
#9  0x00007ffdab960e3e in _XIOError () from /usr/lib/libX11.so.6
#10 0x00007ffdab96825f in ?? () from /usr/lib/libX11.so.6
#11 0x00007ffdab968b97 in _XEventsQueued () from /usr/lib/libX11.so.6
#12 0x00007ffdab951463 in XEventsQueued () from /usr/lib/libX11.so.6
#13 0x00007ffda95db34c in x11EventSourceCheck (s=0xb1f2f0) at kernel/qguieventdispatcher_glib.cpp:87
#14 0x00007ffda575692a in IA__g_main_context_check (context=0xb1e120, max_priority=2147483647, fds=<value optimized out>, n_fds=-1) at /scratch/build-area/glib2.0-2.24.2/glib/gmain.c:2469
#15 0x00007ffda57572e3 in g_main_context_iterate (context=0xb1e120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /scratch/build-area/glib2.0-2.24.2/glib/gmain.c:2588
#16 0x00007ffda575771c in IA__g_main_context_iteration (context=0xb1e120, may_block=1) at /scratch/build-area/glib2.0-2.24.2/glib/gmain.c:2654
#17 0x00007ffdaa42f6d3 in QEventDispatcherGlib::processEvents (this=0xafef80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#18 0x00007ffda95db18e in QGuiEventDispatcherGlib::processEvents (this=0x7fff0f7bcaf4, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#19 0x00007ffdaa4049e2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#20 0x00007ffdaa404dbc in QEventLoop::exec (this=0x7fff0f7bcf60, flags=) at kernel/qeventloop.cpp:201
#21 0x00007ffdaa409a4b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#22 0x00007ffdac97d75b in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/konqueror/src/konqmain.cpp:257
#23 0x00007ffdac577c4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff0f7bdb48) at libc-start.c:228
#24 0x0000000000400679 in _start ()

Reproducible: Didn't try

Steps to Reproduce:
I go to "http://www.xiph.org/video/vid1.shtml" and konqueror crash


Expected Results:  
I go to "http://www.xiph.org/video/vid1.shtml" and konqueror crash
Comment 1 Christoph Feck 2010-09-25 22:00:12 UTC
This crash is caused by a bug in libxine. Please report it to http://bugs.xine-project.org/

> [KCrash Handler]
> #5  0x00007ffd8f384cbf in xine_event_dispose_queue () from /usr/lib/libxine.so.1
> #6  0x00007ffd7ab9f594 in ?? () from /usr/lib/xine/plugins/1.29/xineplug_dmx_matroska.so
> #7  0x00007ffd8f37a0f0 in ?? () from /usr/lib/libxine.so.1
> #8  0x00007ffd8f36f4db in xine_open () from /usr/lib/libxine.so.1