Bug 252288 - plasma hangs when internet connection becomes unavailable
Summary: plasma hangs when internet connection becomes unavailable
Status: RESOLVED DUPLICATE of bug 184062
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.5 and older
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-24 22:07 UTC by Moritz Augustin
Modified: 2012-05-17 18:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
screenshot of desktop (300.70 KB, image/png)
2010-09-24 22:07 UTC, Moritz Augustin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Augustin 2010-09-24 22:07:14 UTC
Created attachment 51965 [details]
screenshot of desktop

Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

I can reproduce plasma hanging for a while. 

Just shutdown router or change default gateway to a host in your ip network which does not exist so ip packets get a time out.
Then plasma does not respond. No Kickoff, no program start no mouse reaction to any control bar...

I think the problem could be connected to kopete or skype (I use the skype wrapper in kopete) BUT plasma should never hang even if some application is doing wrong!

The only plasma applets with internet connection is pyweather.

Reproducible: Always

Steps to Reproduce:
1) have a working internet connection (you should have ;))
2) shutdown your router or change the default route to an ip which does not exist, i.e. in linux with iproute2 type as root: 
> ip ro
this should give something like 'default via 192.168.178.1 dev eth0'
then remember the adress and type
> ip ro change default via 192.168.178.123
be sure 192.168.178.123 does not exist in your network so you get time outs
3) wait plasma to hang for minutes with a little wake-up then hang again, and so on until the network connection is available again

maybe you have to open the programs i have (i think it could be skype or kopete (i use the skype wrapper in kopete))

Actual Results:  
plasma hangs for minutes, wakes up for seconds, hangs for minutes,wakes up for seconds,...

Expected Results:  
plasma should never hang

have installed kopete, skype and use the skype through kopete wrapper
gui plasma configuration see screenshot
Comment 1 Aaron J. Seigo 2010-09-25 01:43:36 UTC
do you have any remote locations in your "Places" listing? nfs drives mounted?
Comment 2 Moritz Augustin 2010-09-25 10:09:33 UTC
in places there are following online-links:
- one sftp
- ine link to local afs director /afs/....

but no nfs, no samba
Comment 3 Alexander Potashev 2011-01-06 23:39:10 UTC
Duplicate of bug#184062 ?
Comment 4 Myriam Schweingruber 2012-05-17 18:20:28 UTC

*** This bug has been marked as a duplicate of bug 184062 ***