Bug 252185 - Imap sync impossible after loosing internet connexion (Disconnected mode unchecked)
Summary: Imap sync impossible after loosing internet connexion (Disconnected mode unch...
Status: RESOLVED DUPLICATE of bug 258271
Alias: None
Product: KMail Mobile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks: 252225
  Show dependency treegraph
 
Reported: 2010-09-23 23:17 UTC by Sabine Faure
Modified: 2011-01-21 21:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sabine Faure 2010-09-23 23:17:06 UTC
Version:           unspecified (using Devel) 
OS:                Linux

After disconnecting the N900 from a wifi connection on purpose while 'Enable disconnected mode' check box unchecked, the imap resource refuses to sync after reconnecting the N900.

The Imap resource seems stuck (does not do anything anymore but still displays 'Ready')

Reproducible: Didn't try

Steps to Reproduce:
- Launch Kmail-mobile
- Connect the N900 to the wifi
- Click on your Imap account
- Open the 'Actions' tab
- Click on 'Account'
- Click on 'Edit account'
- Uncheck the ' Enable Disconnected Mode' check box
- Click on 'Write new email' (ex: Email 1)
- Enter a subject, a few words (ex: testing disconnected mode disabled) and a
recipient
- Click on 'Send'
- Reopen 'Actions' tab
- Click on 'Synchronize emails in account'
- Go to your Imap inbox and check that Email 1 is listed in the Message list
- DO NOT click on the email
- Disconnect the N900 from the wifi
- Go back to the Imap inbox and click on Email 1 to read its content in the
Message viewer.
- The email content should not appear since there is no internet connection
- Reconnect the N900 to the wifi connection
- Sync the Imap inbox

Actual Results:  
Nothing happens. The Imap resource seems stuck and won't sync anymore.

Only a restart of Akonadi server will make the Imap resource sync again and only then the user can read Email 1 content.

The pb is that this functionality is not available from the N900. Atm only developers and testers can do that from terminals on desktop computers.

Expected Results:  
Maybe having a restart akonadi server functionality in Kmail-mobile would be a solution so that the user is not stuck with a non working app if he willingly decides to uncheck the 'Enable Disconnected Mode'.

N900, 4:4.5~20100922.1178352-1maemo1.1177763
Comment 1 Volker Krause 2010-11-29 16:30:15 UTC

*** This bug has been marked as a duplicate of bug 258271 ***
Comment 2 Sabine Faure 2011-01-21 21:31:55 UTC
I retested this bug today and I can still reproduce it.

Atm there is no error message saying that something is wrong and no way to restart akonadi server from the N900 which is the only solution for the user to be able to read emails again.

N900, 4:4.6~.20110118.1600.git254268b-1maemo1.121498