Bug 252111 - KSnapshot and "Open with" don't work
Summary: KSnapshot and "Open with" don't work
Status: RESOLVED DUPLICATE of bug 240051
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-23 10:42 UTC by Kane
Modified: 2010-09-23 14:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kane 2010-09-23 10:42:28 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

I can not open the screen taken with the Gimp

Reproducible: Always

Steps to Reproduce:
- press PrtScr key
- then try to open screenshot -> Open with -> Gimp image editor

Actual Results:  
Gimp says something like: "Opening '/home/kane/tmp/foo_fx_3.6.png' failed: Could not open '/home/kane/tmp/foo_fx_3.6.png' for reading: No such file or directory"

Expected Results:  
Gimp open the screenshot

ksnapshot version 0.8.1
gimp version 2.6.8
Comment 1 Fri13 2010-09-23 12:50:49 UTC
I can confirm this. It happens with PNG fileformat if it was used last time with "Save as" function. 

If the last saved file format was JPEG, the "open with" will open the file correctly in later use/instances of the KSnapshot.

By some reason the KSnapshopt tries to offer non-saved file to external application last snapshot was stored as PNG. That can be noticed from the file path what external applications reports as missing. When last snapshot was saved as JPEG, the file gets always stored to $tmp directory. And if last snapshot was as PNG, the file is tried to be offered from the last stored directory and not from $tmp directory.
Comment 2 Christoph Feck 2010-09-23 14:07:39 UTC

*** This bug has been marked as a duplicate of bug 240051 ***