Bug 251898 - Can View calendar, folder selection and view buttons at the same time
Summary: Can View calendar, folder selection and view buttons at the same time
Status: VERIFIED FIXED
Alias: None
Product: KOrganizer Mobile
Classification: Unclassified
Component: calendar (show other bugs)
Version: unspecified
Platform: Maemo 5 Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: komo3
: 250671 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-21 10:14 UTC by Felix Wolfsteller
Modified: 2011-02-15 18:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Wolfsteller 2010-09-21 10:14:58 UTC
To reproduce, in 4:4.5~20100920.1177660-1maemo1.1177547.

0) Start korganizer-mobile.
1) Select a folder (tested with "Personal Calendar" without any other account set up),
2) Select Week View.
3) Open the flap.
4) Select View -> Back to Folder Selection
5) Press Cancel.

The following screen shows the folder selection ("home") scren, transparently overlayed above the calendar view.

Although cluttered, it somehow strangely does feel pretty useful and looks consistent.
Comment 1 Volker Krause 2010-10-13 15:29:52 UTC
Fixed by Tobias' recent application state tracking refactoring.
Comment 2 Volker Krause 2010-10-13 17:36:32 UTC
*** Bug 250671 has been marked as a duplicate of this bug. ***
Comment 3 Felix Wolfsteller 2010-10-13 19:39:07 UTC
"Back to folder selection" is wrongly worded. One expects to go back to the homescreen. Or to go to the "Folder selection" (or "Select Folders"?). The View that comes after touching "Back to Folder Selection" was surprising to me. Version 4:4.5~20101013.1185493-1maemo1.1185177 .
Comment 4 Felix Wolfsteller 2010-10-13 19:41:10 UTC
Last comments "new issue" also implicitely mentioned in the duplicate https://bugs.kde.org/show_bug.cgi?id=250671 .
Comment 5 Volker Krause 2010-10-14 10:29:06 UTC
SVN commit 1185761 by vkrause:

fix action names

BUG: 251898


 M  +3 -3      mobile/calendar/KorganizerActions.qml  
 M  +1 -1      mobile/contacts/KAddressBookActions.qml  
 M  +1 -0      mobile/mail/KMailActions.qml  
 M  +1 -1      mobile/notes/NoteActions.qml  
 M  +1 -1      mobile/tasks/TaskActions.qml  
 M  +2 -2      runtime/qml/akonadi/CollectionDelegate.qml  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1185761