Bug 251862 - Unable to add feed using command-line options
Summary: Unable to add feed using command-line options
Status: RESOLVED NOT A BUG
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 1.6.5
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-20 22:57 UTC by Oleg Atamanenko
Modified: 2014-01-22 21:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Atamanenko 2010-09-20 22:57:48 UTC
Version:           1.6.5 (using KDE 4.5.1) 
OS:                Linux

Akregator doesn't add feed from commandline if it is already running. Thus, it is impossible to configure firefox to add feed to akregator.

Also, it will be great if parameter --addfeed will not be required. (So, when user chooses akregator to use as web feed handler it will work as user expected. Nowdays akregator just shows its window and *nothing* happens).

Reproducible: Didn't try

Steps to Reproduce:
1. Start akregator.
2. Run from konsole akregator --addfeed http://feeds.feedburner.com/blogspot/hsDu


Actual Results:  
<unknown program name>(11052)/ main: akregator is already running, exiting.

Expected Results:  
Feed is added to the akregator.

OS: Linux (i686) release 2.6.35-ARCH
Compiler: gcc
Comment 1 Christophe Giboudeaux 2010-09-24 02:17:09 UTC
Works as expected in trunk, even if akregator is already running.

akregator <url> without --addfeed exists since 07/2007 (http://websvn.kde.org/?revision=683223&view=revision)