Bug 251855 - ksnapshot: open with: tries to open unexisting file (adds automatically a name)
Summary: ksnapshot: open with: tries to open unexisting file (adds automatically a name)
Status: RESOLVED DUPLICATE of bug 240051
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-20 21:17 UTC by Mark
Modified: 2010-09-23 14:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
suggested but not existing file name (109.98 KB, image/png)
2010-09-20 21:17 UTC, Mark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2010-09-20 21:17:59 UTC
Created attachment 51831 [details]
suggested but not existing file name

Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

use ksnapshot to take a snapshot of screen, for me, it automatically prepares a name for the picture by using the last one saved name plus a number increased by one. So on the example screenshot it's gwenview_err2.png 
'Save as' and 'copy to clipboard' options work flawlessly, but 'open with' causes error. The programs there assume the file is already saved, so gwenview complains about nonexisting file and kolour paint just falls back to an empty canvas.

Reproducible: Always

Steps to Reproduce:
take screenshot, go for Open with..

Actual Results:  
fails as file with auto-suggested name does not exist

Expected Results:  
use some temporary name to save the file eg to /tmp/ksnapshot-<process number or whatever random>.png
Comment 1 Stefan Fleiter 2010-09-22 11:04:47 UTC
I can confirm this bug with Ubuntu Maverick (10.10):

If a snapshot is taken by pressing the "print" key ksnapshot opens.
If I then press the "open with" button and choose a program like
gimp or gwenview WITHOUT saving the picture it tries to open 
"Bildschirmfoto1.png" in my home dir which does not exist.

If I save the picture as ksnapshot_bug.png in my home dir and afterwards
choose "open with" gwenview, it ries to open ksnapshot_bug1.png.

So there are 2 bugs:
- If the screenshot was not saved "open with" should create a temporary file
  first and open that with the chosen program.
- If the screenshot was saved either that file should be opened or a
  temporary file as before.
  Appending 1 or increasing the numer as reported by Marek is wrong.
Comment 2 Christoph Feck 2010-09-23 14:08:00 UTC

*** This bug has been marked as a duplicate of bug 240051 ***