Bug 251788 - copy fish -> fish or sftp ->sftp waits for a while and do nothig. fish <-> sftp works! o.O
Summary: copy fish -> fish or sftp ->sftp waits for a while and do nothig. fish <-> sf...
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: fish (show other bugs)
Version: 4.5
Platform: OpenSUSE Linux
: NOR major with 1 vote (vote)
Target Milestone: ---
Assignee: Jörg Walter
URL:
Keywords:
: 251301 267135 268119 268156 268214 269815 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-20 08:15 UTC by Suberu
Modified: 2011-04-01 13:09 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Suberu 2010-09-20 08:15:13 UTC
Version:           4.5 (using KDE 4.5.1) 
OS:                Linux

As above. Copying files from one remote fish server to another (using dolphin or krusader) can't work anymore (may be from 4.5 version - do not remember exactly). Instead of copying file it creates empty copy on destination server. Copy fish(1) -> my comp -> fish(2) works fine. Tried from sftp to sftp connected server - same behavior. Tried direct from fish to sfp (same servers) - works! But this is not good and not beautiful (:  

Reproducible: Always

Steps to Reproduce:
1) Go to first remote server through sftp or fish
2) Go to second remote server through sftp or fish (but same proto as to first!)
3) Try copy any file from one to another -> 

Actual Results:  
It will be doing copy forever until you cancel(:
And if you doing this through fish and files on source and destination the same (you wanted replace one by another) - destination file become truncated to zero bytes and transfer window continues to wait forever..........

Expected Results:  
File must be copied!

opensuse 11.3 x32, kde 4.5.1, all updated from stable update repos.
Comment 1 subscryer 2010-09-29 10:08:01 UTC
I can confirm the bit about sftp<->sftp, I have to use my local machine as a buffer and do the copy/move in two steps.
KDE 4.5.1 here.
Comment 2 mateusz-lists 2010-10-18 11:26:04 UTC
Perhaps it's is connected to fact that after upgrade to 4.5.2 form 4.4.x I am unable to make simultaneous operations on sftp://. Now have to wait to single operation (like copy/move) to finish, before I can even list directory contents in krusader. It was quite possible in pre 4.5.x versions of KDE.
Comment 3 Ralf Jung 2010-10-26 11:09:44 UTC
This might be related to bug 251301, if it is not even a duplicate.

(In reply to comment #2)
> Perhaps it's is connected to fact that after upgrade to 4.5.2 form 4.4.x I am
> unable to make simultaneous operations on sftp://. Now have to wait to single
> operation (like copy/move) to finish, before I can even list directory contents
> in krusader. It was quite possible in pre 4.5.x versions of KDE.
Same issue here, and quite annoying. Sometimes it works, and the "Do you want to overwrite" dialogue appears while the first transfer is still in progress. But often I have to wait till the first transfer finished, then cancel the stalled 2nd one and re-start it.
Comment 4 Andreas Hartmetz 2010-12-26 11:10:38 UTC
SVN commit 1209277 by ahartmetz:

Allow two connections per host, which is a common limit in my experience,
and allows copying/moving files on the same host.
BUG: 251788


 M  +2 -0      fish/fish.protocol  
 M  +2 -0      sftp/sftp.protocol  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1209277
Comment 5 Andreas Hartmetz 2010-12-26 11:13:13 UTC
*** Bug 251301 has been marked as a duplicate of this bug. ***
Comment 6 Andreas Schneider 2011-03-10 14:58:39 UTC
Git commit 8584f3b23dc71da8506058418a1ad03316f027c1 by Andreas Schneider. on behalf of Andreas Hartmetz
Committed on 26/12/2010 at 11:09.
Pushed by anschneider into branch 'KDE/4.6'.

Allow two connections per host, which is a common limit in my experience,
and allows copying/moving files on the same host.
BUG: 251788

svn path=/trunk/KDE/kdebase/runtime/; revision=1209277
(cherry picked from commit e31be89fd580c7a242505adadca6e9db6367070f)

M  +2    -0    kioslave/fish/fish.protocol     
M  +2    -0    kioslave/sftp/sftp.protocol     

http://commits.kde.org/kde-runtime/8584f3b23dc71da8506058418a1ad03316f027c1
Comment 7 Andreas Schneider 2011-03-10 15:00:00 UTC
*** Bug 267135 has been marked as a duplicate of this bug. ***
Comment 8 Suberu 2011-03-10 18:48:22 UTC
(In reply to comment #6)
> Git commit 8584f3b23dc71da8506058418a1ad03316f027c1 by Andreas Schneider. on
> behalf of Andreas Hartmetz
> Committed on 26/12/2010 at 11:09.
> Pushed by anschneider into branch 'KDE/4.6'.
> 
> Allow two connections per host, which is a common limit in my experience,
> and allows copying/moving files on the same host.
> BUG: 251788
> 
> svn path=/trunk/KDE/kdebase/runtime/; revision=1209277
> (cherry picked from commit e31be89fd580c7a242505adadca6e9db6367070f)
> 
> M  +2    -0    kioslave/fish/fish.protocol     
> M  +2    -0    kioslave/sftp/sftp.protocol     
> 
> http://commits.kde.org/kde-runtime/8584f3b23dc71da8506058418a1ad03316f027c1

Thanks! But this may be fixed problem of copying to the same server. 
Problem of copying from one remote server to another using same(!)(fish or sftp) protocol still exists - copying gets stuck and wait indefinitely. After manual cancelling that I'm getting null-byte file on server-receptor.

Tested this time on kde 4.6.0 (opensuse 11.4 x64)
Comment 9 Andreas Schneider 2011-03-11 10:09:36 UTC
*** Bug 268156 has been marked as a duplicate of this bug. ***
Comment 10 Frank Reininghaus 2011-03-11 12:44:44 UTC
*** Bug 268119 has been marked as a duplicate of this bug. ***
Comment 11 Frank Reininghaus 2011-03-11 12:47:56 UTC
(In reply to comment #8)
> Tested this time on kde 4.6.0 (opensuse 11.4 x64)

This is fixed in KDE 4.6.2 (not yet released). If you want the fix faster, you can either build KDE from source and apply the patch or ask your distribution to apply the fix to their packages.
Comment 12 Frank Reininghaus 2011-03-11 12:50:03 UTC
*** Bug 268214 has been marked as a duplicate of this bug. ***
Comment 13 Suberu 2011-03-11 19:02:41 UTC
(In reply to comment #11)
> This is fixed in KDE 4.6.2 (not yet released). If you want the fix faster, you

Thanks for clear info about that! (: Will be waiting till april (:
Comment 14 Frank Reininghaus 2011-04-01 13:09:43 UTC
*** Bug 269815 has been marked as a duplicate of this bug. ***