Bug 251749 - problems with transform tool: undo, handles, bigger selection
Summary: problems with transform tool: undo, handles, bigger selection
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools/Transform (show other bugs)
Version: 0.1
Platform: Unlisted Binaries Linux
: NOR normal
Target Milestone: ---
Assignee: Marc Pegon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-19 19:54 UTC by Adam C
Modified: 2013-01-20 10:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam C 2010-09-19 19:54:11 UTC
Version:           0.1
OS:                Linux

this is for transform2.
steps to reproduce:
1. create a second layer
2. draw a smilie into the middle of the second layer
3. scale the smilie (i have made it bigger)
= now the selection is bigger, than the scaled smilie
4. undo
= the smilie now appears in another place then it was drawn. maybe you even have to move the layer, so that it is visible again.
5. draw on the first layer "out of canvas" (that means start drawing in the canvas and then move the mouse into the gray area). i have drawn into every direction.
6. switch to transform tool
= now the handles are "out of canvas" and therefor not visible.
7. scale again (toolbox or move until the handles are visible)
8. undo
= again, the undo is not correct, as the layer is not on the original position.

Reproducible: Always




OS: Linux (x86_64) release 2.6.32-24-generic
Compiler: cc
Comment 1 Adam C 2010-09-19 23:02:20 UTC
another bug with position:
1. create an image with 16px*16px
2. draw something
3. click on transform tool
4. in the toolbox enter 90 degrees into the rotation field
5. click apply
6. the drawing vanishes.

this could be due to tile size
Comment 2 Halla Rempt 2010-10-14 21:08:17 UTC
Can you take a look?
Comment 3 Marc Pegon 2010-10-18 12:02:40 UTC
I'll try to take a look at it, though I am actually quite busy :/
Comment 4 Adam C 2010-10-31 17:14:00 UTC
this bug still happens here (tested on laptop and desktop computer):
1. create a second layer
2. draw a smilie into the middle of the second layer
3. scale the smilie (i have made it bigger)
4. undo
= the smilie now appears in another place then it was drawn. maybe you even

o "selection is bigger" doesn't happen
o "handles are "out of canvas" and therefor not visible" was fixed
o i've not retested comment #1
Comment 5 Dmitry Kazakov 2013-01-20 10:48:21 UTC
Git commit 0e3a6beaba892879fc0f15b2dba0ce5975911daf by Dmitry Kazakov.
Committed on 20/01/2013 at 11:43.
Pushed by dkazakov into branch 'krita-fixed-transform-kazakov'.

Ported Transform Tool to strokes

There is one regression: the actions inside a single transform stroke
(that is until you applied the transformation) cannot be undone yet.

The undo of the transformation as a whole works perfectly.
Related: bug 313294, bug 310559, bug 297929, bug 297927

M  +4    -7    krita/image/kis_selection_transaction_data.cpp
M  +4    -2    krita/image/kis_selection_transaction_data.h
M  +2    -2    krita/image/kis_transaction.h
M  +1    -1    krita/image/kis_transform_visitor.h
M  +1    -1    krita/plugins/extensions/imagesize/imagesize.cc
M  +2    -1    krita/plugins/tools/defaulttools/strokes/move_selection_stroke_strategy.cpp
M  +2    -1    krita/plugins/tools/defaulttools/strokes/move_stroke_strategy.cpp
M  +1    -0    krita/plugins/tools/tool_transform2/CMakeLists.txt
M  +248  -521  krita/plugins/tools/tool_transform2/kis_tool_transform.cc
M  +24   -24   krita/plugins/tools/tool_transform2/kis_tool_transform.h
M  +4    -4    krita/plugins/tools/tool_transform2/kis_tool_transform_config_widget.cpp
M  +1    -1    krita/plugins/tools/tool_transform2/kis_tool_transform_config_widget.h
A  +204  -0    krita/plugins/tools/tool_transform2/strokes/transform_stroke_strategy.cpp     [License: GPL (v2+)]
A  +97   -0    krita/plugins/tools/tool_transform2/strokes/transform_stroke_strategy.h     [License: GPL (v2+)]
M  +23   -7    krita/plugins/tools/tool_transform2/tool_transform_args.cc
M  +37   -8    krita/plugins/tools/tool_transform2/tool_transform_args.h
M  +2    -2    krita/ui/actions/kis_selection_action_factories.cpp
M  +1    -1    krita/ui/kis_mirror_visitor.cpp
M  +2    -2    krita/ui/tool/kis_selection_tool_helper.cpp

http://commits.kde.org/calligra/0e3a6beaba892879fc0f15b2dba0ce5975911daf