Bug 251651 - ShutdownModeDefault allways uses ShutdownModeInteractive
Summary: ShutdownModeDefault allways uses ShutdownModeInteractive
Status: RESOLVED WORKSFORME
Alias: None
Product: ksmserver
Classification: Unclassified
Component: general (show other bugs)
Version: 4.5 and older
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2010-09-18 12:15 UTC by linux
Modified: 2018-10-27 02:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description linux 2010-09-18 12:15:09 UTC
Version:           unspecified
OS:                Linux

ShutdownModeDefault would follow settings in KDM (DefaultSdMethod) if defined or must provide configuration options to allow users select default ShutdownMode.

By actual state is not possible bypass session list on shutdown/reboot computer nor by SystemSetting, nor by KDM settings and computer is not halted, because is waiting to confirm dialog.

I am sorry, my english do not allow me better description :-)

Reproducible: Always

Steps to Reproduce:
1, login KDE
2, open another session (remote, console, or so)
3. select shutdown/reboot computer

Actual Results:  
Always is showed confirmation dialog to close others sessions

Expected Results:  
There must be way to allow bypass this dialog - useful on single-user computers

This behavior can be related to kickoff settings (too) - i am not sure
Comment 1 linux 2010-09-18 12:19:15 UTC
hops, i forgot version - 4.4.5, from Debian testing
Comment 2 Oswald Buddenhagen 2010-10-24 00:52:02 UTC
kdm would have to expose that setting to the session somehow.
but i'm pondering removing that setting in the first place and making is a state variable instead (i.e., remember last used mode).
another problem is that ksmserver might not be able to actually execute forced mode anyway, as kdm's command socket rejects it if it is configured to require root authorization.
so this isn't going to be easy to fix. i'm pondering something like letting kdm show the actual in-session shutdown dialog including session kill selection and authorization and letting ksmserver do a "headless" shutdown.
but that's already in a different report ...
Comment 3 Myriam Schweingruber 2012-09-08 12:32:41 UTC
Is this still valid with KDE 4.9.x?
Comment 4 Andrew Crouthamel 2018-09-23 02:34:40 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Andrew Crouthamel 2018-10-27 02:48:25 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!