Bug 251537 - Panel puts ghost shadow on Desktop
Summary: Panel puts ghost shadow on Desktop
Alias: None
Product: plasma4
Classification: Plasma
Component: panel (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
: 248995 252881 254440 255431 255667 257852 259010 259162 263826 (view as bug list)
Depends on:
Reported: 2010-09-17 09:01 UTC by Thilo-Alexander Ginkel
Modified: 2011-02-02 20:19 UTC (History)
26 users (show)

See Also:
Latest Commit:
Version Fixed In:

ghost shadow on a desktop (117.56 KB, image/jpeg)
2010-10-05 01:31 UTC, Bartosz Kwitniewski
Before restarting compositing (204.65 KB, image/jpeg)
2010-12-07 08:45 UTC, david
After restarting compositing (207.50 KB, image/jpeg)
2010-12-07 08:47 UTC, david
4.5.5 doesn't fix it in kubuntu amd64 (206.07 KB, image/jpeg)
2011-01-09 21:00 UTC, Norberto Bensa

Note You need to log in before you can comment on or make changes to this bug.
Description Thilo-Alexander Ginkel 2010-09-17 09:01:25 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

From time to time, after logging into my KDE session, the shadow that is usually drawn behind the Plasma Panel at the bottom of the screen appears detached from the panel in the upper left quadrant of the screen. My panel is set to auto-hide and the shadow appears and disappears when the panel shows and hides. To temporarily correct the issue (until the ghost shadow decides to show up again), either change the panel alignment from "Center" to "Left" to "Center" (but I guess any alignment change will do) or log off and log on again (while the latter comes with a certain probability that the issue will immediately pop up again).

When inspecting the list of existent windows, one can actually spot a window, the dimensions of which correspond to the dimensions of the shadow.

For an example, refer to the attached screenshot.

This issue started happening after upgrading to KDE 4.5.0 (from 4.4.x) and is still present with KDE 4.5.1.

Reproducible: Sometimes
Comment 1 Thilo-Alexander Ginkel 2010-09-17 09:07:22 UTC
As my screenshot apparently exceeds the permissible size, I cannot attach it to this ticket. Please use the following image instead:


While I am not 100% certain that this is related to plasma instead of (kwin / compositing), I think the fact that there is a window of matching size hints at compositing being not guilty. ;-)
Comment 2 Thilo-Alexander Ginkel 2010-09-17 09:40:55 UTC
Another observation: Even when the shadow shows up where it is supposed to be a window slightly larger than the panel briefly flickers behind the panel when the panel is unhidden from time to time.
Comment 3 Beat Wolf 2010-09-17 12:56:47 UTC
that is a duplicate.. not sure where the other is
Comment 4 Kai Uwe Broulik 2010-09-18 12:31:45 UTC
I can confirm that from time to time. But only the panel on the left screen (dual monitor configuration) not the one on the right. Resizing the panel or restarting plasma fixes that temporarily.
Comment 5 Kai Uwe Broulik 2010-09-18 12:34:03 UTC
Addition: Might be related to the fact that since 4.5.0 that panel shadows are hidden when a window is maximized so that the shadow does not get into the translucent background of aurorae window borders.
Comment 6 Bartosz Kwitniewski 2010-10-05 01:31:21 UTC
Created attachment 52226 [details]
ghost shadow on a desktop

Same problem here after upgrade to 4.5.x. Arch Linux 64 bit.
Comment 7 ewald.kicker 2010-10-10 12:02:15 UTC
same problem for me - might be caused by updating xorg to 1.9? (Arch Linux 64 bit)
Comment 8 Alvaro Carroz 2010-10-14 18:02:34 UTC
Tested on Kubuntu 10.10 (amd64) with Nvidia (proprietary) drivers. It happens both on 4.5.1 and 4.5.2.

Disabling shadows in Desktop Effects did not make the shadow go away. It only disappears when I restart plasma or suspend / enable desktop effects.
Comment 9 hamelg 2010-10-16 16:51:10 UTC
If the current activity type is "folder view", you can't put an icon over the ghost (a small disallow sign appears near the icon), like a widget. I think it's a interesting clue ...
Comment 10 hamelg 2010-10-16 19:28:13 UTC
I can see the ghost window
$ wmctrl -pxlG
0x0200098c -1 21795  0    0    1288 808  plasma-desktop.Plasma-desktop  darkstar plasma-desktop
Comment 11 Alvaro Carroz 2010-10-16 19:49:01 UTC
Does anyone know if this happens on 32-bit versions?
Comment 12 Alvaro Carroz 2010-10-16 19:49:36 UTC
(In reply to comment #10)
> I can see the ghost window
> $ wmctrl -pxlG
> ...
> 0x0200098c -1 21795  0    0    1288 808  plasma-desktop.Plasma-desktop 
> darkstar plasma-desktop

Sixth sense reference? ;)
Comment 13 Thilo-Alexander Ginkel 2010-10-16 21:07:23 UTC
(In reply to comment #10)
> I can see the ghost window
> $ wmctrl -pxlG
> ...
> 0x0200098c -1 21795  0    0    1288 808  plasma-desktop.Plasma-desktop 
> darkstar plasma-desktop

Which size is your desktop?
Comment 14 Alvaro Carroz 2010-10-16 21:15:17 UTC
(In reply to comment #13)
> (In reply to comment #10)
> > I can see the ghost window
> > $ wmctrl -pxlG
> > ...
> > 0x0200098c -1 21795  0    0    1288 808  plasma-desktop.Plasma-desktop 
> > darkstar plasma-desktop
> Which size is your desktop?

Oh, right. I forgot to mention that. Mine is 1680x1050.
Comment 15 Thilo-Alexander Ginkel 2010-10-17 00:41:46 UTC
Hm, I had I theory about the ghost being a fixed fraction of the full desktop originating at (0,0), but on my Kubuntu 10.10 test VM (running KDE 4.5.1) I just got a ghost window, which no longer matches this pattern:

0x02a020c3 -1 1326   259  192  541  408  plasma-desktop.Plasma-desktop    matryoshka plasma-desktop

This was with two panels (one auto-hiding at the top of the screen and one at the bottom being always visible). After deleting the panel at the top and rebooting the old pattern came back:

0x02a01676 -1 1345   0    0    541  408  plasma-desktop.Plasma-desktop  matryoshka plasma-desktop

In my experience the ghost is much more likely to show up when first logging in after booting the system than during consecutive logins (without rebooting).

When inspecting the window dimensions it seems that these mimic the aspect ratio of the desktop size - although the fraction of the screen that is occupied by the ghost varies by desktop size.
Comment 16 hamelg 2010-10-17 09:49:48 UTC
(In reply to comment #13)
> Which size is your desktop?

dimensions:    1920x1200 pixels (554x342 millimeters)                                                
resolution:    88x89 dots per inch                                                                   
depths (7):    24, 1, 4, 8, 15, 16, 32                                                               
root window id:    0x15a                                                                             
depth of root window:    24 planes                                                                   
number of colormaps:    minimum 1, maximum 1           
default colormap:    0x20                             
default number of colormap cells:    256              
preallocated pixels:    black 0, white 16777215       
options:    backing-store NO, save-unders NO          
largest cursor:    64x64
Comment 17 hamelg 2010-10-17 18:39:08 UTC
The ghost window is related to the Panel settings.
If the panel is set to auto-hide, the ghost appears and disappears with the panel.

When the bug is happening :
0x020008c9 -1 6490   0    0    1288 808  plasma-desktop.Plasma-desktop  darkstar plasma-desktop

When the bug doesn't happen :
0x0200098c -1 21698  0    1159 1920 41   plasma-desktop.Plasma-desktop  darkstar plasma-desktop

Additionally, if you modify the height panel setting, the ghost disappears definitively until the next session.

Something is wrong with the window geometry behind the panel.
Comment 18 Thilo-Alexander Ginkel 2010-10-18 10:08:39 UTC
Not sure if that is important, but I noticed that the size of the ghost window is only dependent on the Desktop resolution and not on the size of the panel.

For a 1280x1024 display that is:

0x02000402 -1 3139   0    0    861  690  plasma-desktop.Plasma-desktop  andromeda plasma-desktop

It occupies pretty much 2/3 of the screen in horizontal and vertical direction.

And as the question came up in comment #11: Yes, I have also seen the issue pop up on a 32-bit Kubuntu install running KDE 4.5.1.
Comment 19 Alvaro Carroz 2010-10-18 13:21:22 UTC
Curious. My previous install was Kubuntu 10.04 32-bit, updated to 4.5.1 via PPA. The ghost was never shown. It only started appearing after a clean install of 10.10 (amd64)

I was using a different plasma theme (a dark one) which I haven't installed yet. I'll do some tests today and post a comment.

(In reply to comment #18)
> And as the question came up in comment #11: Yes, I have also seen the issue pop
> up on a 32-bit Kubuntu install running KDE 4.5.1.
Comment 20 Thilo-Alexander Ginkel 2010-10-18 16:11:25 UTC
I upgraded from Kububtu 10.04 and see the ghost - with or without a new
Comment 21 Beat Wolf 2010-10-19 16:34:25 UTC
*** Bug 254440 has been marked as a duplicate of this bug. ***
Comment 22 Marcelo Bossoni 2010-10-22 23:43:16 UTC
I can confirm this bug in kde 4.5.1 and 4.5.2 using NVIDIA proprietary drivers.
Comment 23 Marcelo Bossoni 2010-10-22 23:46:00 UTC
Forgot to mention that disabling (Alt+Shift+F12) and enabling (Alt+Shift+F12) the compositing removed the square.
Comment 24 k6lw 2010-10-25 20:22:17 UTC
I too am experiencing this "bug" in 4.5.1 on 64 bit using Nvidia beta drivers and auto hide of the task bar. Screen is set to 1920 X 1080. (The Nvidia drivers are what ever was installed as part of the upgrade from 10.04 to 10.10. Nvidia screen says beta on it now. Video card is an Nvidia 9600M GS with 512 Mb.)
Comment 25 Christoph Feck 2010-10-28 01:10:02 UTC
*** Bug 255431 has been marked as a duplicate of this bug. ***
Comment 26 Andrea Z. 2010-10-28 06:43:26 UTC
same here on Gentoo 64 bit with nvidia and compositing on.
I have only one panel always visible.
To make it disappear I have to turn off compositing and then turn it on.
During this two moves, for just a moment this rectangle becomes fully black.
This happens also with another user on the same machine.
Sorry for duplication of bug.
Comment 27 Gökçen Eraslan 2010-10-29 15:57:13 UTC
I can reproduce this in 32bit KDE 4.5.2 with Nvidia display card and proprietary driver.

My resolution is 1440x900 and the size of the ghost square is 960x600. One interesting thing to note is that, when I double click during KSplash, I see a white region in the place where ghost square is drawn. Finding out what that white region may help to resolve that issue.
Comment 28 Gökçen Eraslan 2010-10-29 16:00:37 UTC
Yeah, turning KDE Splash screen off makes it easier to see the mysterious white region before turning into a ghost in the shell.
Comment 29 Christoph Feck 2010-10-30 16:03:44 UTC
*** Bug 255667 has been marked as a duplicate of this bug. ***
Comment 30 hamelg 2010-11-04 20:59:09 UTC
Issue still here in 4.5.3
Comment 31 Norberto Bensa 2010-11-06 17:41:26 UTC
Same problem here. Nothing more to add.
Comment 32 Beat Wolf 2010-11-08 11:02:47 UTC
*** Bug 252881 has been marked as a duplicate of this bug. ***
Comment 33 Cédric Bellegarde 2010-11-08 15:58:12 UTC
Another information, 3 computers here:
- At home: i have this bug
- On my laptop, i have this bug too
- At work, on a dualscreen, after some month with Kde 4.5, never have seen this bug!
Comment 34 Cédric Bellegarde 2010-11-08 18:07:39 UTC

id=$(wmctrl -lx|grep plasma-desktop.Plasma-desktop|cut -d ' ' -f1)
wmctrl -i -r $id -b toggle,fullscreen

It will make your desktop flashing at end of splash screen but seems to work around issue ;)
Comment 35 Kai Uwe Broulik 2010-11-08 18:44:38 UTC
I noticed in VirtualBox, when I resize the window (i.e. change the screen resolution) that area the ghost shadow is around flickers briefly like a window (grey background) and then disappears.
Comment 36 Andrea Z. 2010-11-08 19:34:02 UTC
I can confirm that the script from Bellegarde Cédric "solves" the problem
Comment 37 Lorenzo Squarza 2010-11-12 09:30:09 UTC
This bug is present here on a desktop with kubuntu 10.10 with nvidia propetary plus autohide panel and a laptop 10.10 with open ati drivers and panel always visible.
Comment 38 Beat Wolf 2010-11-15 17:47:49 UTC
*** Bug 248995 has been marked as a duplicate of this bug. ***
Comment 39 Sebastien ROHAUT 2010-11-22 20:57:32 UTC
Just to say I've exactly the same problem. I'm using ubuntu 10.10 amd64, lastest KDE, Nvidia drivers. I had the same problem with openSUSE 11.3. Disabling and enabling Effects make shadow borders go back.

I will temporary use the "workaround" script.
Comment 40 Christoph Feck 2010-12-06 16:20:05 UTC
*** Bug 259010 has been marked as a duplicate of this bug. ***
Comment 41 Thilo-Alexander Ginkel 2010-12-07 08:07:37 UTC
(In reply to comment #34)
> Workaround:
> #!/bin/bash
> id=$(wmctrl -lx|grep plasma-desktop.Plasma-desktop|cut -d ' ' -f1)
> wmctrl -i -r $id -b toggle,fullscreen

I just tried this workaround, but it does not seem to have any effect (at least once the desktop is fully operational). Is there a preferred point in time during the startup sequence to execute this workaround?
Comment 42 david 2010-12-07 08:45:40 UTC
Created attachment 54232 [details]
Before restarting compositing

I have the same issue on Arch64. Restarting compositing doesn't entirely fix the problem. I'm using the search and launch activity, and when the ghost appears it hides all the bookmarked icons behind it (but only those fully behind it). Restaring compositing hides the shadow, but the missing icons don't reapppear
Comment 43 david 2010-12-07 08:47:14 UTC
Created attachment 54233 [details]
After restarting compositing
Comment 44 Daniel Nicoletti 2010-12-07 11:12:22 UTC
I think I found the issue.
Another WORKAROUND is to disable the splash screen.
After that when starting you will see a window with no borders with the same size of this shadow. But without the splash screen I think KWin does paint that shadow.
I don't know how to fix it but at least I can see now what is causing this shadow.
Comment 45 Beat Wolf 2010-12-07 11:36:53 UTC
cc'ing kwin, perhaps they know more about what to do.
Comment 46 Kubuntiac 2010-12-12 02:50:55 UTC
Getting this on two more computers:

Computer 1:
* Kubuntu 10.04 32 bit
* Xorg-edgers (ie daily build of Xorg and associated drivers)
* KDE 4.5.4
* ATI HD 4850 (r600)
* Single monitor desktop
* Autohide panel
* Compositing ON

Computer 2:
* Dell Inspiron 1501 Laptop
* Kubuntu 10.04 32 bit
* Standard ATI FOSS Driver from repos
* KDE 4.5.4
* ATI Radeon Xpress M200
* Default (non-autohide) panel
* Compositing OFF

The only similarities between the two computers I can see are: 32 Bit Kubuntu with KDE 4.5.4. They both use FOSS ATI, too, but very different versions.
Comment 47 Kubuntiac 2010-12-12 02:55:17 UTC
For me it seems to add the following windows, versus when the shadow window isn't visible:
0x01e0147a -1 1680   0    739  1360 29   Plasma.Plasma         morpheus plasma-desktop
0x01e01486 -1 1680   0    0    914  520  plasma-desktop.Plasma-desktop  morpheus plasma-desktop

Monitor resolution is 1360 x 768
Comment 48 sergio.guibert 2010-12-12 17:39:09 UTC
Same problem here, with kubuntu 10.10 64 bits KDE 4.5.4 with Radeon open source drivers.
Screen dimension : 1920x1080.
The ghost shadow first appeared when I closed a KDE session with a rekonq window opened. Since this time, a ghost shadow whom dimension corresponds to this window appears at the top left of the screen when my KDE session starts. Always the same dimension, always at the same position. Closing a session with another window opened does not change the position and the dimension of the ghost shadow, next time a KDE session is started.
Deleting local .kde directory does not fix anything.
Same behavior as Adreas Z (comment #26) with respect to compositing.
Comment 49 J Bolos 2010-12-13 17:32:29 UTC
Huh, only wanted to add a "me too". It happened with 10.04, and a 10.10 amd64 clean install updated to KDE 4.5.4. Dual screen 1680x1050+1152x864, nvidia propietary driver 260.19.21.

Just updated to KDE 4.6 beta 2 and the problem seems to be vanished!
Comment 50 Aaron J. Seigo 2010-12-16 00:46:11 UTC
*** Bug 259162 has been marked as a duplicate of this bug. ***
Comment 51 Aaron J. Seigo 2010-12-16 01:14:37 UTC
SVN commit 1206815 by aseigo:

adjust the shadow window geom on resizeEvent, just as it is with moveEvent. good chance it's the cause of ..

 M  +4 -4      panelview.cpp  

WebSVN link: http://websvn.kde.org/?view=rev&revision=1206815
Comment 52 Aaron J. Seigo 2010-12-16 01:15:53 UTC
can those who are affected by this update to the next 4.6 prerelease (beta/rc) or 4.6.0 if you can't before then (though preferably we find out sooner) and confirm if the above commit fixes it? thanks.
Comment 53 Martin Flöser 2010-12-18 12:20:30 UTC
*** Bug 257852 has been marked as a duplicate of this bug. ***
Comment 54 Thilo-Alexander Ginkel 2010-12-18 21:56:23 UTC
I have downported the equivalent of Aaron's fix to KDE 4.5.4 and uploaded new packages to a special PPA for Kubuntu:


Please let me know whether this works for you (in that case it would proably make sense to commit the fix to the official KDE 4.5.x codebase).
Comment 55 Kubuntiac 2010-12-19 08:57:59 UTC
That PPA seems to be private. I just get:

"Not allowed here
Sorry, you don't have permission to access this page. "

at launchpad. I'm logged in.
Comment 56 Daniel Eklöf 2010-12-29 10:27:40 UTC
(In reply to comment #52)
> can those who are affected by this update to the next 4.6 prerelease (beta/rc)
> or 4.6.0 if you can't before then (though preferably we find out sooner) and
> confirm if the above commit fixes it? thanks.

I've been running 4.6 RC1 for about a week now, and haven't seen this issue even once after upgrading. I.e. it looks like it's been fixed!
Comment 57 Kai Uwe Broulik 2010-12-29 16:01:20 UTC
I did encounter it once but it was another “symptome”. Instead of having a rectangle drawn on the screen, I had a black shadow at the bottom of the screen (my panel is at the top) on my notebook 1366x768 Kubuntu 10.10 KDE 4.6 RC1 Intel graphics
Comment 58 Mahendra Tallur 2011-01-05 10:39:30 UTC
This bug occurs on my setup as well, not each time, but maybe in 33% of the cases.

Kubuntu 10.10, i386, KDE 4.5.4, nvidia 260.19.06
Empty frame in the top left corner (similar to the one in the provided screenshot). Bigger than the default folder view plasmoid.

Only using default plugins / settings here.

I guess there won't be a KDE 4.5.5 as 4.6.0 is released this month, so, if it's been fixed meanwhile, it's probably not an issue anymore.
Comment 59 Andrea Z. 2011-01-05 10:43:43 UTC
ok we just wait for 4.6 :-)
Comment 60 Alvaro Carroz 2011-01-09 17:29:45 UTC
After a minor update (it still is 4.5.4) from the Kubuntu backports PPA the shadown vanished. I'm now on 4.5.5 (Kubuntu 10.10) and the shadow remains gone.
Comment 61 Kai Uwe Broulik 2011-01-09 17:39:02 UTC
I haven‘t had it in a while with KDE 4.6 RC1 or RC2.
Comment 62 Norberto Bensa 2011-01-09 17:47:53 UTC
4.5.5 (kubuntu) still has the bug. I've seen it once so far.
Comment 63 ewald.kicker 2011-01-09 20:46:10 UTC
Bug is gone for me with the update to version 4.5.5 (Arch Linux 64 bit).
Comment 64 Norberto Bensa 2011-01-09 21:00:59 UTC
Created attachment 55782 [details]
4.5.5 doesn't fix it in kubuntu amd64

kubuntu amd64, kde 4.5.5

$ wmctrl -lGpx
0x01e003d2 -1 8229   0    0    1680 1050 Plasma.Plasma         venkman plasma-desktop
0x01e003cf -1 8229   0    1005 1680 45   Plasma.Plasma         venkman plasma-desktop
0x01e003d5 -1 8229   272  167  1136 716  plasma-desktop.Plasma-desktop  venkman plasma-desktop

$ dpkg -l | grep kdebase
ii  kdebase-bin                               4:4.5.5-0ubuntu1.1ppa1                            core binaries for the KDE 4 base module
ii  kdebase-data                              4:4.5.5-0ubuntu1.1ppa1                            shared data files for the KDE 4 base module
ii  kdebase-runtime                           4:4.5.5-0ubuntu1ppa1                              runtime components from the official KDE 4 release
ii  kdebase-runtime-data                      4:4.5.5-0ubuntu1ppa1                              shared data files for the KDE 4 base runtime module
ii  kdebase-workspace                         4:4.5.5-0ubuntu1ppa1                              base workspace components from the official KDE 4 release
ii  kdebase-workspace-bin                     4:4.5.5-0ubuntu1ppa1                              core binaries for the KDE 4 base workspace module
ii  kdebase-workspace-data                    4:4.5.5-0ubuntu1ppa1                              shared data files for the KDE 4 base workspace module
ii  kdebase-workspace-kgreet-plugins          4:4.5.5-0ubuntu1ppa1                              KDE greet libraries for authentication
ii  libkworkspace4                            4:4.5.5-0ubuntu1ppa1                              library for the kdebase workspace

Aaron, does 4.5.5 include this fix?
Comment 65 André Fettouhi 2011-01-09 21:04:14 UTC
Seems to be gone in my case as well but I need to test it bit more though.
Comment 66 Kubuntiac 2011-01-11 05:45:27 UTC
I'm still getting it with 4.5.5 on Kubuntu 10.10 but with a whole bunch of freaky ppa's (Xorg-edgers etc). One time the window shadow came up for me just as I was shutting down, and actually showed a window there after a second or two. The window was titled Rekonq (which I have as one of my daily-ppa's) so I have a feeling this is likely rekonq related.
Comment 67 Kubuntiac 2011-01-11 09:04:49 UTC
Hmmm... purged rekonq, logged out and in again and and I still get it...
Comment 68 André Fettouhi 2011-01-11 09:06:32 UTC
Still getting it here also.
Comment 69 André Fettouhi 2011-01-11 09:10:04 UTC
Still getting it here also.
Comment 70 Thomas Lübking 2011-01-11 15:37:13 UTC
There's a similar report and a thread on kwin or kde-devel (forgot) wich seems to tie a "ghost window" to the presence of activities - can this be confirmed by users who still encounter the issue?
Comment 71 Mahendra Tallur 2011-01-11 15:41:12 UTC
Thomas : I don't think so ; in my case, I have a pretty clean install with KDE 4.5.5, am not using activities, and still do encounter the "ghost window" issue on the plasma desktop.
Comment 72 hamelg 2011-01-11 20:12:15 UTC
(In reply to comment #63)
> Bug is gone for me with the update to version 4.5.5 (Arch Linux 64 bit).

Are you sure ? 
upgraded to 4.5.5 and unfortunately the bug is still here on Arch Linux 32 bits.
has the commit (http://websvn.kde.org/?view=rev&revision=1206815) been applied to 4.5.5 ?
Comment 74 Aaron J. Seigo 2011-01-11 20:46:30 UTC
looking through the comments it seems it is fixed with 4.6, and not in 4.5.5, which given that the fix is only in 4.6 and not backported to 4.5.5 that is precisely what we should expect. wonderful. :)
Comment 75 Norberto Bensa 2011-01-11 22:47:05 UTC
Actually I expected it to be included in 4.5.5... :-/
Comment 76 Martin Flöser 2011-01-21 17:28:10 UTC
*** Bug 263826 has been marked as a duplicate of this bug. ***
Comment 77 Andrea Z. 2011-02-02 16:13:24 UTC
bug not present in kde 4.6 :-)
Comment 78 Evert Vorster 2011-02-02 18:58:59 UTC
Confirmed, bug fixed in kde 4.6.0
Comment 79 Kai Uwe Broulik 2011-02-02 20:19:26 UTC
I don‘t experience it anymore with 4.6 either.