Bug 251179 - ark crashes with signal: aborted when quitting while loading large archive
Summary: ark crashes with signal: aborted when quitting while loading large archive
Status: RESOLVED DUPLICATE of bug 193908
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.15
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-14 06:37 UTC by محمد النقيب
Modified: 2010-09-14 10:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description محمد النقيب 2010-09-14 06:37:33 UTC
Application: ark (2.15)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
ark crashes with signal: aborted when quitting while loading large archive

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Ark (ark), signal: Aborted
[KCrash Handler]
#7  0x006b3422 in __kernel_vsyscall ()
#8  0x00280651 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x00283a82 in *__GI_abort () at abort.c:92
#10 0x002b749d in __libc_message (do_abort=2, fmt=0x38bf98 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#11 0x002c1591 in malloc_printerr (action=<value optimized out>, str=0x6 <Address 0x6 out of bounds>, ptr=0x960498a) at malloc.c:6264
#12 0x002c19ce in malloc_consolidate (av=<value optimized out>) at malloc.c:5142
#13 0x002c2d65 in _int_free (av=<value optimized out>, p=0x96d4ef0) at malloc.c:5015
#14 0x002c5ecd in *__GI___libc_free (mem=0x96d4ef8) at malloc.c:3738
#15 0x067a20ad in qFree (ptr=0x96d4ef8) at global/qmalloc.cpp:60
#16 0x02204245 in QList<QHash<int, QVariant> >::free (this=0x95514f0, data=0x96d4ef8) at /usr/include/qt4/QtCore/qlist.h:744
#17 0x02204277 in ~QList (this=0x6, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qlist.h:716
#18 0x021fc850 in ~ArchiveModel (this=0x95514e8, __in_chrg=<value optimized out>) at ../../../ark/part/archivemodel.cpp:213
#19 0x068bbc36 in QObjectPrivate::deleteChildren (this=0x95589c8) at kernel/qobject.cpp:1957
#20 0x068c3380 in ~QObject (this=0x95542b8, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#21 0x0012b59f in ~Part (this=0x95542b8, __vtt_parm=0x220b3ec, __in_chrg=<value optimized out>) at ../../kparts/part.cpp:212
#22 0x0012bd2a in ~ReadOnlyPart (this=0x95542b8, __vtt_parm=0x220b3e8, __in_chrg=<value optimized out>) at ../../kparts/part.cpp:459
#23 0x0012be9f in ~ReadWritePart (this=0x95542b8, __vtt_parm=0x220b3e4, __in_chrg=<value optimized out>) at ../../kparts/part.cpp:721
#24 0x021eddac in ~Part (this=0x95542b8, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../ark/part/part.cpp:133
#25 0x08055131 in ~MainWindow (this=0x9539ad0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../ark/app/mainwindow.cpp:74
#26 0x068b9dc5 in qDeleteInEventHandler (o=0x0) at kernel/qobject.cpp:3988
#27 0x068bbae8 in QObject::event (this=0x9539ad0, e=0x6) at kernel/qobject.cpp:1202
#28 0x00f90e36 in QWidget::event (this=0x9539ad0, event=0x96afa40) at kernel/qwidget.cpp:8617
#29 0x013cffd7 in QMainWindow::event (this=0x9539ad0, event=0x96afa40) at widgets/qmainwindow.cpp:1417
#30 0x00994f24 in KMainWindow::event (this=0x9539ad0, ev=0x96afa40) at ../../kdeui/widgets/kmainwindow.cpp:1100
#31 0x009dd9df in KXmlGuiWindow::event (this=0x9539ad0, ev=0x96afa40) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:130
#32 0x00f3377c in QApplicationPrivate::notify_helper (this=0x93d6f48, receiver=0x9539ad0, e=0x96afa40) at kernel/qapplication.cpp:4396
#33 0x00f39869 in QApplication::notify (this=0xbf8c4c2c, receiver=0x9539ad0, e=0x96afa40) at kernel/qapplication.cpp:4361
#34 0x0089ea9a in KApplication::notify (this=0xbf8c4c2c, receiver=0x9539ad0, event=0x96afa40) at ../../kdeui/kernel/kapplication.cpp:310
#35 0x068a8feb in QCoreApplication::notifyInternal (this=0xbf8c4c2c, receiver=0x9539ad0, event=0x96afa40) at kernel/qcoreapplication.cpp:732
#36 0x068ac24b in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x93c0c18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#37 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x93c0c18) at kernel/qcoreapplication.cpp:1373
#38 0x068ac40d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#39 0x068d7d04 in QCoreApplication::sendPostedEvents (s=0x93d9310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#40 postEventSourceDispatch (s=0x93d9310) at kernel/qeventdispatcher_glib.cpp:277
#41 0x01a3e5e5 in g_main_dispatch (context=0x93d9290) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:1960
#42 IA__g_main_context_dispatch (context=0x93d9290) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2513
#43 0x01a422d8 in g_main_context_iterate (context=0x93d9290, block=<value optimized out>, dispatch=1, self=0x93d70d8) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2591
#44 0x01a424b8 in IA__g_main_context_iteration (context=0x93d9290, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#45 0x068d77f5 in QEventDispatcherGlib::processEvents (this=0x93c08f8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#46 0x00ff4de5 in QGuiEventDispatcherGlib::processEvents (this=0x93c08f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x068a7a99 in QEventLoop::processEvents (this=0xbf8c4b84, flags=) at kernel/qeventloop.cpp:149
#48 0x068a7f1a in QEventLoop::exec (this=0xbf8c4b84, flags=...) at kernel/qeventloop.cpp:201
#49 0x068ac4cf in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#50 0x00f325a7 in QApplication::exec () at kernel/qapplication.cpp:3672
#51 0x08054389 in main (argc=4, argv=0xbf8c4fc4) at ../../../ark/app/main.cpp:209

This bug may be a duplicate of or related to bug 193908, bug 208881.

Possible duplicates by query: bug 208881.

Reported using DrKonqi
Comment 1 محمد النقيب 2010-09-14 10:01:49 UTC

*** This bug has been marked as a duplicate of bug 193908 ***