Bug 251166 - Tellico freeze for few second (with high cpu load) when opening big collection in icon view.
Summary: Tellico freeze for few second (with high cpu load) when opening big collectio...
Status: RESOLVED DUPLICATE of bug 272583
Alias: None
Product: tellico
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Robby Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-14 00:54 UTC by Fest
Modified: 2011-05-06 17:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fest 2010-09-14 00:54:59 UTC
Version:           2.3 (using KDE 4.5.1) 
OS:                Linux

I'm saving hq covers (500Kb+) for movie entries.
Only problem that when i open icon view, Tellico freeze for few seconds (3-12) with 100% cpu load.

No matter how many entries with covers in normal resolution (>150Kb) i have, adding only one in hq create this freezes. 

I have not very old cpu (q6600 overclocked to 3Ghz), and other programs not having problem with such images. 
Digikam, gwenview open instantly this images in thumbnail mode, so imho it's bug.

Reproducible: Always

Steps to Reproduce:
1) Make entry.
2) Add hq cover (500Kb+).
3) Open icon view.

Actual Results:  
Tellico freeze for few second with high cpu load.

Expected Results:  
Tellico open icon view instantly.
Comment 1 Fest 2010-09-17 20:59:54 UTC
Actually i was wrong - hq covers is not the reason of freezes (at least not at first place). 

I checked by ctrl+a whole collection - window is freezing. Checked with images in file and in folders.
After i checked selecting few entry's only. When selecting only few, even with hq covers - no freeze.
It's seems when collection grown over specific size/entry's icon view start slow down.

If it help, i can send my tc file.
Comment 2 Robby Stephenson 2010-10-19 05:46:08 UTC
So this does not occur only when you're storing the images in the tc file itself? Cause that could be an issue, where Tellico has to extract the image from the file.
Comment 3 Fest 2010-10-19 13:52:17 UTC
I tried all options. Freezes occurring in all situations.

And I just discovered some strange file-size behavior. 
1)Cover folder i store covers, before adding to Tellico is twice bigger then Tellico's cover folder:
  ls -lh /home/fest/.config/tellico/covers/
  total 15M
and
  ls -lh /home/fest/.config/tellico/video_files/
  total 7.7M
or
  ls -lh /home/fest/.config/tellico/video.tc
  -rw-r--r-- 1 fest fest 7.4M Oct 19 13:51

2)Cover i added to Tellico is twice smaller then same cover opened from Tellico. 
  ls -lh /home/fest/.config/tellico/covers/A-Team.jpg
  -rw-r--r-- 1 fest fest 2.3M Sep 18 16:19 /home/fest/.config/tellico/covers/A-
and 
  ls -lh /tmp/kde-fest/tellicoEt2621.png
  -rw------- 1 fest fest 4.6M Oct 19 13:40 /tmp/kde-fest/tellicoEt2621.png

So original cover folder is twice bigger, but covers itselfs is twice smaller. How can it be?
Comment 4 Robby Stephenson 2010-10-20 04:52:50 UTC
(In reply to comment #3)
> So original cover folder is twice bigger, but covers itselfs is twice smaller.
> How can it be?

Are you asking me about image compression? jpeg is inherently lossy and can have various compression ratios. If you want to check for details on each image, use the identify command from ImageMagick.
Comment 5 Fest 2010-10-20 05:31:25 UTC
Sorry. Missed that Tellico open images externally as png.

But still, tellico database (or image folder) twice is smaller than original cover folder and A-Team cover there is only 583 Kb jpeg, while original cover is 2.3M and opened from Tellico is 4.6M png.

So i don't understand: if original covers is jpeg, and Tellico stores them as jpeg, why they opened as png in IconView/externally and where they stored? Or Tellico converting them before showing?
Comment 6 Robby Stephenson 2011-05-06 17:53:45 UTC

*** This bug has been marked as a duplicate of bug 272583 ***