Bug 250979 - RFE: add support for freerdp
Summary: RFE: add support for freerdp
Status: RESOLVED DUPLICATE of bug 248896
Alias: None
Product: krdc
Classification: Unclassified
Component: RDP (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-12 15:48 UTC by Stefan Becker
Modified: 2010-09-12 19:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Becker 2010-09-12 15:48:14 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

Quote from the freerdp project page:

"FreeRDP is a fork of the rdesktop project that intends to rapidly
 start moving forward and implement features that rdesktop lacks the most."

  <http://www.freerdp.com/>
  <http://sourceforge.net/projects/freerdp/>

f.ex. it works out of the box with Win7 RDP, whereas rdesktop-1.6.0 does not.

Fedora is already reviewing to add a package for freerdp, see

  <https://bugzilla.redhat.com/show_bug.cgi?id=603481>

It would be really nice if krdc would support freedrdp as alternative to rdesktop. I'm not sure if a new plugin would be required or if it would be enough to add it as auto-detected option to the current plugin (freerdp client does have some different command line options).

Reproducible: Always
Comment 1 Stefan Becker 2010-09-12 19:06:36 UTC
Another option would be to use libfreerdp instead of the command line program.
Comment 2 Urs Wolfer 2010-09-12 19:43:47 UTC
I think adding a 2nd plugin with higher "priority" would be the perfect solution. So the old plugin would just be used as fallback solution.

*** This bug has been marked as a duplicate of bug 248896 ***