Bug 250924 - invalid MIME type in /usr/share/mime/packages/kde.xml
Summary: invalid MIME type in /usr/share/mime/packages/kde.xml
Status: RESOLVED DUPLICATE of bug 303627
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: SVN
Platform: Ubuntu Linux
: NOR normal with 42 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL: http://websvn.kde.org/trunk/KDE/kdeli...
Keywords:
Depends on:
Blocks: 235564
  Show dependency treegraph
 
Reported: 2010-09-11 21:10 UTC by Christopher Yeleighton
Modified: 2014-08-16 12:02 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Yeleighton 2010-09-11 21:10:44 UTC
+++ This bug was initially created as a clone of Bug #235564 +++

Version:            (using KDE 4.4.2)
OS:                Linux
Installed from:    Ubuntu Packages

Here is the problem:

# update-desktop-database
[...]
Error in file "/usr/share/applications/kde4/kfontview.desktop": "fonts/package" is an invalid MIME type ("fonts" is an unregistered media type)
Comment 1 Rex Dieter 2010-09-11 22:01:26 UTC
Seems update-mime-database also dislikes anything commented as "fake" types in kde.xml

$ sudo update-mime-database /usr/share/mime
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'fonts/package'
Comment 2 Rex Dieter 2010-12-13 17:32:43 UTC
Please review/test,
http://reviewboard.kde.org/r/6111/
Comment 3 Rex Dieter 2010-12-20 23:55:22 UTC
Fixed in trunk/ with commit r1208194
Comment 4 Ariel Garcia 2012-09-16 10:51:09 UTC
This issue is still present in KDE 4.8.4 from Debian (kdelibs5-data  4:4.8.4-3), see 
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=469833#60

# update-mime-database /usr/share/mime
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'

Also other distros have open bugs about it.
Could you please check if the commit did land in the releases?
Comment 5 Ariel Garcia 2012-09-16 10:56:48 UTC
Actually the commit r1208194 you mention did only fix the 
            "fonts/package"
mimetype, but none of the other fake mimetypes shown in me previous comment.

KDE should either not use these fake mimetypes or the mime tools/standards should be adapted to cope with them. :-)
Comment 6 Thomas Hackert 2013-06-08 06:35:49 UTC
Hello Christopher, Rex, *,
this bug still exists in KDE 4.8 under Debian Testing AMD64 ... :( Could someone fix this bug, please?
If I use

<quote>
update-mime-database /usr/share/mime
</quote>

I get the message

<quote>
Unknown media type in type 'chemical/x-alchemy'
Unknown media type in type 'chemical/x-cache'
Unknown media type in type 'chemical/x-cactvs-ascii'
Unknown media type in type 'chemical/x-cactvs-binary'
Unknown media type in type 'chemical/x-cactvs-table'
Unknown media type in type 'chemical/x-cdx'
Unknown media type in type 'chemical/x-cdxml'
Unknown media type in type 'chemical/x-chem3d'
Unknown media type in type 'chemical/x-cif'
Unknown media type in type 'chemical/x-cml'
Unknown media type in type 'chemical/x-daylight-smiles'
Unknown media type in type 'chemical/x-dmol'
Unknown media type in type 'chemical/x-gamess-input'
Unknown media type in type 'chemical/x-gamess-output'
Unknown media type in type 'chemical/x-gaussian-input'
Unknown media type in type 'chemical/x-gaussian-log'
Unknown media type in type 'chemical/x-genbank'
Unknown media type in type 'chemical/x-gulp'
Unknown media type in type 'chemical/x-hin'
Unknown media type in type 'chemical/x-inchi'
Unknown media type in type 'chemical/x-inchi-xml'
Unknown media type in type 'chemical/x-jcamp-dx'
Unknown media type in type 'chemical/x-macromodel-input'
Unknown media type in type 'chemical/x-mdl-molfile'
Unknown media type in type 'chemical/x-mdl-rdfile'
Unknown media type in type 'chemical/x-mdl-rxnfile'
Unknown media type in type 'chemical/x-mdl-sdfile'
Unknown media type in type 'chemical/x-mdl-tgf'
Unknown media type in type 'chemical/x-mmcif'
Unknown media type in type 'chemical/x-mol2'
Unknown media type in type 'chemical/x-mopac-graph'
Unknown media type in type 'chemical/x-mopac-input'
Unknown media type in type 'chemical/x-mopac-out'
Unknown media type in type 'chemical/x-msi-car'
Unknown media type in type 'chemical/x-msi-hessian'
Unknown media type in type 'chemical/x-msi-mdf'
Unknown media type in type 'chemical/x-msi-msi'
Unknown media type in type 'chemical/x-ncbi-asn1'
Unknown media type in type 'chemical/x-ncbi-asn1-binary'
Unknown media type in type 'chemical/x-ncbi-asn1-xml'
Unknown media type in type 'chemical/x-pdb'
Unknown media type in type 'chemical/x-shelx'
Unknown media type in type 'chemical/x-vmd'
Unknown media type in type 'chemical/x-xyz'
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
</quote>

Using DuckDuckGo, I found out, that nearly every existing distribution has one or more bugs reported to this output ... :( Is it possible to reopen this bug and fix it, please?
Sorry for the inconvenience
Thomas.
Comment 7 Christoph Feck 2013-06-16 01:06:32 UTC
Those "chemical" types are not added by KDE.
Comment 8 Vadim Zhukov 2014-06-26 10:35:01 UTC
chemical/* are not from kdelibs, but uri/* and all/* are.

Still here on 4.13 (!).
Comment 9 Pavel Mendl 2014-07-15 08:02:07 UTC
This bug is definitely WRONG marked as RESOLVED FIXED ! I found this after having enough of "Unknown media type in type ..." and googled out that every major distro has pending bugreports for this and all blame KDE devs for kde.xml content being not conform with MIME standard and waiting for their resolution to incorporate into distros.

I did not dig deep into the standards but definitely this is something that is not yet resolved for sure and some action would be well appreciated by many.

I can confirm the problem still exists in the updated (as of today) Debian testing distro:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
and all of the above mimetypes are present in the file usr/share/mime/packages/kde.xml
Comment 10 Christoph Feck 2014-08-16 12:02:57 UTC

*** This bug has been marked as a duplicate of bug 303627 ***