Bug 250656 - When closing download status window the application crashes
Summary: When closing download status window the application crashes
Status: RESOLVED DUPLICATE of bug 265681
Alias: None
Product: kget
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KGet authors
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-09 13:19 UTC by Mihail
Modified: 2011-02-08 14:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihail 2010-09-09 13:19:32 UTC
Application: kget (2.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
При закрытие окна сведеней о закачке вылетает программа.
 UBuntu 10.04 - Gnome

The crash can be reproduced every time.

 -- Backtrace:
Application: KGet (kget), signal: Segmentation fault
[KCrash Handler]
#6  0x007b928b in KWidgetJobTracker::description (this=0xa02ad50, job=0x9e84410, title=..., field1=..., field2=...) at ../../kdeui/jobs/kwidgetjobtracker.cpp:134
#7  0x007b8d7f in KWidgetJobTracker::qt_metacall (this=0xa02ad50, _c=QMetaObject::InvokeMetaMethod, _id=29, _a=0xbfc2074c) at ./kwidgetjobtracker.moc:98
#8  0x01123c9a in QMetaObject::metacall (object=0xa02ad50, cl=3217164276, idx=29, argv=0xbfc2074c) at kernel/qmetaobject.cpp:237
#9  0x011323d5 in QMetaObject::activate (sender=0x9e84410, m=0xfadc88, local_signal_index=4, argv=0xbfc2074c) at kernel/qobject.cpp:3293
#10 0x00e3f135 in KJob::description (this=0x9e84410, _t1=0x9e84410, _t2=..., _t3=..., _t4=...) at ./kjob.moc:201
#11 0x001ae3c0 in KGetGlobalJob::update (this=0x9e84410) at ../../kget/core/kgetglobaljob.cpp:57
#12 0x001ad910 in KUiServerJobs::slotTransfersChanged (this=0x9cfaa78, transfers=...) at ../../kget/core/kuiserverjobs.cpp:111
#13 0x00181505 in KUiServerJobs::qt_metacall (this=0x9cfaa78, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfc20998) at moc_kuiserverjobs.cpp:80
#14 0x01123c9a in QMetaObject::metacall (object=0x9cfaa78, cl=3217164276, idx=6, argv=0xbfc20998) at kernel/qmetaobject.cpp:237
#15 0x011323d5 in QMetaObject::activate (sender=0x9e6cd98, m=0x209f80, local_signal_index=7, argv=0xbfc20998) at kernel/qobject.cpp:3293
#16 0x001919e3 in TransferTreeModel::transfersChangedEvent (this=0x9e6cd98, _t1=...) at ./transfertreemodel.moc:156
#17 0x001938b5 in TransferTreeModel::timerEvent (this=0x9e6cd98, event=0xbfc20f50) at ../../kget/core/transfertreemodel.cpp:643
#18 0x0112f254 in QObject::event (this=0x9e6cd98, e=0x1e25498) at kernel/qobject.cpp:1212
#19 0x013694dc in QApplicationPrivate::notify_helper (this=0x9d00d20, receiver=0x9e6cd98, e=0xbfc20f50) at kernel/qapplication.cpp:4300
#20 0x0137005e in QApplication::notify (this=0xbfc212a8, receiver=0x9e6cd98, e=0xbfc20f50) at kernel/qapplication.cpp:3704
#21 0x007c5f2a in KApplication::notify (this=0xbfc212a8, receiver=0x9e6cd98, event=0xbfc20f50) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x0111ea3b in QCoreApplication::notifyInternal (this=0xbfc212a8, receiver=0x9e6cd98, event=0xbfc20f50) at kernel/qcoreapplication.cpp:704
#23 0x0114dd66 in QCoreApplication::sendEvent (this=0x9d03c34) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#24 QTimerInfoList::activateTimers (this=0x9d03c34) at kernel/qeventdispatcher_unix.cpp:603
#25 0x0114a917 in timerSourceDispatch (source=0x9d03c68) at kernel/qeventdispatcher_glib.cpp:184
#26 idleTimerSourceDispatch (source=0x9d03c68) at kernel/qeventdispatcher_glib.cpp:231
#27 0x037d85e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#28 0x037dc2d8 in ?? () from /lib/libglib-2.0.so.0
#29 0x037dc4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#30 0x0114a5d5 in QEventDispatcherGlib::processEvents (this=0x9cdcc98, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#31 0x01429135 in QGuiEventDispatcherGlib::processEvents (this=0x9cdcc98, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x0111d059 in QEventLoop::processEvents (this=0xbfc21214, flags=) at kernel/qeventloop.cpp:149
#33 0x0111d4aa in QEventLoop::exec (this=0xbfc21214, flags=...) at kernel/qeventloop.cpp:201
#34 0x0112169f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#35 0x01369577 in QApplication::exec () at kernel/qapplication.cpp:3579
#36 0x080eb06d in main (argc=1, argv=0xbfc214d4) at ../../kget/main.cpp:184

Reported using DrKonqi
Comment 1 Nicolas L. 2010-09-09 15:49:08 UTC
-- Information about the crash:
"When closing download status window the application crashes"
Comment 2 Matthias Fuchs 2011-02-08 14:47:39 UTC

*** This bug has been marked as a duplicate of bug 265681 ***