Bug 250655 - Akregator crashed startup
Summary: Akregator crashed startup
Status: RESOLVED DUPLICATE of bug 116482
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 1.6.2
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-09 13:00 UTC by bilisimfevzi
Modified: 2010-09-12 14:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bilisimfevzi 2010-09-09 13:00:03 UTC
Application: akregator (1.6.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Akregator  crashing while updating and adding sourge . And my Rss sourge's news delete. no problem when not internet connection.

The crash can be reproduced every time.

 -- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
[KCrash Handler]
#6  0x01a0d040 in ?? () from /lib/tls/i686/cmov/libc.so.6
#7  0x036be08d in c4_Column::FetchBytes (this=0x89bd820, pos_=0, len_=134567248, buffer_=..., forceCopy_=false) at /usr/include/bits/string3.h:52
#8  0x036c7c08 in c4_FormatB::GetOne (this=0x8946c78, index_=186, length_=@0xbf87ce7c) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:583
#9  0x036c7c50 in c4_FormatS::Get (this=0x8946c78, index_=186, length_=@0xbf87ce7c) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:842
#10 0x036cabd6 in c4_Handler::GetBytes (this=0x8946c78, index_=186, buf_=..., copySmall_=false) at ../../../../akregator/plugins/mk4storage/metakit/src/handler.cpp:53
#11 0x036d8f1b in c4_Sequence::Get (this=0x8948228, index_=186, propId_=10, buf_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:319
#12 0x036d5df8 in c4_Reference::GetData (this=0x8947ecc, row_=186, col_=0, buf_=...) at ../../../../akregator/plugins/mk4storage/metakit/include/mk4.inl:421
#13 c4_View::GetItem (this=0x8947ecc, row_=186, col_=0, buf_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/view.cpp:225
#14 0x036d0aff in c4_HashViewer::KeySame (this=0x8947ec8, row_=186, cursor_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/remap.cpp:157
#15 0x036d0cdd in c4_HashViewer::LookDict (this=0x8947ec8, hash_=960929356, cursor_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/remap.cpp:257
#16 0x036d1662 in c4_HashViewer::Lookup (this=0x8947ec8, key_=..., count_=@0xbf87d05c) at ../../../../akregator/plugins/mk4storage/metakit/src/remap.cpp:344
#17 0x036bf361 in c4_CustomSeq::RestrictSearch (this=0x8949e98, cursor_=..., pos_=@0xbf87d108, count_=@0xbf87d0bc) at ../../../../akregator/plugins/mk4storage/metakit/src/custom.cpp:110
#18 0x036d6ffb in c4_View::Find (this=0x89464ac, crit_=..., start_=0) at ../../../../akregator/plugins/mk4storage/metakit/src/view.cpp:830
#19 0x036dad39 in Akregator::Backend::FeedStorageMK4Impl::findArticle (this=0x87325f0, guid=...) at ../../../../akregator/plugins/mk4storage/feedstoragemk4impl.cpp:298
#20 0x036db4b8 in Akregator::Backend::FeedStorageMK4Impl::contains (this=0x87325f0, guid=...) at ../../../../akregator/plugins/mk4storage/feedstoragemk4impl.cpp:291
#21 0x031cd298 in Private (this=0x8aa1e78, article=..., feed_=0x8947d68, archive_=0x87325f0) at ../../../akregator/src/article.cpp:171
#22 0x031ce46c in Article (this=0xbf87d360, article=..., feed=0x8947d68) at ../../../akregator/src/article.cpp:245
#23 0x031da8d7 in Akregator::Feed::appendArticles (this=0x8947d68, feed=...) at ../../../akregator/src/feed.cpp:481
#24 0x031dc50c in Akregator::Feed::fetchCompleted (this=0x8947d68, l=0x8983f80, doc=) at ../../../akregator/src/feed.cpp:676
#25 0x031dccab in Akregator::Feed::qt_metacall (this=0x8947d68, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf87d570) at ./feed.moc:112
#26 0x04980c9a in QMetaObject::metacall (object=0x8947d68, cl=2199, idx=22, argv=0xbf87d570) at kernel/qmetaobject.cpp:237
#27 0x0498f3d5 in QMetaObject::activate (sender=0x8983f80, m=0x333a974, local_signal_index=0, argv=0xbf87d570) at kernel/qobject.cpp:3293
#28 0x033165df in Syndication::Loader::loadingComplete (this=0x8983f80, _t1=0x8983f80, _t2=..., _t3=Syndication::Success) at ./loader.moc:91
#29 0x033177e8 in Syndication::Loader::slotRetrieverDone (this=0x8983f80, data=..., success=true) at ../../syndication/loader.cpp:157
#30 0x03317c0c in Syndication::Loader::qt_metacall (this=0x8983f80, _c=QMetaObject::InvokeMetaMethod, _id=-1, _a=0xbf87d734) at ./loader.moc:79
#31 0x04980c9a in QMetaObject::metacall (object=0x8983f80, cl=2199, idx=5, argv=0xbf87d734) at kernel/qmetaobject.cpp:237
#32 0x0498f3d5 in QMetaObject::activate (sender=0x8985580, m=0x333ab58, local_signal_index=0, argv=0xbf87d734) at kernel/qobject.cpp:3293
#33 0x03319f9f in Syndication::DataRetriever::dataRetrieved (this=0x8985580, _t1=..., _t2=true) at ./dataretriever.moc:85
#34 0x0331b0b4 in Syndication::FileRetriever::slotResult (this=0x8985580, job=0x864d878) at ../../syndication/dataretriever.cpp:132
#35 0x0331b1b7 in Syndication::FileRetriever::qt_metacall (this=0x8985580, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbf87d8a8) at ./dataretriever.moc:213
#36 0x04980c9a in QMetaObject::metacall (object=0x8985580, cl=2199, idx=8, argv=0xbf87d8a8) at kernel/qmetaobject.cpp:237
#37 0x0498f3d5 in QMetaObject::activate (sender=0x864d878, m=0x18f4c88, local_signal_index=3, argv=0xbf87d8a8) at kernel/qobject.cpp:3293
#38 0x01786183 in KJob::result (this=0x864d878, _t1=0x864d878) at ./kjob.moc:194
#39 0x017864e8 in KJob::emitResult (this=0x864d878) at ../../kdecore/jobs/kjob.cpp:312
#40 0x01b20f30 in KIO::SimpleJob::slotFinished (this=0x864d878) at ../../kio/kio/job.cpp:486
#41 0x01b2196d in KIO::TransferJob::slotFinished (this=0x864d878) at ../../kio/kio/job.cpp:1058
#42 0x01b1f343 in KIO::TransferJob::qt_metacall (this=0x864d878, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbf87db3c) at ./jobclasses.moc:367
#43 0x04980c9a in QMetaObject::metacall (object=0x864d878, cl=2199, idx=47, argv=0xbf87db3c) at kernel/qmetaobject.cpp:237
#44 0x0498f3d5 in QMetaObject::activate (sender=0x898ffe0, m=0x1ccff44, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3293
#45 0x01beb707 in KIO::SlaveInterface::finished (this=0x898ffe0) at ./slaveinterface.moc:171
#46 0x01beea2d in KIO::SlaveInterface::dispatch (this=0x898ffe0, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#47 0x01bebbc3 in KIO::SlaveInterface::dispatch (this=0x898ffe0) at ../../kio/kio/slaveinterface.cpp:91
#48 0x01bdf088 in KIO::Slave::gotInput (this=0x898ffe0) at ../../kio/kio/slave.cpp:324
#49 0x01bdf293 in KIO::Slave::qt_metacall (this=0x898ffe0, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbf87de4c) at ./slave.moc:82
#50 0x04980c9a in QMetaObject::metacall (object=0x898ffe0, cl=2199, idx=30, argv=0xbf87de4c) at kernel/qmetaobject.cpp:237
#51 0x0498f3d5 in QMetaObject::activate (sender=0x872b648, m=0x1ccc820, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#52 0x01ae9bd7 in KIO::Connection::readyRead (this=0x872b648) at ./connection.moc:92
#53 0x01aebf8e in KIO::ConnectionPrivate::dequeue (this=0x892f8e0) at ../../kio/kio/connection.cpp:82
#54 0x01aec0be in KIO::Connection::qt_metacall (this=0x872b648, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x87f72f8) at ./connection.moc:79
#55 0x04980c9a in QMetaObject::metacall (object=0x872b648, cl=2199, idx=5, argv=0x87f72f8) at kernel/qmetaobject.cpp:237
#56 0x0498b336 in QMetaCallEvent::placeMetaCall (this=0x8a32c40, object=0x872b648) at kernel/qobject.cpp:561
#57 0x0498c3fe in QObject::event (this=0x872b648, e=0x8a32c40) at kernel/qobject.cpp:1248
#58 0x00d5a4dc in QApplicationPrivate::notify_helper (this=0x82f7268, receiver=0x872b648, e=0x8a32c40) at kernel/qapplication.cpp:4300
#59 0x00d6105e in QApplication::notify (this=0xbf87e784, receiver=0x872b648, e=0x8a32c40) at kernel/qapplication.cpp:3704
#60 0x00442f2a in KApplication::notify (this=0xbf87e784, receiver=0x872b648, event=0x8a32c40) at ../../kdeui/kernel/kapplication.cpp:302
#61 0x0497ba3b in QCoreApplication::notifyInternal (this=0xbf87e784, receiver=0x872b648, event=0x8a32c40) at kernel/qcoreapplication.cpp:704
#62 0x0497e473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x82d6d00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#63 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82d6d00) at kernel/qcoreapplication.cpp:1345
#64 0x0497e5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#65 0x049a7adf in QCoreApplication::sendPostedEvents (s=0x82fca90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=0x82fca90) at kernel/qeventdispatcher_glib.cpp:276
#67 0x035b75e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#68 0x035bb2d8 in ?? () from /lib/libglib-2.0.so.0
#69 0x035bb4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#70 0x049a75d5 in QEventDispatcherGlib::processEvents (this=0x82d69e0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#71 0x00e1a135 in QGuiEventDispatcherGlib::processEvents (this=0x82d69e0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x0497a059 in QEventLoop::processEvents (this=0xbf87e704, flags=) at kernel/qeventloop.cpp:149
#73 0x0497a4aa in QEventLoop::exec (this=0xbf87e704, flags=...) at kernel/qeventloop.cpp:201
#74 0x0497e69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#75 0x00d5a577 in QApplication::exec () at kernel/qapplication.cpp:3579
#76 0x0804fa61 in main (argc=5, argv=0xbf87e8e4) at ../../../akregator/src/main.cpp:103

This bug may be a duplicate of or related to bug 116482.

Possible duplicates by query: bug 244777, bug 244290, bug 241928, bug 240766, bug 230523.

Reported using DrKonqi
Comment 1 FiNeX 2010-09-12 14:52:03 UTC

*** This bug has been marked as a duplicate of bug 116482 ***